[Solved] Subtitles not moved from temp folder

I'm using XBMC for IOS on Apple TV2, v11.0-RC2.

Since I moved from SBM share to FTP share I've had some trouble getting the subtitle add-on to work properly.
I know FTP shares are considered read-only (why why why?), so I configured the add-on to use a local folder for the subtitles instead.
My sub folder: /var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/subs
The folder is configured both under Video Settings and the subtitle add-on configuration - just to be sure Tongue

The download itself to the sub_tmp folder works fine, and I've verified that the subtitle file actually end up there.
My problem is that when the subtitle is moved to my real subtitle folder, something happens - and the file is never moved - and no text is displayed.

From the log file:
12:17:44 T:134672384   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Fetching subtitles using url 'http://subscene.com/swedish/Tangled-Tangled-3D-Rapunzel/subtitle-447107-dlpath-85666/zip.zipx' with referer header 'http://subscene.com/swedish/Tangled-Tangled-3D-Rapunzel/subtitle-447107.aspx' and post parameters '__EVENTARGUMENT=&typeId=zip&__VIEWSTATE=%2FwEPDwULLTIwNzQ4MTM0OTdkGAEFEXMkbGMkYmNyJFBvc3RMaXN0D2dkPUdDJfJbAyIcFzrUmmKGlXuSZx0%3D&subtitleId=447107&filmId=85666&__EVENTTARGET=s%24lc%24bcr%24downloadLink&__PREVIOUSPAGE=z2VItJabX0fA_0Bz_zqeEkPIIbfZjSgVl-JR9gMa0h5nk--BMMlMq1WK6lo60hTdRYdlgwsXxCg89aE-PL7eLrwswmE1'
12:17:44 T:134672384   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Saving subtitles to '/var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/sub_tmp/subscene.zip'
12:17:46 T:85581824   DEBUG: GetZipList - Processing zip://%2fvar%2fmobile%2fLibrary%2fPreferences%2fXBMC%2fuserdata%2faddon%5fdata%2fscript%2exbmc%2esubtitles%2fsub%5ftmp%2fsubscene%2ezip/
12:17:47 T:134672384   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Unpacked files in '/var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/sub_tmp'
12:17:47 T:134672384   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Unpacked subtitles file 'nedivx-tangled-retail.srt'
12:17:47 T:134672384   DEBUG: ### [XBMC Subtitles-services.Subscene.service] -  Subtitles saved to '/var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/sub_tmp/subscene.zip'
12:17:47 T:134672384   DEBUG: ### [XBMC Subtitles-utilities] - vfs module copy /var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/sub_tmp/nedivx-tangled-retail.srt -> /var/mobile/Library/Preferences/XBMC/userdata/addon_data/script.xbmc.subtitles/subs/Tangled.2010.BRRip.Xvid {1337x}-Noir.sv.srt
12:17:47 T:112779264  NOTICE: Opening Subtitle stream: 0 source: 1024
12:17:47 T:112779264   ERROR: OpenStream - Unable to create subtitle parser
12:17:47 T:112779264 WARNING: OpenSubtitleStream - Unsupported stream 0. Stream disabled.

Has anyone come across this issue before, and solved it?

Best regards,

Ok, I solved it.
I found some information on the forum that xmbc is running under the 'mobile' user - why didn't I think of that before.... Blush
After changing the ownership (as this wiki post suggests, under repair settings: http://wiki.xbmc.org/index.php?title=XBM...r_settings) for the subs folder it worked fine.

chown -R mobile:mobile subs/

Thanks! =)
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[Solved] Subtitles not moved from temp folder00