•   
  • 1
  • 100
  • 101
  • 102
  • 103
  • 104(current)
Allwinner A10 : Is XBMC ported to MALI-400MP ?
(2014-03-16, 22:46)hybridmag Wrote:
(2014-03-16, 22:11)davilla Wrote: If other video players like mx player had public source code available, then we too would know all the secret sauce.

The thing is that not only mx player has hardware acceleration for allwinner..
i saw many more (like 4) that can handle this and play videos with hardware acceleration..
i will make a list of them here.. maybe one of them has a public source code available...

EDIT:
I've found this vlc build for example, the publisher wrote that its hardware accelerated vlc for allwinner a10:
https://github.com/matthiasbock/VideoLAN...er-A10-VPU

EDIT2:
I just saw this VidOn,me said they will publish their build to github:
http://forum.xbmc.org/showthread.php?tid...pid1654839

Here is their github: (updated 4 hours ago)
https://github.com/vidonme/xbmc


i hope they really show us something now...
Thanks, this XBMC fork can be built on our A10 boards?
Reply
(2014-03-14, 20:15)toketin Wrote: I've got XBMC working, the problem is that alsa sees only one Sound Devices that is Default (sunxi-CODEC sunxi PCM), while it should be sunxisndhdmi in order to get the sound working through hdmi. Here's the log file:
How can i fix this line CAESinkOSS::EnumerateDevicesEx - Failed to open mixer: /dev/mixer that it may be the cause of the missing sound? Xbmc also can't run smoothly 720p video :/

Hi Toketin,
I encounted this issue when running XBMC on my Mele A2000. It could be fixed by modifying the alsa configuration(asound.conf) so that the sound cards are ordered as you prefer but as I was in a rush I just built the hdmi audio into the kernel and had the codec as a module. I've yet to revisit this to do it correctly but it's on my to do list. If you manage to get there before me then I'll be grateful if you share your conf file.
Mucus
Reply
(2014-03-21, 09:40)mucuskipper Wrote:
(2014-03-14, 20:15)toketin Wrote: I've got XBMC working, the problem is that alsa sees only one Sound Devices that is Default (sunxi-CODEC sunxi PCM), while it should be sunxisndhdmi in order to get the sound working through hdmi. Here's the log file:
How can i fix this line CAESinkOSS::EnumerateDevicesEx - Failed to open mixer: /dev/mixer that it may be the cause of the missing sound? Xbmc also can't run smoothly 720p video :/

Hi Toketin,
I encounted this issue when running XBMC on my Mele A2000. It could be fixed by modifying the alsa configuration(asound.conf) so that the sound cards are ordered as you prefer but as I was in a rush I just built the hdmi audio into the kernel and had the codec as a module. I've yet to revisit this to do it correctly but it's on my to do list. If you manage to get there before me then I'll be grateful if you share your conf file.
Mucus

Are the HD videos working smooth for you?
Reply
(2014-03-21, 12:44)Samuelor Wrote: Are the HD videos working smooth for you?

Hi Samuelor,
nope but I haven't tried since October last year and my main concern at the time was getting spdif audio working. I'm pretty confident that it's achievable but more effort needs to be thrown into mainlining the kernel so that something like OpenElec can be used to create a working XBMC setup. Last night I tried a 720p TV rip using the latest Android.apk on my A20 board and the video didn't even start.
I'll revisit this thread again as I've not been here for a long while. It would be nice to catch up other people experiences whether good or bad.
Mucus.
Reply
(2014-03-21, 13:56)mucuskipper Wrote:
(2014-03-21, 12:44)Samuelor Wrote: Are the HD videos working smooth for you?

Hi Samuelor,
nope but I haven't tried since October last year and my main concern at the time was getting spdif audio working. I'm pretty confident that it's achievable but more effort needs to be thrown into mainlining the kernel so that something like OpenElec can be used to create a working XBMC setup. Last night I tried a 720p TV rip using the latest Android.apk on my A20 board and the video didn't even start.
I'll revisit this thread again as I've not been here for a long while. It would be nice to catch up other people experiences whether good or bad.
Mucus.

try those VidOn.me builds..
they suppose to have hardware accelaration but its crash on startup in my device...
Reply
(2014-03-21, 22:00)hybridmag Wrote:
(2014-03-21, 13:56)mucuskipper Wrote:
(2014-03-21, 12:44)Samuelor Wrote: Are the HD videos working smooth for you?

Hi Samuelor,
nope but I haven't tried since October last year and my main concern at the time was getting spdif audio working. I'm pretty confident that it's achievable but more effort needs to be thrown into mainlining the kernel so that something like OpenElec can be used to create a working XBMC setup. Last night I tried a 720p TV rip using the latest Android.apk on my A20 board and the video didn't even start.
I'll revisit this thread again as I've not been here for a long while. It would be nice to catch up other people experiences whether good or bad.
Mucus.

try those VidOn.me builds..
they suppose to have hardware accelaration but its crash on startup in my device...

I cant open any of them Sad
its just crash on startup
Reply
I can get it to run but I can't get it to show movies I get a black screen and the it freezes
Reply
(2014-03-23, 17:45)Brinis Wrote: I can get it to run but I can't get it to show movies I get a black screen and the it freezes

try older versions and tell us if they work for you...
Reply
Hello,

I recently bought a MeLe M6 chinese box in order to run XBMC at my parents'. I didn't do much research beforehand, and just figured it would pack more power than a Raspberry Pi while being more user-friendly (included a remote, since the TV doesn't support CEC) and still including the connectivity I expected (Ethernet). Details on the hardware were a bit scarce, but the product sheet did mention 1080p video, so I thought "hey, why not".

Turns out the device uses an Allwinner A20 CPU with a Mali 400-MP GPU.

I installed XBMC/Android successfully on the device while keeping the default ROM. At first, this seemed to work great, including accessing NFS shares.

Unfortunately, video playback isn't smooth; it seems HD content has no HW acceleration. Even basic 720p videos struggle to play (I get about 10fps and a complete a/v desync). What's the current state of XBMC on such a device? Anything I can do to improve it?

Thanks!

EDIT: I've had moderate "success" with one of Wololo's builds: http://makesmarttv.net/external-players-...ompromise/
Playback start smoothly even with (local) 1080p content, using the internal player. Unfortunately, it stops after 15 seconds or so. Using the internal player is quite critical to me, as this set-up in meant to be used by people who need subtitles.
Reply
For all people out here looking for a working xbmc on all allwiner cpu (a20, and a bunch of mk808, 802 is tested by myself) ...

I luckily retain one specific build of xbmc with libstageright that does work. The sad news is that good thing does not persist until any other version of xbmc (tried and test many build including gotham rc1 as well.

here is the file name if someone can goole it xbmc-20130219-32e99c7-android-hwaccel-armeabi-v7a.apk - and if no where found I can send it to anybody requested.
Reply
No CedarX acceleration till XBMC get the info they need from all winner.

Until then I am using Gotham RC1 with a XM player and smbwrapper.apk

Runs 90% of the vids with mx wrapper!!

Happy for now, that I didn't totally waste $40 on a paper weight
Reply
(2014-05-04, 18:59)Typhoonk123456 Wrote: smbwrapper.apk

Does something similar exist for NFS shares?
Reply
Hi all, i'm new here and hope this is the right 3d Tongue
I've xbmc working on A10 (cubieboard 1), but every time i try to play an audio file, xbmc crash, but don't generate a crash log (it only disappear and close the task).
The same version of xbmc has worked in past with mp3 too, and i don't understand why it crash (libmad0 is installed).
Someone has some suggestions where i can investigate?
Thanks in advance Smile
Tk
Reply
  •   
  • 1
  • 100
  • 101
  • 102
  • 103
  • 104(current)
 
Thread Rating:
  • 15 Vote(s) - 4.13 Average



Logout Mark Read Team Forum Stats Members Help
Allwinner A10 : Is XBMC ported to MALI-400MP ?4.1315