•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 63
  •   
Android -  Music Pump Kodi Remote
#46
(2012-07-14, 11:38)Millencolin007 Wrote: I just noticed that I uploaded the wrong apk yesterday, which did not yet fix the issue with JB and has a couple of other issues. You should get an update through play store in a moment. I also changed the volume decrease/increase interval from 10% to 5%.

For the thumbnails, try to clear the thumbnail cache from the music pump settings or by deleting the folder under /mnt/sdcard/Android/data/ch.berard.musicpump/cache. I have improved thumbnail resolution lately and you are probably still seeing the cached thumbnails from older versions. Also there have been a couple of changes for album thumbnails lately so low resolution may also be related to this.

Yo do not by chance automatically kill the wifi connection when the screen goes off? This would prevent the app to play the next song since it waits for a "song complete" event from xbmc to play the next song.


thanks for the update, I noticed most of the things are improving now. ..but I am noticing that the full scale artwork for albums is not loading, but the small thumbnails in the album list are, I did clear the cache and data too.. should I try manually deleting the folder?

I do have my phone set to underclock on screen off, and strangely enough the problem only seems to happen sometimes, most of the time it seems to play the next track Fine.. but when it doesn't the second I turn my screen on it goes to the next track.

thank you very much for the hasty update though

Edit: I tried rebuilding my whole music library in hopes it would improve the art situation.. but now it won't find any music at all.. I've tried everything I could think of to he it back but I'm just out of ideas now.. TV and movies parts works and looks good tho!
Reply
#47
(2012-07-14, 11:53)Millencolin007 Wrote: You can try to remove the folder /mnt/sdcard/Android/data/ch.berard.musicpump/cache manually. All thumbnails are cached in this folder. If you still get wrong/old thumbnails it is xbmc which sends some cached images.

Thanks - I think it was my data in the end - when I viewed everything through winamp, it all looked fine, but when I browsed the folders I could see all sorts of image files which were messing things up!

Quote:For performance reasons it only displays the first 1000 songs in the play queue but actually adds all songs => If you hit shuffle it will play all songs.
Perfect sense, thanks!

Quote:Didn't have time yet to implement it yet but it will come ;-)
Looking forward to it Big Grin

Quote:I am not going to change the way playlists are handled, but I may add some kind of party mode where everyone can add songs or youtube videos to the queue.
Fair enough Big Grin But a party mode would be a fab addition

Quote:Artist artwork is actually already implemented, you just need to enable it from settings ;-)

I've enabled it, but not getting anything back. Where before I can the small grey icons next to each artist, it's not blank - nothing there at all. Is it something I need to enable / setup in XBMC?

Thanks again!
Reply
#48
Quote:Edit: I tried rebuilding my whole music library in hopes it would improve the art situation.. but now it won't find any music at all.. I've tried everything I could think of to he it back but I'm just out of ideas now.. TV and movies parts works and looks good tho!

Maybe you forgot to scan the music folder to the xbmc library or maybe you are using a nightly build where music import is broken.


Quote:I've enabled it, but not getting anything back. Where before I can the small grey icons next to each artist, it's not blank - nothing there at all. Is it something I need to enable / setup in XBMC?

If you are using XBMC Eden you have to fetch artist metadata in xbmc (I think it's "query info for all artist" in the artists view on xbmc). If you are using a recent nightly build you won't see any artist images because the artistid is not returned in the AudioLibrary.getSongDetails anymore (Probably a bug in the json-rpc interface).
Reply
#49
I'm hoping it is something as simple as that.. I did reload the library entirely. I also tried a previous nightly build to no avail, but maybe since it was built with a newer version it isn't working? At any rate I checked the xbmc library with a different dlna app and everything was there.

Night lies have been flaky tho.. right now milkdrop won't rotate presents (dafuq)
Reply
#50
(2012-07-16, 20:12)skabyss Wrote: I'm hoping it is something as simple as that.. I did reload the library entirely. I also tried a previous nightly build to no avail, but maybe since it was built with a newer version it isn't working? At any rate I checked the xbmc library with a different dlna app and everything was there.

Night lies have been flaky tho.. right now milkdrop won't rotate presents (dafuq)

Did you actually have a version of the app which was working with the music library on Jelly Bean?
0.95 was the update where I forgot to include the fix for JB when clicking on the speaker icon
0.94 was the version before

I can send you your last working version so you can find out if your problem lies in your xbmc installation or if there is a problem with the latest music pump update.
Reply
#51
Okay, I had version .94 backed up and I tried a restore to give that one a shot.. I kept getting an 'out of date beta' prompt, but did manage to change all the settings.. and alas I did not connect. I know I had that version working before so the problem must lay somewhere in the way my xbmc is set-up it would seem.

I may try making a separate install to test tings more in a day or 2 here.

Thanks for the help tho!
Reply
#52
First of all let me say I really like this app and it is well-conceived.

Your approach of using a local playlist makes a lot of sense. However, now I can't use a normal IR remote control for skipping to the next song because there is always only one song in the xbmc playlist. I prefer using an IR remote for such a task as it's much faster than grabbing my phone. Any chance of transmitting the playlist on the phone to the now playing playlist on xbmc?
Reply
#53
This app is really great, but a wake on lan feature is really on my wishlist, as in the official remote app. I am also missing flac support when playing locally but i guess this is a android problem and not the app? Really good work!
Reply
#54
(2012-07-17, 00:53)marvin1985 Wrote: First of all let me say I really like this app and it is well-conceived.

Your approach of using a local playlist makes a lot of sense. However, now I can't use a normal IR remote control for skipping to the next song because there is always only one song in the xbmc playlist. I prefer using an IR remote for such a task as it's much faster than grabbing my phone. Any chance of transmitting the playlist on the phone to the now playing playlist on xbmc?

I tried a little workaround a couple of days ago where I added the next and previous song to the xbmc playlist so that you would be able to skip forward and backward but I run into some issues with xbmc so I put this idea on hold for the moment. If you have an android ICS or newer device you can use skip to the next song from the lockscreen which is relatively fast.

(2012-07-17, 08:36)sajberman Wrote: This app is really great, but a wake on lan feature is really on my wishlist, as in the official remote app. I am also missing flac support when playing locally but i guess this is a android problem and not the app? Really good work!

Wake on lan will be added sometime, its not a high priority for me at the moment. Flac is only supported on android 3.1+
Reply
#55
MillenC, wanted to give an update. I tried to load the artist list again randomly, and no songs loaded which was no surprise.. But I just put my phone down while on that screen and went to bed. When I woke up and turned it back on the list seems to have populated, although I have no idea how long that took to happen. So luckily that is working again.

Unfortunately the album art is still a bit hit or miss. I played an album from your app that showed no album art, but in YATSE (another android xbmc widget) the art seemed to have called up fine (although I am running an alpha build of it from just last weekend). I noticed I was still having issues with the next track not playing every time, but maybe pre-loading the next track items in xbmc like you mentioned could help with that!
Reply
#56
(2012-07-18, 22:29)skabyss Wrote: MillenC, wanted to give an update. I tried to load the artist list again randomly, and no songs loaded which was no surprise.. But I just put my phone down while on that screen and went to bed. When I woke up and turned it back on the list seems to have populated, although I have no idea how long that took to happen. So luckily that is working again.

Unfortunately the album art is still a bit hit or miss. I played an album from your app that showed no album art, but in YATSE (another android xbmc widget) the art seemed to have called up fine (although I am running an alpha build of it from just last weekend). I noticed I was still having issues with the next track not playing every time, but maybe pre-loading the next track items in xbmc like you mentioned could help with that!

There's a new (preferred) way to retrieve images in xbmc. I don't know if YATSE is already using this. This may explain the difference. Moreover YATSE may have cached the album art from a previous xbmc installation.

Pre-loading the next track will probably not help with your problem since I suspect that the notification connection on port 9090 gets killed during sleep, maybe because wifi turns off automatically even if I set a wake lock. Do you still see the issues with the next track if you set your wifi policy to never sleep?



Reply
#57
If you use vfs you just need to urlencode the data from json for image:// suppport no need to switch to image so support for both Frodo and Eden. (Even if a simple startwith image:// allows easy switch to image)

BTW I never posted here but I must admit I use you app for offline mode, and some times also for online, the only annoying thing is that when you disconnect from a server it seems you clear playlists or stop all that is playing.
The annoying example is : I'm playing a movie on my Xbmc, I start music pump to synchronize music for next day, close music pump and the movies stops Sad
Reply
#58
@MC Yea I did check my wifi sleep policy too and it is set to never sleep.

It seems like it happens more when I select the item from the "now playing" play list more than it would if i just long press an album and press "play" that way. I have no idea why that would be, but that seems to be what is happening for me. Also I noticed if you long-press play an album that is already playing, it will actually just skip to the next track.. This isnt so much a problem as much as potentially just unexpected behavior, figured I would mention it.

Thanks for the continued support!
Reply
#59
(2012-07-18, 23:46)Tolriq Wrote: If you use vfs you just need to urlencode the data from json for image:// suppport no need to switch to image so support for both Frodo and Eden. (Even if a simple startwith image:// allows easy switch to image)

BTW I never posted here but I must admit I use you app for offline mode, and some times also for online, the only annoying thing is that when you disconnect from a server it seems you clear playlists or stop all that is playing.
The annoying example is : I'm playing a movie on my Xbmc, I start music pump to synchronize music for next day, close music pump and the movies stops Sad

Yes I am aware of the two ways to retrieve the album art and the url encoding. I was following the json-rpc development thread. At the moment I use the additional request to xbmc with Files.PrepareDownload to get a propper url for any xbmc version. On Froyo it returns the ../image/.. url and on Eden the ../vfs/...

Indeed the automatic playback stop can be annoying in some situations, I will make it optional or remove it.

The playlist is actually hold on the device itself and every time a song is complete I get a notification from xbmc and start the next song. You will only see one song at a time in the playlist => If you stop the app music will finish playing the playlist and stop (or stop music directly when you close the app)
Reply
#60
(2012-07-19, 00:04)skabyss Wrote: @MC Yea I did check my wifi sleep policy too and it is set to never sleep.

It seems like it happens more when I select the item from the "now playing" play list more than it would if i just long press an album and press "play" that way. I have no idea why that would be, but that seems to be what is happening for me. Also I noticed if you long-press play an album that is already playing, it will actually just skip to the next track.. This isnt so much a problem as much as potentially just unexpected behavior, figured I would mention it.

Thanks for the continued support!

Doesn't make sense to me that there would be a difference depending from where you start playback. Maybe it has to do with the song length (or the duration without receiving a notification from xbmc) or bad wifi reception which drops the connection from time to time

On my devices I don't have these disconnects so it is difficult to debug. If you want you can extract the log from your device after your music stopped using a tool like "Log Collector" and send it to me. Maybe I can see from there why it doesn't play the next song.
Reply
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 63
  •   
 
Thread Rating:
  • 7 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Music Pump Kodi Remote4.437