Please note the Skinning Engine ABI will be bumped to 5.17.0 immediately after the release of v21 Omega - Beta 2. Before updating to a nightly released after Beta 2, ensure your skin has been updated by the skinner. More Info and Github PR (December 07) x
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7
Linux [xbmcbuntu] [SOLVED] some buttons not working PHILIPS MCE USB IR Receiver-Spinel plus
Can you be more precise on latency or key repeating? I don't think I observe this on my system.
(2012-08-04, 16:25)guilmxm Wrote: Hi,

I have somes troubles with the zotac remote control using Fermenta's lirc built, the remote control works but i always have some latency or key repeating, i would say it works more or less...

I tested it on fresh install on Ubuntu minimal and desktop versions, i'm sure the install is very clean, and also X11 does not register the device as a keyboard, X11 message logs:

[ 12.164] (II) config/udev: Adding input device PHILIPS MCE USB IR Receiver- Spinel plus (/dev/input/event2)
[ 12.164] (**) PHILIPS MCE USB IR Receiver- Spinel plus: Ignoring device from InputClass "PHILIPS MCE USB IR Receiver- Spinel plus"

I can even see using irw (with X11 stopped) that latency or key repeat, i also tried to uncomment suppress key in lircd.conf
min_repeat 9
suppress_repeat 9

With this setting i have less repeating key but always latency, as far an example one key sometimes works, sometimes you have to re-press the key wich will proceed in 2 keys pressed...

A little bit frustrating :-(

Thanks for your help!!!

Did you solve this?? i have the same problem on one of my Two Zotac ZBOX Nano AD10

@FernetMenta Sorry i haven't see your answer before...

In fact, i could even observe it with ipw (with X11 stopped to avoid any issue related to X11 taking the device as a keyboard)
When you press one key, it can result randomly in no action or repeated actions, sometimes quite infinite, sometimes just a few, and sometimes nothing.
The same behavior is off course observed inside XBMC

To all, i finally solved my issue by blacklisting the module "ite_cir" which is corresponding to the internal receiver module automatically loaded by the kernel, as you can see in dmesg:

[ 14.780621] ite_cir: Auto-detected model: ITE8704 CIR transceiver
[ 14.780628] ite_cir: Using model: ITE8704 CIR transceiver

After a reboot, everything is working like a charmed ! So my conclusion, is that even if lirc wasn't taking in charge signals coming from the internal receiver, this seems to generate unwanted behavior (or interferences i don't know).

You could also deactivate the internal receiver inside the UEFI, but if you do so you won't be able anymore to power on the system using the remote.

TO CONCLUDE: There is 2 more important steps to avoid any issue

1. Ensure X11 does ignore the external IR

Some updates will overwrite the /usr/share/X11/xorg.conf.d/10-evdev.conf, if overwritted X11 will also consider the device as a keyboard.

You can ensure X11 is ignoring the device in X11 log file (/var/log/X11/xorg.log) with a such message:

[ 12.164] (II) config/udev: Adding input device PHILIPS MCE USB IR Receiver- Spinel plus (/dev/input/event2)
[ 12.164] (**) PHILIPS MCE USB IR Receiver- Spinel plus: Ignoring device from InputClass "PHILIPS MCE USB IR Receiver- Spinel plus"

2. Blacklist ite_cir module to prevent the kernel to manage the internal IR

In my case (running kernel 3.2.0_26 and 27), the module "ite_cir" is automatically loaded at system boot, you can see it in kernel log:

dmesg | grep CIR

[ 14.780621] ite_cir: Auto-detected model: ITE8704 CIR transceiver
[ 14.780628] ite_cir: Using model: ITE8704 CIR transceiver

I had to blacklist it:

edit : "/etc/modprob.d/blacklist.conf" and add the line:

blacklist ite_cir

And reboot

THIS operation definitvely solves my big problem and now the remote MCE is working like a charm Cool Cool
Please support my Blog, XBMC and Linux related :-)

Hi, i thought my issue solved...but finally and unfortunately not... Confused
With settings above, i have less key repeats and delay, but still the remote does not work properly.

After a lot of new tests, i am sure now that the problem does not come from lirc and also not from Xorg but from XBMC itself !

In fact, using irw i can easily see what's happening :

- With lirc started and Xorg / XBMC stopped, i can press whatever i want, there is not key repeats or delay
- With Xorg started but XBMC stopped, same situation everything is fine
- With XBMC started, i have key delays and random keys repeats!!! Huh

That's very boring and frustrating... I tested with xbmc-xvba and xbmc-xvba-eden and having the same issue.

irw does not lie, XBMC is faulty !

Thks If you have any idea

Please support my Blog, XBMC and Linux related :-)
Can you be more precise on your observations? When executing irw is the counter steadily incremented? What happens when you run irw in parallel to XBMC? Watch the counter (irw).

I have read your tutorial. The ASIC hang is fixed in my master branch, you should not need any kernel parameters. Please revert for further tests on this topic.
Yeah that's not easy as it is quite random...

In fact, i can observe 3 situations:

- sometimes with irw i see for 1 key pressed in remote 2 new lines (no increments in counter), which results naturally in 2 actions in XBMC

0000000000070051 00 KEY_DOWN zotac.conf
0000000000070051 00 KEY_DOWN zotac.conf

- other times and randomly, one 1 key pressed you get several repeated lines, with counter increments, which results in many repeated action in XBMC

000000000007004f 00 KEY_RIGHT zotac.conf
000000000007004f 01 KEY_RIGHT zotac.conf
000000000007004f 02 KEY_RIGHT zotac.conf
000000000007004f 03 KEY_RIGHT zotac.conf
000000000007004f 04 KEY_RIGHT zotac.conf
000000000007004f 05 KEY_RIGHT zotac.conf
000000000007004f 06 KEY_RIGHT zotac.conf
000000000007004f 07 KEY_RIGHT zotac.conf

and other time, for 1 key pressed, nothing and you have to re-press until new signal...

What is very strange, it's as i said i don't observe that when XBMC is not loaded (i thought before Xorg was in fault), i can press whatever i want i always see 1 line in irw ouput...
So, when XBMC is stopped, lirc seems to work very fine, and when XBMC is loaded, it becomes to act randomly...

I go crasy with this remote control Rofl

note: ok for your remark about my tuto and ASIC hang, i'll delete this part thanks!
Please support my Blog, XBMC and Linux related :-)
some more information:

- i had strictly the same behavior on 2 different hardware (2 x zotac AD10) i've done for people

- i tested the same hardware with Openelec, Openelec automatically detects and install the internal IR, and under XBMC the remote works perfectly fine
The external IR also get detected and but you get repeated keys if you let both

Would it be possible to use the internal receiver with your conf instead of the external ?
i tried to use the internal IR with linux dev input (so standard lirc) but could never make it works.

My guess is that it is would work better with the internal IR...
Please support my Blog, XBMC and Linux related :-)
I think there is a problem in the lirc driver for this remote. I will check when back home.
I guess so Big Grin, thanks
Please support my Blog, XBMC and Linux related :-)
I find placing the receiver away from direct light removes the repeating presses.
I'm still having this problem (the repeats) even when the lights are off ...

any ideas ?

I'm about to just replace both of them (I have two AD-01s)
Check this thread:
They say that covering a good portion of the receiver with a black tape would help.

I récenty tested an all new Zotac AD11, the external IR is bad, real bad and i could never make it work as it should...

Therefore, the internal IR works really great out of the box in Openelec,
And i don't have any repeating keys.
But if i try the external even in openelec it does not work good

I would like to know who OE takes in charge the internal IR when standard kernel can't... I guess some kernel patch

Anyway, zotac external IR sucks that's a fact ;-) i think bad series...
Please support my Blog, XBMC and Linux related :-)

Hi, i'm currently trying to understand how to make the remote to work with the Internal IR, with poor success for now Huh
The thing is, as i guess you, that many people have troubles with the external IR, for others this works perfectly.
My guess is that Zotac have made bad quality series, and covering 2/3 the receiver with black tape is not really great...

So anyway, with the last Zotac AD11 i'm testing, i have the repeating issue as usual with the external, when the internal (under OpenELEC) is working perfectly fine Cool

So the question is how to make it work under standard Linux, as far as i understood OpenELEC is using eventlircd and not standard lirc, but could not find any useful documentation on it.
I tried to build eventircd based on home project page ( but failing in configure step, so no go for now...

The module "ite_cir" is loaded in both OE and Ubuntu, input devices seems equal:

cat /proc/bus/input/devices

I: Bus=0019 Vendor=1283 Product=0000 Version=0000
N: Name="ITE8713 CIR transceiver"
P: Phys=
S: Sysfs=/devices/virtual/rc/rc0/input2
U: Uniq=
H: Handlers=kbd event2
B: EV=100013
B: KEY=fff 0 200108fc32e 237605100000000 0 700158000 419200004001 8e968000000000 10000000
B: MSC=10

I: Bus=0000 Vendor=0000 Product=0000 Version=0000
N: Name="MCE IR Keyboard/Mouse (ite-cir)"
P: Phys=/input0
S: Sysfs=/devices/virtual/input/input3
U: Uniq=
H: Handlers=sysrq kbd mouse0 event3
B: EV=100017
B: KEY=30000 7 ff87207ac14057ff febeffdfffefffff fffffffffffffffe
B: REL=3
B: MSC=10

I've seen people with same IR hardware on asus getting it to work using mceusb lirc configuration, does not seem to work for Zotac devices...also tried linux input layer, no success

I also tried to use your driver (i imagine IR codes are equal with internal/external IR), and just replace with /dev/input/event2 and event3 (tried both) in lircd command line and hardware.conf... no success

Also tried to use your config and replacing udev config file with information from the ITE8713 (vendor, product) to point out to /dev/remote, no success ^^ (i guess anyway SUBSYSTEM set to usb can't be good for the internal IR)

In OpenELEC, irw receives signals, so the remote is not seen as a keyboard by Xorg, and has to be managed bur lircd/eventlircd...

To conclude, i was thinking perhaps you have an idea on how to achieve this to work out of OpenELEC ?

Thanks anyway ^^

Please support my Blog, XBMC and Linux related :-)
Hi everyone
I'm having a slight problem here. I have a zotac zbox id80 shipped with remote running xbmcbuntu.
I followed the instructions for the setup and when I run irw the remote seems to be working perfectly but once I load into xbmc I get no response with the remote. However if I go back and delete the added bit from the 10-evdev.conf file, and go back into xbmc the remote is back to its old self with some of the buttons not working.

Any ideas?

  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 7

Logout Mark Read Team Forum Stats Members Help
[xbmcbuntu] [SOLVED] some buttons not working PHILIPS MCE USB IR Receiver-Spinel plus0
This forum uses Lukasz Tkacz MyBB addons.