libstagefright - Experimental hardware video decoding builds
Hmm there is a issue Chen a AVC Blu-Ray stream .m2ts shows strange frame jumping (reorder issue) in the beginning for around 35 seconds either with H/W+ or XBMC
no frame jumps with the kSoftwareCodecsOnly path (RKPlayer,MX Player Hardware Mode, Archos Video Player). Maybe it's a parser issue i guess both player use in these modes the libav parser not yours.
Though it happens only on the first load seeking back doesn't show these frame jumps anymore.


Mpeg-2 Blu-Ray stream .m2ts still fallsback to ff-mpeg2video, is the vpu mpeg-2 decoder not accessible via libstagefright as neither mx player can use it in H/W+ mode ?

Also .m2ts and .mkv VC-1 fallback to ff-vc1

so currently only H.264 seems to work accelerated for RK3066, which at least grants most web based plugin support by now Smile

tested and work now

Vimeo 1080p
Youtube 1080p
Apple Quicktime Trailer 1080p

Lot of Apple Quicktime 1080p content tough wont work sufficient yet, especially Game content Promo Videos that use very high framerates

so most H.264 based Web Platforms should work now

Mpeg-4 Part 2 ASP 1080p 23.976 stf-mpeg4 also works though frame drop issues


Messages In This Thread
RE: libstagefright - Experimental hardware video decoding builds - by CruNcher - 2013-02-23, 19:00
libstagefright - by mo123 - 2013-05-14, 14:29
RE: libstagefright - by Koying - 2013-05-14, 14:30
RE: libstagefright - by Maverick5269 - 2013-05-16, 23:04
RE: libstagefright - by matander - 2013-05-19, 18:26
RE: libstagefright - by FreeFrag - 2013-05-22, 13:02


Logout Mark Read Team Forum Stats Members Help
libstagefright - Experimental hardware video decoding builds10
This forum uses Lukasz Tkacz MyBB addons.