•   
  • 1
  • 15
  • 16
  • 17
  • 18
  • 19(current)
[Release] Language Preference Manager
(2022-04-01, 19:07)rafikW Wrote:
(2022-04-01, 00:01)rockrider69 Wrote: @rafikW and all others interested

as per our previous discussion, I have now added to v0.1.6BETA (see link in previous post) the possibility to create easy/simplified Conditional Subtitles rules:
like 'pol:non>any:pol' or 'fre:non>eng:eng>any:fre' etc....

You can use it both via the normal 3 CondSubs rules (select Any as the audio language), or directly in the Custom Condsubs option line (see the above examples).
(Note that if not empty the Custom Condsubs line always take precedence over the 3 rules whatever they are...)

Tests sounds all good on my side, but I'll wait for some more feedback before pushing it further.

Hi,
I have checked Conditional Subtitles providing the rule: pol:non>any:pol
but it doesn't work.
....

Hi,

Thanks for testing !

have you created the exact pol:non>any:pol as a Custom Conditional Subtitle Rule at bottom od the settings ?
...looks like your 3 normal rules are still the ones activated when normally if a custom rule is created it must take precedence. Weird ...

Alternatively you can just modify the 1-2 rules as follow :
If audio language is "Polish" then display subtitles with language "None"; Forced is selected.
If audio language is "Any" then display subtitles with language "Polish"; Forced is not selected.
This should give you the same result.

If this also is not working please post a mediainfo output of the Polish/English audio movie not working.
Reply
@rafikW 
and please download again from GitHub and re-install : v0.1.6BETA
I have fixed 2 small typos while trying to understand your issue. They don't explain your problem though, but better to be on the exact same code.
Reply
hi, does this addon works for pvr?
i have many channels with subtitle language undetermined ("und") , my goal is to make kodi auto enable any subtitle , even in those cases.
Reply
(2022-04-02, 14:23)diogosena Wrote: hi, does this addon works for pvr?
i have many channels with subtitle language undetermined ("und") , my goal is to make kodi auto enable any subtitle , even in those cases.

Hi,
no it does not work at all for pvr at this stage (generating some errors I have not had time to investigate so far).

With pvr/iptv, the naming/codes of audio and subtitles streams is a bit weird so that would need more investigation just to figure if anything useful can be achieved.

For my understanding, on these channels do you manage to switch and show the 'und' subtitles manually via KODI/OSD ?
Reply
Big Grin 
(2022-04-02, 14:10)rockrider69 Wrote: @rafikW 
and please download again from GitHub and re-install : v0.1.6BETA
I have fixed 2 small typos while trying to understand your issue. They don't explain your problem though, but better to be on the exact same code.

Hi,
I don't know how it happened but I did not have in the three conditions an option "If audio language is 'Any' so I have uninstalled it together with removing settings file, installed again and now I'm able to see 'Any' so I have configured:
If audio language is "Polish" then display subtitles with language "None"; Forced is selected.
If audio language is "Any" then display subtitles with language "Polish"; Forced is not selected.
If audio language is "None" then display subtitles with language "None"; Forced is not selected.
and... it works.
Many thanks.
Just a suggestion: any change in the code should means next version number. Maybe I messed up something with 3 versions of 0.1.6BETA? Confused
Reply
(2022-04-02, 14:53)rockrider69 Wrote:
(2022-04-02, 14:23)diogosena Wrote: hi, does this addon works for pvr?
i have many channels with subtitle language undetermined ("und") , my goal is to make kodi auto enable any subtitle , even in those cases.

Hi,
no it does not work at all for pvr at this stage (generating some errors I have not had time to investigate so far).

With pvr/iptv, the naming/codes of audio and subtitles streams is a bit weird so that would need more investigation just to figure if anything useful can be achieved.

For my understanding, on these channels do you manage to switch and show the 'und' subtitles manually via KODI/OSD ?
 
Yes, this solved for me:

<?xml version='1.0' encoding='UTF-8'?>
<advancedsettings version="1.0">
    <languagecodes>
        <code>
            <short>und</short>
            <long>Portuguese (Brazil)</long>
        </code>
        <code>
            <short>por</short>
            <long>Portuguese (Brazil)</long>
        </code>
    </languagecodes>
</advancedsettings>
Reply
(2022-04-02, 15:21)rafikW Wrote:
(2022-04-02, 14:10)rockrider69 Wrote: @rafikW 
and please download again from GitHub and re-install : v0.1.6BETA
I have fixed 2 small typos while trying to understand your issue. They don't explain your problem though, but better to be on the exact same code.

....
and... it works.
Many thanks.
Just a suggestion: any change in the code should means next version number. Maybe I messed up something with 3 versions of 0.1.6BETA? Confused

Hi,
I am glad this is now working as expected, enjoy !

Valid suggestion of course about version management  Wink
On the BETA branches though I am taking some shortcuts being only one to code, still traceability is ok with commits history.
And now using Git Desktop instead of only GitHub/browser  Nerd
Reply
Hi all !

here is a new released version of this addon :  LPM v0.1.6

News are :
-Fix custom conditional preferences rules not working. (note : if ...>lan:non>... is used then forced tag is assumed on. See v0.1.3)
-Add a switch to completely ignore 'Signs and Songs' types of subtitle tracks. Default is off.
-Add special 'Any' audio language code to allow easy / simplified Conditional Subtitles rules like 'pol:non>any:pol'.
-Plus some small typo fixed

Thanks for all your help and time in testing   Smile

Enjoy!
Reply
@diogosena 

hi again,

I am unsure that remapping in such way in advanced setting is going to bring the right answer as the addon is extracting the audio and video 'language' fields from the actual movie streams.
A very quick test on a french channel with my usual pvr was not positive. Naming is wrong even for the main audio stream  Confused

I don't have any IPTV channel in my own list having 'true' subtitles tracks. Most have instead 3 audio tracks including one with 'closed caption' for impaired text additions.

If you can give one reference of your typical TV Channels with 'und' subtitles I will try to understand it works.

Not soon though as I will be out for a week or so from today  Cool
Reply
(2022-04-02, 21:40)rockrider69 Wrote: @diogosena 

hi again,

I am unsure that remapping in such way in advanced setting is going to bring the right answer as the addon is extracting the audio and video 'language' fields from the actual movie streams.
A very quick test on a french channel with my usual pvr was not positive. Naming is wrong even for the main audio stream  Confused

I don't have any IPTV channel in my own list having 'true' subtitles tracks. Most have instead 3 audio tracks including one with 'closed caption' for impaired text additions.

If you can give one reference of your typical TV Channels with 'und' subtitles I will try to understand it works.

Not soon though as I will be out for a week or so from today  Cool

The stream that comes in, has Dvbsub with languages sometimes "por" and sometimes "und" (that was the problematic one)

If i set kodi to display Portuguese subtitles, it works for "por", but not for "und"

That trick in advancedsettings made kodi understand "und" like Portuguese, and solved my problems (without needing the addon)
Reply
(2022-03-29, 20:17)rockrider69 Wrote: @clockwerk 

2. New switch in General options to completely ignore subtitle tracks named '... Signs ...'. Default is off.
    Of course you need to activate some Sub Preferences and/or Conditional Sub Preferences for this to trigger.

Let me now !

This doesn't work when the subtitle is "Default" to begin with. It doesn't ignore "Default" + "Signs"
Reply
(2022-04-20, 11:03)clockwerk Wrote: This doesn't work when the subtitle is "Default" to begin with. It doesn't ignore "Default" + "Signs"

Hello,

Can you please copy here a small extract of your kodi.log (all lines starting with [Language Preference Manager]) or even better a link to an upload of a full debug log.
Please send again the mediainfo extract of your tracks (unless it is the same as in your 03/27 post), as well as the conditional subtitle rules you have defined.

As far as I  understand the basic principle of the addon is that it completely ignore any "Default : yes" tag to rather apply the conditional rules that you have defined instead.

As an example, below is the test file I am using and it does skip the 1st French track despite it is tagged Default, and always use the 2nd one when French is the request.

Text #1
ID                                       : 5
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 2 h 4 min
Bit rate                                 : 36 b/s
Count of elements                        : 1100
Stream size                              : 33.3 KiB (0%)
Title                                    : Signs and Songs
Language                                 : French
Default                                  : Yes
Forced                                   : No

Text #2
ID                                       : 6
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 2 h 4 min
Bit rate                                 : 36 b/s
Count of elements                        : 1100
Stream size                              : 33.1 KiB (0%)
Title                                    : Français (SRT)
Language                                 : French
Default                                  : No
Forced                                   : No

Text #3
ID                                       : 7
Format                                   : UTF-8
Codec ID                                 : S_TEXT/UTF8
Codec ID/Info                            : UTF-8 Plain Text
Duration                                 : 2 h 4 min
Bit rate                                 : 32 b/s
Count of elements                        : 1128
Stream size                              : 29.7 KiB (0%)
Title                                    : English (SRT)
Language                                 : English
Default                                  : No
Forced                                   : No
Reply
(2022-04-22, 10:34)rockrider69 Wrote: conditional rules

 Fixed. Apparently "conditional rules" needs to be enabled even though most of my vids are kept at JPN audio and ENG sub.

Set it to JPN AUDIO + ENG SUB and it worked! Thanks!
Reply
Yes you need to have some Subtitle rule activated for the whole process of subtitles evaluation to trigger,
Glad it works for you as well now !
Reply
(2022-04-09, 20:41)diogosena Wrote: That trick in advancedsettings made kodi understand "und" like Portuguese, and solved my problems (without needing the addon)

Hello,

If this makes the trick I guess the easy way for you is stick to the advancesettings change.

What I can add is that if you ever do want to use other features from this addon, it should work as well together with your modified advancedsetting.
For example if you define a subtitle rule like any:por, then if no "true" por subtitles is found, but a former und (obviously remapped to por by kodi...) exists, then it should be displayed.

I have only done a simple test myself, but hopefully you can easily confirm.
Reply
  •   
  • 1
  • 15
  • 16
  • 17
  • 18
  • 19(current)



Logout Mark Read Team Forum Stats Members Help
[Release] Language Preference Manager2
This forum uses Lukasz Tkacz MyBB addons.