DSPlayer (DirectShow Player for XBMC) Frodo build available
#83
(2013-02-11, 13:19)steelman1991 Wrote: Gonna hazard a guess that they download in rar format for seeding purposes - unrar loses the ability to re-seed.

Yes, now I have remembered that some trackers and binary newsgroups use multi-volume RARs for file distribution. But this is completely unknown practice in our part of the world, so I wouldn't hold your breath for this to be fixed any time soon.

(2013-02-11, 14:14)purpleman Wrote: Roman,

In regards to subtitles:

A) dsplayer ignores preferred subtitle language settings in xbmc (always play the first subtitle stream)
B) dsplayer loads internal mkv-muxed subtitles *before* external srt ones (so if there are two muxed streams and one srt the order will be 1. muxed, 2.muxed, 3.srt).

the combination of the two results in me having to manually change subtitle language on each and every file I start to play.
the preferred behavior is that SRT subtitles load before the mkv-muxed ones (obviuously, if I bothered to put an SRT, makes sense that I'd want to display it), or at least have dsplayer honor the preferred language setting in xbmc.

Any chance to get these to the developer to be fixed?

Thank you! Smile

As for subtitle streams, as I understand, they are handled not by a DSplayer itself but by a splitter filter. Try to set up your splitter. E.g. AVsplitter allows you to select default languages for audio and subs.

(2013-02-11, 21:29)ArieS Wrote: Ok, I'm now using the final build you posted on the 1st page and I've got the same issue.
I've even tried to mess around with the sound config in Windows, changing from 24bits to 16bits. trying to uncheck the Exclusive Mode for the sound, still no luck.
From my log, I'm sure it has something to do with :
14:50:52 T:4492 ERROR: CAESinkDirectSound::UpdateCacheStatus: GetCurrentPosition failed. Unable to determine buffer status. HRESULT = 0x88780096
14:50:52 T:4492 ERROR: CSoftAE::RunOutputStage - sink error - reinit flagged

and
14:50:52 T:4492 ERROR: CAESinkDirectSound::CheckPlayStatus: Failed to play the DirectSound buffer: unknown

But I have no idea what that means so Sad Anyone has a clue?

By the way, you guys set up your audio in Windows as it says here in the sticky, right?

If this issue is specific to your system, I'm afraid there's little that can be done. The final Frodo build has been posted a while ago, and I guess there would have been mass outcry in this topic if it had had major issues.
The recent sound issues were easily reproducible and that is why they were fixed rather quickly.
Try to test different combination of sound renderers (in DSplayer and in XBMC itself, because they are independent).
Reply


Messages In This Thread
RE: DSPlayer (DirectShow Player for XBMC) Frodo build available - by Roman_V_M - 2013-02-12, 12:37
HELP!!! - by takiyon - 2014-12-28, 16:12


Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available8
This forum uses Lukasz Tkacz MyBB addons.