•   
  • 1
  • 46
  • 47
  • 48(current)
  • 49
  • 50
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
@ dreamer

1) get http streaming to work (see at the setting in tv backend and/or xbmc tvheadend plugin).
2) disable in xbmc dsplayer config "use directshow merits"
3) install newest version of lav decoder/splitter
4) make mediasconfig as describet here: http://forum.xbmc.org/showthread.php?tid...pid1557059

if this will work i will show you how to get faster switching times with other source filter/splitter.
Reply
guys I managed to run the xy-VSFilter through the interface of xbmc
now i can choose a subtitle, hide/show etc etc directly from xbmc gui
everything work ok...

now I have to put it all together (libsubs.dll and xyvsfilter.dll)

but this is not difficult just boring

(2014-03-19, 03:25)tiben20 Wrote: Even if we are not planning on merging with the main branch of xbmc can you keep the xbmc formatting convention http://forum.xbmc.org/showthread.php?tid=5238
2 spaces instead of tabs and braces the way they ask
also im not sure but CoUninitialize in DSPlayer.cpp might cause some bugs when closing many times the player i remember having some problems with initializing and uninitialize the com library in the past, but of course if there is no problem just leave it like that.

@tiben20
Now I end this thing with xvsfilter and then I promise to bring order to the code Smile

but there is alot of integration of dsplayer code and i don't think that eduard has followed this rules so much :\
Reply
That is fantastic! DSPlayer will now be perfect for me. You have no idea how happy this makes me. Big Grin
Reply
(2014-03-19, 22:19)aracnoz Wrote: guys I managed to run the xy-VSFilter through the interface of xbmc
now i can choose a subtitle, hide/show etc etc directly from xbmc gui
everything work ok...

now I have to put it all together (libsubs.dll and xyvsfilter.dll)

but this is not difficult just boring

(2014-03-19, 03:25)tiben20 Wrote: Even if we are not planning on merging with the main branch of xbmc can you keep the xbmc formatting convention http://forum.xbmc.org/showthread.php?tid=5238
2 spaces instead of tabs and braces the way they ask
also im not sure but CoUninitialize in DSPlayer.cpp might cause some bugs when closing many times the player i remember having some problems with initializing and uninitialize the com library in the past, but of course if there is no problem just leave it like that.

@tiben20
Now I end this thing with xvsfilter and then I promise to bring order to the code Smile

but there is alot of integration of dsplayer code and i don't think that eduard has followed this rules so much :\
good thing i don't have to work with the subtitle code, it took me around 60 hours to remove the atl library out of the mpc-hc code only to integrate their subtitle renderer into xbmc
Reply
(2014-03-19, 22:19)aracnoz Wrote: guys I managed to run the xy-VSFilter through the interface of xbmc
now i can choose a subtitle, hide/show etc etc directly from xbmc gui
everything work ok...

now I have to put it all together (libsubs.dll and xyvsfilter.dll)

but this is not difficult just boring

That's amazing news indeed! If it works ok ,I believe it should replace current dsplayer subtitle renderer instead of co-exist since xy-VSFilter is more matured and been developed over years.
Reply
libsubs.dll e xyvsfilter.dll work togheter now Big Grin

@oldpoem

i made this in a clean way, let me explain how work

this is my filtersconfig.xml

Code:
<!-- Subs filters -->
    <filter name="xyvsfilter" type="subs">
      <guid>{9852A670-F845-491B-9BE6-EBD841B8A613}</guid>
      <osdname>XyVSFilter Auto</osdname>
    </filter>

and this is the mediasconfig.xml

Code:
<rule filetypes="mkv|avi|mp4">
    <source filter="avsource" />
    <splitter filter="avsplitter" />
    <video filter="lavvideodec" />
    <audio filter="ffdaudiodec" />    
    <subs filter="xyvsfilter" />
    <extra>
      <extra filter="ffdshowraw" />
    </extra>    
  </rule>

when you start a mediafile if there is "<subs filter="xyvsfilter" />" in the mediasconfig.xml xbmc unload libsubs.dll and work only with the external filter
obviously if you don't put "<subs filter="xyvsfilter" />" in the mediasconfig .xml xbmc work as usuals with libsubs.dll

during playback pressing 'L' (Next Subtitle) XBMC show de dialog selector in each cases(external filter or libsubs.dll), to choose the favorite subtitle stream
Reply
i know that the old vsfilter was not able to use dxva, the xyvsfilter work with dxva??
Reply
finished

I have yet to try but I think that everything will work with the various filters for subtitles not only with xy-VSFilter

however you have to start to testing this new features as i set it to be sure that all work correctly Smile

download and install this xy-VSFilter_3.0.0.211_Installer.exe

as i said in the filtersconfigs.xml i've added this new filter


Code:
<!-- Subs filters -->
    <filter name="xyvsfilter" type="subs">
      <guid>{9852A670-F845-491B-9BE6-EBD841B8A613}</guid>
      <osdname>XyVSFilter Auto</osdname>
    </filter>

so if you wanna exclude libsubs.dll you must add the new tag <subs filter in the mediaseconfig.xml in this way

Code:
<rule filetypes="mkv|avi|mp4">
    <source filter="avsource" />
    <splitter filter="avsplitter" />
    <video filter="lavvideodec" />
    <audio filter="ffdaudiodec" />    
    <subs filter="xyvsfilter" />
  </rule>

now xbmc work as usual but with xy-vsfilter controlled by xbmc's gui


xbmc should remember the last selected subtitle, but sometime if you select a stream and in a millisecond you close the player and you restart he cannot work correctly

in this cases i think that xbmc hasn't a time to store the selected stream information into the database

so you have to wait at least some seconds after you has changed the sub Smile

obviously if you want that xbmc use the libsubs.dll you have to remove <subs filter from the mediasconfig.xml

that's all


this is the build when we have tested for good we can build a setup

XBMC_EXEONLY-test_xyvsfilter-Gotham_dsplayer.rar

night

ciauz


(2014-03-20, 03:27)tiben20 Wrote: i know that the old vsfilter was not able to use dxva, the xyvsfilter work with dxva??

yes


p.s.

can someone give me a gift and open the thread "DSPlayer (DirectShow Player for XBMC) Gotham build available" Smile?

riciauzz
Reply
someone? lol
I am not gonna do it!, That's for u to do guys who are working on this.
And btw, my compliments!!!
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
Work perfect, congratulations, but how I active dxva in dsplayer version?

Image

My video lav configuration:

Image
MediaBrazil forum Website - Youtube Channel
Aeon MQ9-0.3.0 & Ace2 Skin Team
MarcosQui Website Donate and support us.
Reply
I think that you have to select dxva2 (copy-back) with ati... I've a nvidia card and dxva with nvidia cuvid it's enabled
Reply
Thanks for tip, work now, selected dxva2-copy back (using amd ati radeon).

Image

For reference:
Image
MediaBrazil forum Website - Youtube Channel
Aeon MQ9-0.3.0 & Ace2 Skin Team
MarcosQui Website Donate and support us.
Reply
I just noticed after quite some time that i have not been running DSplayer using DXVA. I have LAV filters configured to use CUVID (I have an nVidia 660Ti) and i tried all of the other DXVA settings in LAV but i do not get DXVA showing up when I play back.

During playback, codec info shows everything loaded - LAV audio/video, FFDRaw. but is says not using DXVA. I'd be very appreciative to hear theories or suggestions why I'm not getting XBMC using DVXA.... This is for playback of normal video files, like mkv.

filters.xml
Code:
<filtersconfig>
  <filters>
    <filter name="lavvideodec" type="videodec">
        <guid>{EE30215D-164F-4A92-A4EB-9D4C13390F9F}</guid>
        <osdname>LAV Video Decoder</osdname>
    </filter>
    <filter name="lavaudiodec" type="audiodec">
        <guid>{E8E73B6B-4CB3-44A4-BE99-4F7BCB96E491}</guid>
        <osdname>LAV Audio Decoder</osdname>
    </filter>
    <filter name="avsource" type="source">
        <path>AVSplitter.ax</path>
        <guid>{D8980E15-E1F6-4916-A10F-D7EB4E9E10B8}</guid>
        <osdname>AV Source</osdname>
    </filter>
        <filter name="avsplitter" type="splitter">
        <guid>{529A00DB-0C43-4F5B-8EF2-05004CBE0C6F}</guid>
        <osdname>AV Splitter</osdname>
    </filter>
        <filter name="ffdraw" type="extra">
        <guid>{0B390488-D80F-4A68-8408-48DC199F0E97}</guid>
        <osdname>FFdshow RAW</osdname>
    </filter>
    <!-- Subs filters -->
        <filter name="xyvsfilter" type="subs">
             <guid>{9852A670-F845-491B-9BE6-EBD841B8A613}</guid>
             <osdname>XyVSFilter Auto</osdname>
       </filter>
  </filters>
</filtersconfig>

mediaconfig.xml
Code:
<mediasconfig>
  <rules>    
    <rule filetypes="ts|m2ts|bdmv|mp4|m4v|avi|mpg|mpeg|mkv">
        <source filter="lavfsplitter" />
        <splitter filter="lavf_splitter" />
        <video filter="lavvideodec" />
        <audio filter="lavaudiodec" />
        <extra filter="ffdraw" />
    </rule>

    <rule protocols="http">
            <source filter="urlsource" />
          <splitter filter="lavf_splitter" />
          <video filter="lavvideodec" />
          <audio filter="lavaudiodec" />
    </rule>
    <!-- New rule for preferred streaming source filter -->  
    <rule url="true" filetypes=".*">
          <source filter="lavfsplitter" />
    </rule>
  </rules>
</mediasconfig>
Reply
(2014-03-19, 19:24)Ed76 Wrote: @ dreamer

1) get http streaming to work (see at the setting in tv backend and/or xbmc tvheadend plugin).
2) disable in xbmc dsplayer config "use directshow merits"
3) install newest version of lav decoder/splitter
4) make mediasconfig as describet here: http://forum.xbmc.org/showthread.php?tid...pid1557059

if this will work i will show you how to get faster switching times with other source filter/splitter.

I tried this with my setup but it caused XBMC to hang.... I'm using NPVR, but not sure that would make much of a difference. Anyone else get this working?
Reply
@deh2k7

as far as i know npvr used http streaming. so livetv via dsplayer should be possible. maybe you have a formatting failure in your filterconfig and/or mediasconfig? try to play a simple mkv video via dspalyer+lav and look if this work. if you have no success with livetv post your log-files or the relevant part of the log file (after starting a livetv channel).
Reply
  •   
  • 1
  • 46
  • 47
  • 48(current)
  • 49
  • 50
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58