DSPlayer (DirectShow Player for XBMC) Frodo build available
I'm in a bit of a bind. I just purchased PlayOn+PlayLater. Both services are working fine, but I think I have conflicting arguments in my playercorefactory.

-DSPlayer is set as the default in the GUI
-PlayOn streams are apparently in MPEG2, but my mediasconfig and playercorefactory seem to bypass the rules I have in place for MPEG2.

In my playercorefactory, I have the following rules in place:

Code:
<rules action="prepend">
<rule name="streams" internetstreams="true" player="DVDPlayer" />
<rule video="true" player="MPC-HC|PotPlayer|KMPlayer|WinDVDPro|PowerDVD" />
</rules>

I don't have any defined rules for my external players since I am still playing around with them to see which one I like the best. I can open any of the 5 with the context menu no problem. My dilemma is that the something seems to be overriding my "streams" rule which causes playback to fail even though DVDPlayer shows as the default player when I hover over a a video or stream from PlayOn.

Here's my mediasconfig:
Code:
<mediasconfig>
  <rules>
   <rule filetypes="mkv|avi|mp4|h264|mpeg|mpeg2|mpeg4|daap|strm|m4v|flv|ts|mts|m2ts">
    <source filter="lavfsplitter" />
    <splitter filter="lavf_splitter" />
    <video filter="lavvideodec" />  
    <audio filter="lavaudiodec" />
    <extra>
     <extra filter="ffdraw" />
    </extra>
  </rule>
  <rule filetypes="bdmv|mpls">
   <source filter="avsource" />
   <splitter filter="avsplitter" />
   <video filter="lavvideodec" />  
   <audio filter="lavaudiodec" />
   <extra>
    <extra filter="ffdraw" />
   </extra>
   </rule>
   <rule protocols="http|https|pvr|rstp|rtmp|rtmpe">
    <splitter filter="lavf_splitter" />
    <video filter="lavvideodec" />
    <audio filter="lavaudiodec" />
    <extra filter="ffdraw" />
   </rule>
<!-- New rule for preferred streaming source filter -->  
    <rule url="true" filetypes=".*">
     <source filter="lavfsplitter" />
    </rule>
  </rules>
</mediasconfig>

It works perfectly for everything besides internet videos. When browsing my library, videos default to the DS player and there are no problems.

EDIT: I tried <rule PlayOn="true" player="DVDPlayer" /> but that set the DVDPlayer as a default for everything. The goal is to just be able to press play.

EDIT 2: Changed up my rules:
Code:
<rules action="prepend">
<rule video="true" player="MPC-HC|PotPlayer|KMPlayer|WinDVDPro|PowerDVD" />
<rule name="library" filetypes="*.strm" player="DSPlayer" />
<rule name="streams" protocols="daap|mpeg|mpeg2|h264|x264|rtv|rtsp|rtmp|http|https|rtmpe|rtsp|mms|rtp|pvr" player="DVDPlayer" />
</rules>

Now, everything plays with DSPlayer and will fall back to the DVDPlayer in the rare instance that I play a filetype that isnt covered in my mediasconfig.
Reply
 
Thread Rating:
  • 8 Vote(s) - 5 Average


Messages In This Thread
HELP!!! - by takiyon - 2014-12-28, 16:12
RE: DSPlayer (DirectShow Player for XBMC) Frodo build available - by RamboUnchained - 2015-02-09, 00:09


Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58