[RELEASE] Texture Cache Maintenance utility
(2013-10-03, 02:04)MilhouseVH Wrote:
(2013-10-02, 19:47)CaptainKen Wrote: Which command should I use to fix the backslashes? This is driving me crazy with either artwork not showing up or not updating artwork that changed.

There is no command to "fix" the backslashes - they exist in your media library and will always exist until something (not texturecache.py) removes them and replaces them with correctly formatted paths.

texturecache.py since v0.8.9 simply works around the backslash problem, automatically correcting the backslashes whenever they are encountered, but there is no attempt to permanently correct them by updating your media library. If texturecache.py is having problems processing your media library, then submit a verbose log and I'll see if there's another problem, but it shouldn't be due to backslashes (hopefully not, anyway!)

(2013-10-02, 19:47)CaptainKen Wrote: Also does your modified version of MSAA incorporate a fix?
http://forum.xbmc.org/showthread.php?tid...pid1470825

I've not modified MSAA - to the best of my knowledge it still has this backslash/forwardslash flaw. You'll need to contact Trent to obtain a fix, but I get the impression he's lost interest/moved on, so maybe it's time to fork it.

Until such time as a modified version appears, your best bet is to run MSAA only on Linux systems, then your paths will always be "correct". If you run MSAA on a Windows system, your paths (if they are network shares) will end up mangled.

Sorry, looks like I got you mixed up with mikebzh44...LOL

I also misunderstood your statement "Fix: Swap back/forward slashes on JSON artwork paths whenever a slash is used incorrectly" to mean it fixed the database.

Currently I'm having the following issues, although not all of them show up using the "C" option:
Lord of the Rings collection has no fanart or poster showing for the set
Ice Age is displaying fanart from some other movie (can't tell which though)
Home Movies has no fanart
Ocean's is showing fanart from Oceans 196, rather than the set fanart
Fast & Furious 5 won't lock into the collection even though I've confirmed the <set> tag to be correct

Besides the above I ran texturecache (with P, C, R and nc options), deleted sets, clean library, update library all numerous times before magically Cars, Shrek and a few others suddenly showed up correctly.

I ran:
- the tc "P" option
- then MSAA
- then I used the tc "C" option to create a log

Here's my tc verbose log and xbmc log.
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
 
Thread Rating:
  • 17 Vote(s) - 4.76 Average


Messages In This Thread
RE: [RELEASE] Texture Cache Maintenance utility - by CaptainKen - 2013-10-03, 07:02
Crash on Gotham on OS X - by desepticon - 2014-05-29, 17:57
Cleaning - by AleisterHH - 2018-05-28, 22:03
RE: Cleaning - by Milhouse - 2018-05-28, 22:16
qax genre not updated - by Just-Me_A-User - 2018-06-12, 22:06
RE: qax genre not updated - by Milhouse - 2018-06-12, 23:40


Logout Mark Read Team Forum Stats Members Help
[RELEASE] Texture Cache Maintenance utility4.7617