[RELEASE] Texture Cache Maintenance utility
(2013-10-03, 23:46)MilhouseVH Wrote:
(2013-10-03, 14:25)CaptainKen Wrote: While not all my sets contain set artwork, MSAA should drill down and use the first movie fanart and poster, but they do not.

Although that seems to be what MSAA did for Ocean's Collection - as it couldn't access the set fanart (as it was blocked), it drilled down and selected the fanart for one of the movies (1960's version). Try running MSAA again (preferably on a Linux box) and you'll probably find it selects the correct fanart for Ocean's Collection this time.

(2013-10-03, 14:25)CaptainKen Wrote: I'll get a verbose log Saturday as I'm running late now for airport.

OK but not sure when I became support for someone else's add-on! Wink Smile

I'm pretty sure this is not a texturecache related issue. I'm also pretty sure that caching artwork with mangled filenames is no longer a problem, so if your movie sets are not caching the correct artwork then most likely there's a problem with MSAA assigning the wrong artwork in your media library. You can see which artwork is assigned to your movie sets using "jd sets", so if MSAA has assigned incorrect artwork, that will need fixing in MSAA (or your file system, if files are blocked or don't exist).

I'll take a look at your next log - if you're running MSAA again, also include the xbmc.log too.

Update
- Adding set fanart and poster to LOR now shows the set artwork. (Odd that only some movies without set artwork would not drill down to display other artwork for the set.)
- Ocean's poster was a png file, so changed it to jpg and it now shows properly Confused
- Ice Age was a jpeg file, so changed to jpg and now shows properly Confused

I've started to compile a MSAA troubleshooting check list! If you have anything to add, have at it.

If the fanart for a set isn't showing up:
- Press the "I" Info button and Backspace to force a refresh
- Make sure the fanart and poster are jpg, not png, jpeg or any other format
- Check the file permissions
- Make sure the Read-only or Hidden file attributes are not checked
- Make sure within the file attribute window that there isn't a Security Block:
"This file came from another computer and might be blocked to help protect this computer."
- Run "texturecache.py C sets" to recache
- Run "texturecache.py jd sets > LogFilePathAndNameHere" to see what artwork is being used for the set
- Even though MSAA is supposed to drill down and use fanart and poster from a movie in the set, if none exist for the set itself, sometimes you must have actual artwork for the actual set.

THANK YOU FOR ALL YOUR HELP AND PATIENCE!

I'd like to make a contribution to your cause, please point me to where I can do this.
HTPC: Dell Optiplex 7040 Small Form Factor i7-6700 quad-core, 3.4GHz, 16GB
NAS: Synology DS1813+ and DX513, RAID 6 (29TB usable space)
My Media Center | www.CaptainKen.us | www.YouTube.com/KenInGilbert
Reply
 
Thread Rating:
  • 17 Vote(s) - 4.76 Average


Messages In This Thread
RE: [RELEASE] Texture Cache Maintenance utility - by CaptainKen - 2013-10-06, 04:55
Crash on Gotham on OS X - by desepticon - 2014-05-29, 17:57
Cleaning - by AleisterHH - 2018-05-28, 22:03
RE: Cleaning - by Milhouse - 2018-05-28, 22:16
qax genre not updated - by Just-Me_A-User - 2018-06-12, 22:06
RE: qax genre not updated - by Milhouse - 2018-06-12, 23:40


Logout Mark Read Team Forum Stats Members Help
[RELEASE] Texture Cache Maintenance utility4.7617