[RELEASE] Texture Cache Maintenance utility
I enabled logging in the texturecache.cfg, but it doesn't even start logging when using the "RunScript" method! (Running it from the windows 7 command line, however, does create a logfile.)

But maybe I now have got a hint what is going wrong: I put the code from my "test.py" into your "texturecache.py" just to find out why it isn't executed when using the "RunScript" method.

#!/usr/bin/env python
# -*- encoding: utf-8 -*-
import os, sys, platform, re, datetime, time
import socket, base64, hashlib
import threading, random
import errno, codecs
import subprocess
import tempfile

for z in range(0,3):
  sys.stdout.write("\a")
  time.sleep(3)

Result: no execution

but when "socket" is removed, it looks like this

#!/usr/bin/env python
# -*- encoding: utf-8 -*-
import os, sys, platform, re, datetime, time
import base64, hashlib
import threading, random
import errno, codecs
import subprocess
import tempfile

for z in range(0,3):
  sys.stdout.write("\a")
  time.sleep(3)

Result: it does work!!!!!!!

So I think the issue is related to the use of "import socket" under "KODI 18 for Windows", thus "texturecache.py" needs some modification to work again with the "RunScript" method.

Could you please have a look at it?

Thank you in advance!
Reply
 
Thread Rating:
  • 17 Vote(s) - 4.76 Average


Messages In This Thread
Crash on Gotham on OS X - by desepticon - 2014-05-29, 17:57
Cleaning - by AleisterHH - 2018-05-28, 22:03
RE: Cleaning - by Milhouse - 2018-05-28, 22:16
qax genre not updated - by Just-Me_A-User - 2018-06-12, 22:06
RE: qax genre not updated - by Milhouse - 2018-06-12, 23:40
RE: [RELEASE] Texture Cache Maintenance utility - by Mr.Floppy - 2018-12-13, 20:17


Logout Mark Read Team Forum Stats Members Help
[RELEASE] Texture Cache Maintenance utility4.7617