•   
  • 1
  • 29
  • 30
  • 31(current)
  • 32
  • 33
  • 57
  •   
XBMC Video Server: stream/download your library contents
Hey, firstly thanks for this great piece of software.
I got this all set up as intended, but I am trying to run the entire apache setup behind an nginx reverse proxy. The setup on the nginx side, I can do, but I would also need an ability to set a base path in the application, as my url would look something like this:

http://example.com/streaming/...

where "..." would be anything provided by apache. The application redirects to "http://example.com/..." however, making the entire thing unusable.

It would be great if you could point me in the right direction to solve this, as I tried digging through some of the yii framework configs, which resulted in a looped url on http://example.com/streaming/site/login after I tried inserting this:
PHP Code:
'request'=>array(
    
'baseUrl'=>'http://example.com/streaming'

into protected/config/main.php.

Btw, obviously example.com is not the actual url Smile
Reply
(2014-05-29, 21:44)sp8ced21 Wrote:
(2014-05-29, 21:33)Twiggz Wrote: It must be something in the way that I setup the proxy, has to be.

I left <Location /xbmc-vfs> because the readme was not detailed enough to explain what this actually is.
I inserted on both proxypass and proxyreverse http://192.168.X.X:8080/vfs
authentication "Basic Thenbase64code"

is that right??

yup absolutley spot on exactly what i have set except my ip if diff of course, maybe its the port as default is port 80 and im using a diff port might be worth a try, if you use antivirus or firewall try turn those off and see it prob goes away.

ok so to change main port in apache, here is prev post and how too as port 80 is used by alot of other services you mave conflicts which i did as my server runs services on port 80 which is why i use diff port

Just to chime in here for those trying to get this to work on a single Windows machine. For the record, I thought negge's setup instructions were very clear and spot-on; I was able to access the video server from within my network without issue. Problems arose when trying to get in from the outside.

-- You need to be running XBMC Gotham. The install instructions explain this.

-- XBMC webserver must be ON. It's under Settings, Services. Pick a port, doesn't matter much. I chose 1222.

-- Make sure you can get xbmc-video-server to work correctly by navigating to localhost/xbmc-video-server. If you can't get this far, you probably did something wrong in the install instructions. Follow them exactly.

-- If you navigate to yourip:1222 (or whatever port you picked above; remember, you need to open this port in your firewall), you will get the XBMC webserver interface. Which works great. But this interface uses your XBMC master logon credentials, and controls your main XBMC interface. That's not a problem if you are the only one wanting to control this; you can completely skip xbmc-video-server and Apache and all this other stuff if that's the case. xbmc-video-server lets you specify accounts, that can each control an instance of XBMC, that will not affect the operation of your master XBMC.

-- Moving on. In xbmc-video-server backend settings, configure your hostname as your IP address, and your port as the port you picked above.

-- Probably a good idea to not have Apache listening on port 80 (the default). That's a busy port. Pick a random port, preferably something high, like 36331. Don't go over 65500. Open this port in your firewall.

-- Go to your XAMPP install directory (for me, c:\xampp), and navigate to apache\conf. Making sure Apache is not started, Edit the "httpd.conf" file. Find "Listen 80", change to "Listen 36331" (or whatever you picked as your Apache port above). Save.

-- Go into the "extra" folder. Edit "httpd-xampp.conf". Scroll to the bottom, find the "# New XAMPP security concept" block. Delete that entire block. Save.

-- From XAMPP control panel, go to Config in upper right, then "Service and Port Settings". Change "80" to the Apache port you picked above. I'm not entirely sure this step is necessary, but can't hurt.

-- Start Apache. Confirm it is running without displayed errors.

-- Navigate to yourip:yourapacheport/xbmc-video-server/ (so, for example, http://72.191.128.186:36331/xbmc-video-server/ ), and provided you did everything above correctly, you should be in.

Hope this helps someone!



oh and i just spoted your athentication line is wrong default should be

RequestHeader set Authorization "Basic eGJtYzp4Ym1j"

Delete this block opens to a security issue, and in more it's not helpful to succeed of your measure.
Reply
(2014-05-30, 00:25)D0nR0s4 Wrote: Hey, firstly thanks for this great piece of software.
I got this all set up as intended, but I am trying to run the entire apache setup behind an nginx reverse proxy. The setup on the nginx side, I can do, but I would also need an ability to set a base path in the application, as my url would look something like this:

http://example.com/streaming/...

where "..." would be anything provided by apache. The application redirects to "http://example.com/..." however, making the entire thing unusable.

It would be great if you could point me in the right direction to solve this, as I tried digging through some of the yii framework configs, which resulted in a looped url on http://example.com/streaming/site/login after I tried inserting this:
PHP Code:
'request'=>array(
    
'baseUrl'=>'http://example.com/streaming'

into protected/config/main.php.

Btw, obviously example.com is not the actual url Smile

I'll see what I can do about this, I'll need to set up an nginx proxy so I can properly this with altered base URLs. File an issue on Github in the meantime so I don't forget it!
Reply
(2014-05-30, 09:27)negge Wrote: I'll see what I can do about this, I'll need to set up an nginx proxy so I can properly this with altered base URLs. File an issue on Github in the meantime so I don't forget it!

Thank you, I opened an issue (#135) and will look into this myself a little more as soon as I find some time Smile
Reply
negge this might be a long shot is it possible to include trailer links from IMDB into this when your viewing the movie info page where currently you display ratings and actors ect to include imdb link to the trailer ??


also is there any chance you could add a toggle in the admin so we can choose default view for Tv Show Episodes list, as i noticed although it is selectable if i clear browser defaults back to list view be nice to choose so i can have it set as default or change the default if i wish.
Reply
Quote: negge this might be a long shot is it possible to include trailer links from IMDB into this when your viewing the movie info page where currently you display ratings and actors ect to include imdb link to the trailer ??

I think the trailer URL is available through the API, but you can also just click the movie title to go to the IMDB page and watch it. You'd still have to click a link to get to see the trailer so I'm not sure what we'd gain here.

Quote:also is there any chance you could add a toggle in the admin so we can choose default view for Tv Show Episodes list, as i noticed although it is selectable if i clear browser defaults back to list view be nice to choose so i can have it set as default or change the default if i wish.

I don't think I'll be adding a setting for this. It already remembers the last display mode you set, if you clear your browsers cookies then it's "your fault" it forgets it.
Reply
I deleted the whole setup and started from scratch. When I used Galixte's idea of switching ports everything completely broke....

SO! I reinstalled xbmc-video-server and put all my ports back to default ports everywhere, I setup my proxy again, this time in backend settings I used the host computers actual hostname "ubuntu" and everything seems to work now.

I wonder if it was my videos? They were m4v format and when I encoded them I didn't check the "web optimized option".

I've started switching them to mp4 format with web optimized checked. They are at least half the size now and they seem to stream better.

Also: My internet connection is pretty fast, so I doubt that was it either.
Reply
Also, I don't think my ports were busy anyway. The xbmc-video-server runs on a machine with xbmcbuntu installed and that is the only thing installed on it. It has no GUI except for xbmc gotham. I control it from a networked PC using Putty.
Reply
(2014-06-01, 09:30)Twiggz Wrote: ... When I used Galixte's idea of switching ports everything completely broke....

...

Hi,

it's not my idea, look at the post, it's sp8ced21 who you wrote this ;=)
Reply
(2014-06-02, 21:55)Galixte Wrote:
(2014-06-01, 09:30)Twiggz Wrote: ... When I used Galixte's idea of switching ports everything completely broke....

...

Hi,

it's not my idea, look at the post, it's sp8ced21 who you wrote this ;=)

Lol, well it didn't really "completely break" but it certainly changed nothing. It wasn't the issue, is all I was reporting.
Reply
Just fixed some recently introduces issues, follow the update instructions in the README to get the latest code.
Reply
Any instructions for OpenELEC?
Reply
@zag sadly not, I had a brief look at it but there is no Apache package available in the repository (there's some unofficial stuff I haven't tried). While any web server would technically work I am not absolutely sure if the bundled PHP version is capable of running this application (mainly since it relies on the php-sqlite extension).

Meanwhile, updates:
  • fixed more recent issues
  • added WOL (Wake on LAN) support. If a backend is configured with a MAC address it will automatically be awakened if it is determined to be unconnectable. A simple waiting page is displayed while the backend is waking up and the browser automatically redirects to the Browse Movies page when the backend is back up again.
Reply
Hi all, after login i receiving this error "Fatal error: Call to a member function isConnectable() on a non-object in C:\xampp\htdocs\xbmc-video-server\src\protected\components\Controller.php on line 100"
Reply
Crap, I must have screwed something up with the last update. Thanks for reporting, I'll fix it as soon as I can.
Reply
  •   
  • 1
  • 29
  • 30
  • 31(current)
  • 32
  • 33
  • 57
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC Video Server: stream/download your library contents9
This forum uses Lukasz Tkacz MyBB addons.