Solved XBMC issues playing albums
So, for the last month or so, my XBMC box has been acting weird when it comes to music playback. Today, I decided to investigate a little.

Some, what I believe, are pertinent facts about my setup;
  • I have a dedicated XBMC box with all of the media locally stored. The only thing it streams is the occasional YouTube video.
  • This box is most often controlled through an MCE Remote I have configured for basic and advanced functions, such as refreshing both libraries with a single button press through the usage of AutoHotKey. I've had the remote for almost a year and a half, and haven't majorly tinkered with it for roughly six months.
  • My music is synced to all of my devices with AeroFS, and the XBMC Music Source is pointed at this directory. It has been configured that way for roughly six months.

What it's doing is that when you hit play on an item, it'll play that music track...and then, at the end, stop without going on to the next one. If you hit Skip Forward(Which is the button on my remote that has always played the next track while playing albums), it most often errors out with "Playlist - Can't find a next item to play". With certain tracks it'll consistently skip forward to a track much further along in an album, but pressing it again errors out on that track.

Now, if you press Skip Backwards, which has always played the previous track on an album, it'll start to skip around, and randomly play tracks from all over the album, both backwards and forwards from wherever it is, almost like it's on a shuffle setting. Pressing Skip Forward on any of these tracks causes them to immediately error out with "Playlist - Can't find a next item to play".

What I've done to attempt and fix the issue is the following;
  1. Turned it off and on again.
  2. Toggled the "Play Next Song Automatically" setting. I thought maybe it got switched for some off reason, so I turned it off, restarted XBMC, and tried it. Nope, still does it.
  3. Then I thought maybe the setting got messed up, and turning it back on would clear the issue. Turned setting on, restarted XBMC, nope, still does it.
  4. Checked my advancedsettings.xml file, to see if anything in there should impact music playback, but all it still has are my GUI and cache for streaming tweaks.
  5. Checked my keyboard.xml file to see if anything was odd there, but all it has are the settings to help autohotkey do things like refresh both libraries simultaneously, and alternate settings for the Favorites menu and playlist editing. No overlap in keys or even functionality.

I turned turned on the Debug option and recreated the issue. Log here.

I'm at a loss of what it could be. Any ideas?
I'm wondering if your music library got messed up somehow? Try using Music Files mode and open the folder for an album. Play the first track and see if it automatically advances playback to each of the subsequent tracks. This will at least let us know if there is some fundamental problem with playback or if the player simply can't locate the next item due to bad pointers (or something) in the library.

By the way, I appreciate your posting all the information and test results of your attempts to diagnose and resolve your problem.
Thanks. I'm used to being peoples' tech support, so I know how much I appreciate it when people type a small essay versus "It doesn't work. Halp."

I knew I forgot something in the post above...I also tested it in the files view. Does the same thing, but different outcomes. For instance, in library mode, one album has a track 3 that, pressing Skip Forward on will always skip it ahead to track 15. In Files view, however, it just errors out.

Also, I tried, in that album, to see if track 4 would skip ahead to track 16, and maybe the button was just skipping ahead 10+ tracks at a time and erroring out because most of my albums aren't that long. Didn't pan out, though.
Hmm, odd. Can you upload a debug log of you playing an album in Files view? Thanks.
Debug Log for File View troubleshooting

This attempt was done with the album "Beethoven's Last Night", by Trans-Siberian Orchestra. I turned on the Debug option, exited XBMC, deleted the existing log file(just to be sure), and then began.

After starting XBMC and going to the album, I first tried to play it by highlighting the album entry and pressing Play. This caused the first track to play, but pressing Skip Forward resulted in an error.

I then went into the album and selected, what I believe is, the fourth track. It began to play, I pressed Skip Forward, and it resulted in an error.

I then went down to around track 10 and played it, then pressed Skip Backwards a total of three times. It went forwards to around track 15, back to one of the first three tracks, then down to around track 7. At this point I pressed Skip Forward, and it resulted in an error.

At this point I returned to the home screen and exited XBMC.
If you are not afraid of experimenting would it be possible to try out a 13.0 Gotham monthly build so we know if this is still happening with our current code base?

Testing is safe as long as you backup your userdata (wiki) folder or don't use mysql (judging from the log you don't).

So backup your userdata (wiki) to a safe place. Install the last snapshot version retry it if it still happens.
Give feedback Wink

Going back to Frodo 12.2 is simply installing 12.2 again and putting back your userdata (wiki) you first made a backup of. And done.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Yeah, I'd be willing to. I'm not 100% certain when I'll have time, but I'll try it tonight. Do you think it'd be worth removing the current userdata folder and letting a 12.2 installation remake it, and see if the problem follows?

I took a look into the SQL database that XBMC uses, thinking that maybe it was messed up. From what I can tell, though, everything looks correct; for reference I looked up Beethoven's Last Night, since I'd tested it earlier. There isn't any corruption I can see, and the data seems correct, with the tracks in the right order and assigned to the right albums and all.
try both. keep current userdata and if that doesn't work with a fresh one. warning that the music db of Gotham is still a bit wonky atm so wouldn't recommend it for music use.
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Just a SWAG on my part, but try removing the <cachemembuffersize> entry in your advancedsettings.xml, restarting XBMC and retesting your scenario.

If that works, try adding back <cachemembuffersize>, but testing it with various smaller values.

I initially removed <cachemembuffersize> altogether, and tested it with a couple of albums. Pressing Skip Forward causes the track to advance, Skip Backwards to return to start of current track and then go back. Added it back with the same value, and the issue reappeared.

I then cut the buffer size in half, from a gigabyte to 512mb. Issue goes away. I think, rather then toy with it, I'll just keep it at half a gig. Seems like plenty. Wink

What made you think this issue was caused by the <cachemembuffersize> option?
(2013-07-31, 00:24)Igtenio Wrote: What made you think this issue was caused by the <cachemembuffersize> option?

11:04:50 T:3136   DEBUG: CFileCache::Open - opening <C:\Users\Gary\Documents\AeroFS\Music\Trans-Siberian Orchestra\Beethoven's Last Night\02 - Midnight.mp3> using cache
11:04:50 T:3136   ERROR: CFileCache::Open - failed to open cache
11:04:50 T:3136   ERROR: MP3Codec: Unable to open file C:\Users\Gary\Documents\AeroFS\Music\Trans-Siberian Orchestra\Beethoven's Last Night\02 - Midnight.mp3

And when I looked at your cache setting, I suspected your system did not have the resources for such a large cache value, so some of the songs XBMC thought were loaded into cache just ended up in the bit bucket instead. When XBMC later attempted to read those songs from cache, it couldn't find them.
Ah, I see.

Taking a look at the wiki, I also missed something when I initially set the value;

XBMC Wiki Wrote:WARNING: for the bytes set here, XBMC will consume 3x the amount of RAM

I'm not sure how I missed that, but I assumed the gigabyte I set it as would be what it consumed. I can see why it was having issues; it was setting aside three gigabytes for something I do on a rainy day.

Being as how I'm not willing to let XBMC consume 1.5 gigs of RAM just so that streaming might be okay when we do use it, I...think I should be alright setting it at only 128mb. Tongue

This might also explain why playback has been a bit choppy lately...

Thank you, artrafael, for the guess that turned out to fix it, and thank you, Martijn, for the input. I'll edit the topic title accordingly.
Thanks for this. I just encountered the same problem after setting the cache to 1024 000 000 on my system. The next day it wouldn't go to the next track! Removed the setting and it's working.

I'll try half a gig or something later.

To note, I run Windows 8.1 for Frodo 12.2 on an SSD with 8Gb of RAM... and XBMC could have 3Gb if it wanted...there is still plenty spare. Oh well!

Logout Mark Read Team Forum Stats Members Help
XBMC issues playing albums0
This forum uses Lukasz Tkacz MyBB addons.