•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 277
  •   
OpenELEC Testbuilds for RaspberryPi Part 2
#61
Is the stutter buffering (e.g significant pause of audio and video)? Or is it "micro judder" (video not synced to display vsync, and audio okay)

If the latter, enable "Adjust display refresh rate to match video"
http://wiki.xbmc.org/index.php?title=Settings/Videos
#62
Hello everyone -

I have to say, the last few months of builds (both official and Rbej's) have been great... menu is speeding up, playback is almost flawless... amazing what can be done with this $35 unit!

Thanks to everyone involved, and thanks to popcornmix for putting so much time and effort into making this a very usable media center.

Now, I do have a question... I have a group of movies that have TrueHD audio. These movies also have a secondary ACC track, but the TrueHD is track 1. If I play one of these movies, it hammers the system to a point where I cannot even get to the menu to switch the audio track... it hammers the system to a point that I cannot even stop the video from attempting to play. If the video does stop, the system usually requires a reboot to get the system responding properly again.

I know that the TrueHD audio is the problem, all other DTS files are fine... so is there a way to make XBMC ignore the TrueHD audio tracks? I would prefer to not have to remux these files to switch the audio tracks around.

Thanks.
#63
Its, the method 2 or 3:

Adjust display refresh rate to match video its "on start/stop," 24p is running on my tv!
Sync playback to video is disabled
#64
(2013-07-27, 19:59)sdsnyr94 Wrote: Now, I do have a question... I have a group of movies that have TrueHD audio. These movies also have a secondary ACC track, but the TrueHD is track 1. If I play one of these movies, it hammers the system to a point where I cannot even get to the menu to switch the audio track... it hammers the system to a point that I cannot even stop the video from attempting to play. If the video does stop, the system usually requires a reboot to get the system responding properly again.

What happens if you pause at start, wait for the pause, and then change audio track?

I'll look into treating TrueHD as unsupported.
#65
(2013-07-27, 23:51)popcornmix Wrote:
(2013-07-27, 19:59)sdsnyr94 Wrote: Now, I do have a question... I have a group of movies that have TrueHD audio. These movies also have a secondary ACC track, but the TrueHD is track 1. If I play one of these movies, it hammers the system to a point where I cannot even get to the menu to switch the audio track... it hammers the system to a point that I cannot even stop the video from attempting to play. If the video does stop, the system usually requires a reboot to get the system responding properly again.

What happens if you pause at start, wait for the pause, and then change audio track?

I'll look into treating TrueHD as unsupported.

If I do it immediately, that seems to work... but it may not be very easy for my wife to do, since she does not know which files have the TrueHD.

Maybe you could make a new entry in advancedsettings.xml such as <ignoredcodecs>TrueHD</ignoredcodecs> ?
#66
(2013-07-27, 16:26)Trickname Wrote: things to improve:
bluethoose seems to be not working

I don't miss this, since the 'official' Bluetooth implementation lacks mapping on the PS3 BD remote for the number keys (and on the Pi those are useful for seeking) and also it doesn't yet hibernate (so it kills the batteries in under a week-and-a-half!)

Instead I'm using the old PS3D remote addon with the rbej build (I use Frodo) and am much happier with it since it doesn't have those problems and works great with the PS3 BD remote.

These builds are truly awesome, rbej and popcornmix: thanks a stack!
#67
@kreeturez you know the ps3 remote keymapping was recently updated in openelec master. I think it was about a week ago
Guide to building an all in one Ubuntu Server - TV(vdr),File,Music,Web

Server Fractal Designs Define XL, Asus P5QL/EPU, Dual Core E5200, 4gb, L4M-Twin S2 v6.2, Supermicro AOC-USAS-L8I, 1*SSD & 13*HDD drives (24TB total) - Ubuntu Server
XBMC 1 ASRock Z77E-ITX, G850, 8GB RAM, SSD, BD - Ubuntu / OpenElec frodo
XBMC 2 Revo 3700 - OpenElec frodo
XBMC 3 Raspb Pi
#68
(2013-07-28, 09:39)charlie0440 Wrote: @kreeturez you know the ps3 remote keymapping was recently updated in openelec master. I think it was about a week ago

I saw that commit: but I don't recall seeing changes to the numeric keys within it: and alas, they still aren't operating in the latest test release (3.1.5) which was released afterwards. And I'm not seeing any hibernation in 3.1.5 either.
Unless your experience is different? (Maybe I'm doing it wrong, never know ;) )
#69
Hi.

Haven't been having much luck on the openelec forums, so I figured I'll try here (and excuse me if I ask something that's been asked before).
I've tried a few times to use the test builds (coming from 3.1.3), but no matter what I try, the second I try to modify something in the storage folder (namely creating and editing the advancedsettings.xml file), the raspberry pi no longer boots. I've ruled out the SD card, as I've tried three, and they all boot and run 3.1.3 just fine, but can only run an untouched 3.1.5, or test build.

I initially saw this when I tried to upgrade my system manually by copying the kernel and SYSTEM file over a known working system, and having the boot fail, so I gradually stepped back until I was at a raw system.

Any suggestions as to why modifying something on storage (using a test build) will render my PI unbootable (and I've run fsck on the sd card, and the partitions are fine).
#70
Quote: I try to modify something in the storage folder, the raspberry pi no longer boots

what tool used ?
(putty-nano, Winscp) ?

do tell system why not boot ?
#71
(2013-07-28, 12:03)lordvader Wrote: Hi.

Haven't been having much luck on the openelec forums, so I figured I'll try here (and excuse me if I ask something that's been asked before).
I've tried a few times to use the test builds (coming from 3.1.3), but no matter what I try, the second I try to modify something in the storage folder (namely creating and editing the advancedsettings.xml file), the raspberry pi no longer boots. I've ruled out the SD card, as I've tried three, and they all boot and run 3.1.3 just fine, but can only run an untouched 3.1.5, or test build.

I initially saw this when I tried to upgrade my system manually by copying the kernel and SYSTEM file over a known working system, and having the boot fail, so I gradually stepped back until I was at a raw system.

Any suggestions as to why modifying something on storage (using a test build) will render my PI unbootable (and I've run fsck on the sd card, and the partitions are fine).
Be specific about what you are modifying and the location of the file and what commands you are using to do this. Don't assume that we know exactly what you are doing because we must make assumptions which could be completely incorrect if you don't fill us in. Also include the software version you are trying to manipulate.
#72
Updated Gotham Branch

- updated firmware and kernel (3.10.3)

- updated Xbmc 13 Gotham

- updated OpenElec (switch to OpenElec 3.2 branch)

- updated newclock for OmxPlayer (DTS speed up decoding, Support both analogue and hdmi audio, Airplay, H264, MPEGTS and more)

- fixed not playing APE files

- fixed restart and shoutdown issues

http://netlir.dk/rbej/builds/

http://lysin.me/rbej



#73
thanks for the release Rbej, installing atm. What is the difference between - updated OpenElec (switch to OpenElec 3.2 branch) and the prev branch ?
#74
-Did a update from frodo to this last gotham build and no one of my h264.mkv is working anymore, only black screen after i press play.
-Reboot still not working.

Will try do do a clean install tomorrow
#75
(2013-07-29, 00:52)Jönke Wrote: -Did a update from frodo to this last gotham build and no one of my h264.mkv is working anymore, only black screen after i press play.
-Reboot still not working.

Yes, the dual audio patch causes hangs on startup when audio passthrough is enabled.
I'll investigate tomorrow.
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 277
  •   



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 223
This forum uses Lukasz Tkacz MyBB addons.