OpenELEC Testbuilds for RaspberryPi Part 2
(2013-08-25, 16:58)popcornmix Wrote: I believe that is deliberate.
There were some bugs in the dirty rectangle code meaning some display (particularly the system info) were constantly being flagged as requiring an update and so would try to update as fast as possible, resulting in high fps and 100% cpu.
With the fixes you should find the screens only update when required (i.e. at speed the controls update) and the cpu will be lower.

Yes, for me it's lower in Settings or System Info now, around 30fps and 30% CPU. However it still has the bug when moving from the left-hand category pane in Settings to the right-hand pane where the CPU goes to 89%+. For example, Settings - Videos with Library selected it's 25-30%, moving to the other pane so that "Show plot for unwatched items" is selected and it jumps to 89%. Interestingly, this doesn't happen on the Skin Settings pages, i.e Settings - Appearance - Settings where it stays below 50% whatever's selected (at least with xTV-SAF) and on Categories with fewer items in the other pane, such as Startup and Media Sources, it stays below about 35%.


Messages In This Thread
AW: RE: - by DieterLumpen - 2013-07-29, 20:50
include guires switch? - by hpbaxxter - 2013-08-01, 21:46
RE: dual audio?? - by pootler - 2013-08-03, 17:13
Help, watch 3D Film on Non 3D TV - by unix72 - 2013-08-09, 12:39
Remote Controllers - by tfft - 2013-08-14, 09:11
rbej repeatable crash - by RichG - 2013-08-19, 12:43
RE: OpenELEC Testbuilds for RaspberryPi Part 2 - by doveman2 - 2013-08-25, 17:25
New Tester - by theneverstill - 2013-10-03, 17:16