OpenELEC Testbuilds for RaspberryPi Part 2
(2013-12-07, 00:24)pennywisdom Wrote: Its strange, when I run "modprobe lirc_rpi" I can press any one button on the remote and it works. After that no commands from the remote work until a reboot and then I can again press only one button.

In the Add Your Own Remote section, "killall lircd" says that lircd isn't running at all. Then "ir-keytable -p LIRC" returns "Couldn't find any node at /sys/class/rc/rc*." When I run "irrecord /storage/.config/lircd.conf" in this section however, I can see that it is recognizing each key pressed.

Later under troubleshooting, "irw /var/run/lirc/lircd-lirc0" gives me a connection refused error.

The remotes work fine under stock OE as well as rbej's builds, Any further suggestions?

I am having trouble with lirc too but I can get it working until reboot with:

Code:
modprobe lirc_rpi
killall lircd; /usr/sbin/lircd --driver=default --device=/dev/lirc0 --uinput --output=/var/run/lirc/lircd --pidfile=/var/run/lirc/lircd-lirc0.pid /storage/.config/lircd.conf

I have tried adding this to autostart.sh but it seems as if the second line has to be run after the gui is loaded for it to work.

On these latest builds is the OpenELEC settings addon working? On mine it says the addon "is not ready, please try again later", is anyone else getting this?


Messages In This Thread
AW: RE: - by DieterLumpen - 2013-07-29, 20:50
include guires switch? - by hpbaxxter - 2013-08-01, 21:46
RE: dual audio?? - by pootler - 2013-08-03, 17:13
Help, watch 3D Film on Non 3D TV - by unix72 - 2013-08-09, 12:39
Remote Controllers - by tfft - 2013-08-14, 09:11
rbej repeatable crash - by RichG - 2013-08-19, 12:43
New Tester - by theneverstill - 2013-10-03, 17:16
RE: OpenELEC Testbuilds for RaspberryPi Part 2 - by tas* - 2013-12-07, 11:24