OpenELEC Testbuilds for RaspberryPi Part 2
(2014-04-01, 00:52)sraue Wrote: Hi all,

before we release our beta 4 soon, we need help to test the just updated kernel (3.14) which are included in this builds:
http://snapshots.openelec.tv/OpenELEC-RP...b1b.img.gz (Diskimage)
http://snapshots.openelec.tv/OpenELEC-RP...9f1b1b.tar (tarball)

please report back any issue kernel (driver) related (best compare with this builds (kernel 3.13):
http://snapshots.openelec.tv/OpenELEC-RP...47f.img.gz (Diskimage)
http://snapshots.openelec.tv/OpenELEC-RP...f4d47f.tar (tarball)

(there should not be any changes except the kernel update between the both)

Note: this builds contains not the newest patches from popcornmix, instead a almost vanilla XBMC Gotham Beta 3/4 is used with only a few backports.

Thanks much

With 3.95.1, 3.95.2 & 3.95.3, and all Millhouse builds (since 3/15, didn't try earlier), my Wi-Fi would mysteriously go up and down. As long as the slideshow screensaver wasn't running, I could "restart" the network about 50% of the time and get to it via SSH or Samba. I was running into "FIQ NYET" messages depending on FIQ configuration. Other times, I can see the WiFi reconnect multiple times via "dmesg" when I could get SSH to work. Sometimes, dmesg would be littered with "TX status timeouts." All during those times, video seemed to play OK. But once the slideshow screensaver started, it would cause the Samba and SSH connections to disconnect and not be found.

After many hours this past weekend, I settled on going to the OE Config Manager and looking at the connections refresh. What would happen is that during the refresh, the config would sometimes lose ALL the other 2.4GHz network listings except for the 5GHz connection. Whenever I could coax all the networks to appear on that screen, SSH and Samba would start working again.

Kernel 3.14 solved almost all my rPi intermitent network issues--at least that I can see in the last few hours. SSH and Samba connections are stable once again (staying connected) like it was with 3.2.4 and rBej builds. Curiously, I got only about two dozen TX status timeouts over the couple of hours. Normally, there would literally be hundreds and hundreds. Here's what the messages look like:

Code:
[ 5258.001742] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 7 in queue 2
[ 5258.002981] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 7 in queue 2
[ 5258.004252] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 7 in queue 2
[ 5258.005515] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 7 in queue 2
[ 5258.006760] ieee80211 phy0: rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 7 in queue 2


I'm now going to test kernel 3.13 for comparison...


Messages In This Thread
RE: OpenELEC Testbuilds for RaspberryPi Part 2 - by M3Rocket - 2014-04-01, 07:53
AW: RE: - by DieterLumpen - 2013-07-29, 20:50
include guires switch? - by hpbaxxter - 2013-08-01, 21:46
RE: dual audio?? - by pootler - 2013-08-03, 17:13
Help, watch 3D Film on Non 3D TV - by unix72 - 2013-08-09, 12:39
Remote Controllers - by tfft - 2013-08-14, 09:11
rbej repeatable crash - by RichG - 2013-08-19, 12:43
New Tester - by theneverstill - 2013-10-03, 17:16