•   
  • 1
  • 139
  • 140
  • 141(current)
  • 142
  • 143
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-11-27, 04:00)averylinden Wrote: The same thing is happening in the stock OpenElec beta. Does anyone have any pointers?

If it's happening in the stock OE beta you'll need to bring it to their attention - if they don't see your post here, then post on the OpenELEC forum (there's a Beta 4 thread) or post technical details - lsusb, dmesg etc. - as an issue in the OpenELEC github.

Working back through my test builds to identify the build when the break occurred would also be useful to know and might allow the OE developers to focus on a solution.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@popcornmix since version #1125, 25-Nov-2014 and #1126, 26-Nov-2014, i have the same error with the hanging DVD Menu.
(2014-11-27, 06:50)Mister XY Wrote: @popcornmix since version #1125, 25-Nov-2014 and #1126, 26-Nov-2014, i have the same error with the hanging DVD Menu.

And #1124 is still OK (not a testing fluke?)

Although it's possible the de-interlace commits changed between #1124 and #1125.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Yes, #1124 its ok.
My problem is that I'm unable to ssh into openelec Sad I'm unable to reach it through samba share either...

I was on #1123 and I was able to upgrade to #1124 by putting .tar into Update shared folder few days ago. Now, I wanted to upgrade to #1126, but no luck. I'm unable to start samba via Openelec Addon - clicking on radio-button doeasn't help since every time I exit Addon and start it again - radio-button is disabled.

I've managed to put #1126 in /storage/.update by copiing it from USB flash drive and after reboot I'm upgraded, but still have no ssh nor smb access?!?

Any pointers are welcome..
@givo: Sounds like your /storage partition might be having problems (possible corruption) - probably best to run an fsck using a Linux computer. Also, if you add textmode to cmdline.txt and plug in a keyboard you should get a console when you boot OpenELEC that will allow you to view dmesg and look around to work out why ssh isn't working.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Helix build: #1127
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.17.4 #1 PREEMPT Thu Nov 27 23:09:47 GMT 2014 armv6l GNU/Linux

# vcgencmd version
Nov 26 2014 16:23:21
Copyright (c) 2012 Broadcom
version fd43fd4d30f4e3bffbbc570a34a6ea4ae7fc2c57 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20141127230836-r19703-gf0b95eb [Build #1127]

Based on tip of OpenELEC master (f0b95ebd, changelog) and tip of XBMC master (4fbeb9ce, changelog) with the following modifications:
  • Includes newclock4 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock4
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.17.y
  • Excludes the OpenELEC xbmc-001-newclock4 patch in favour of sourcing these and possibly more recent patches directly from newclock4 branch
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Adapted service.openelec.settings to take advantage of PR:5217 [patch details]
  • Includes latest libnfs master (080d2311)
  • Includes latest libcec master (9f000e43)
  • Includes latest xbmc-pvr-addons master (14d98287)
  • Includes latest xbmc-addon-xvdr master (328fa653)
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes additional ffmpeg codecs/muxers enabled for testing/benchmarking purposes (see patch)
  • Includes commits from libcec-2.2.0 (popcornmix)
  • Includes PR:5573: webserver: improved caching control (see discussion)
  • Includes PR:5747: [database] - add setting for hiding watched movies/episodes in recently added lists
  • Includes PR:5752: [jsonrpc] Allow retrieving empty TV shows via VideoLibrary.GetTVShows.
Build Highlights:
  1. New firmware
Build Details:
  1. Firmware (Nov 26):
    • firmware: Add some upstream fixes for mmal and openmax
  2. OpenELEC:
    • [tvheadend] Updated addon version, pkg site. Removed enable-timeshift as... (PR:3649, 1 commit, 1 file changed)
    • tvheadend: bump addon (a2516e85)
    • Revert "kodi: add PR5805" (f0b95ebd)
  3. XBMC:
    • dvdplayer: fix seek behind eof (PR:5777, 1 commit, 1 file changed)
    • [pvr][fix] Return calculated value instead of 'true' in MoveChannel. (PR:5827, 1 commit, 1 file changed)
    • Revert "linux: Check for Logind first, then *Kit-s with UPower when detecting PM framework" (PR:5826, 1 commit, 1 file changed)
    • Revert "gl: multipass renderer would use wrong source pixels sizes" (PR:5830, 1 commit, 1 file changed)
    • [infomanager] container.pluginname returns an empty string (fixes #15566) (PR:5828, 1 commit, 1 file changed)
    • fix: [linux] include ffmpeg tarball in mk-debian-package.sh (PR:5829, 1 commit, 1 file changed)
    • fixup aml no video: video lost after resume (PR:5833, 1 commit, 1 file changed)
    • FIX droid on aarch64 (Nexus 9 - Tegra K1 64bits) (PR:5773, 2 commits, 3 files changed)
  4. newclock4:
    • New commits in this build:
      • [mmalcodec] squash: Avoid deinterlace for dvd menus for now (44df1269)
    • Commits no longer in build:
      • dvdplayer: demux ffmpeg - fix seeking behind eof (30904e0c)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
fsck did find and correct some errors but still no luck Sad Looks like it's going to be a fresh install for me...
(2014-11-28, 02:27)givo Wrote: fsck did find and correct some errors but still no luck Sad Looks like it's going to be a fresh install for me...

Did you try adding "textmode" to the end of your line in /flash/cmdline.txt, and look at dmesg or try to determine why ssh isn't working? It should confirm if your partition is hosed before you blow it away.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@popcornmix: I've lost GUI sounds with build #1127 - I'm seeing lots of OMX/audio related ERRORs in the log: http://sprunge.us/FhWG

The above log is a freshly started kodi.bin, waiting a couple of minutes until the system settles down, then moving from Movies to TVShows across the Home menu (01:03:07), I should hear a GUI click but there is no sound and the following errors appear in the log:

Code:
01:03:08 167.665375 T:3030381632   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
01:03:08 167.665588 T:3030381632   ERROR: CAESinkPi::AddPackets timeout
01:03:09 168.691238 T:3030381632   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
01:03:09 168.691437 T:3030381632   ERROR: CAESinkPi::AddPackets timeout
01:03:10 169.717072 T:3030381632   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
01:03:10 169.717285 T:3030381632   ERROR: CAESinkPi::AddPackets timeout
01:03:11 170.742844 T:3030381632   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
01:03:11 170.743073 T:3030381632   ERROR: CAESinkPi::AddPackets timeout
01:03:12 171.768661 T:3030381632   ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_render wait event timeout
01:03:12 171.768875 T:3030381632   ERROR: CAESinkPi::AddPackets timeout
01:03:12 171.794144 T:3030381632   ERROR: CActiveAESink::OutputSamples - failed
01:03:12 171.794342 T:3030381632   ERROR: CEngineStats::UpdateSinkDelay - inconsistency in buffer time

Also lots of errors playing back video - very stuttery, with no audio in dvdplayer (in the above log, video playback starts at 01:05:49). With omxplayer, there's audio but it's crackly and it sounds slowed down (half-speed) although video is playing back at the correct speed without stutters.

#1126 does not have this problem. Any suggestion which PR/commit to revert?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I copied the firmware from #1126 (Nov 23) to the #1127 system and the audio/video playback problems are all gone so it looks like the new Nov 26 firmware is the problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
@Milhouse i installed the latest build #1127 however tvheadend is still the old version 3.9.1847 I tried uninstalling and re-install in service but is keeps on sayiny 3.9.1847 ( from addon menu and form tvheadend web gui)
(2014-11-28, 06:11)gendo Wrote: @Milhouse i installed the latest build #1127 however tvheadend is still the old version 3.9.1847 I tried uninstalling and re-install in service but is keeps on sayiny 3.9.1847 ( from addon menu and form tvheadend web gui)

I've built and uploaded service.multimedia.tvheadend-4.3.3.zip.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-11-28, 07:13)Milhouse Wrote:
(2014-11-28, 06:11)gendo Wrote: @Milhouse i installed the latest build #1127 however tvheadend is still the old version 3.9.1847 I tried uninstalling and re-install in service but is keeps on sayiny 3.9.1847 ( from addon menu and form tvheadend web gui)

I've built and uploaded service.multimedia.tvheadend-4.3.3.zip.

Thanks
(2014-11-28, 02:42)Milhouse Wrote: Did you try adding "textmode" to the end of your line in /flash/cmdline.txt, and look at dmesg or try to determine why ssh isn't working? It should confirm if your partition is hosed before you blow it away.

Beleive it or not - don't have keyboard at home. I was surprised myself, but there are only laptops, tablets, phones, ... no PC... I'll give it a try today - once I get a hold of keyboard...
  •   
  • 1
  • 139
  • 140
  • 141(current)
  • 142
  • 143
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.