•   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-08-29, 18:57)tech242 Wrote: Anyone else experiencing problems with audio passthrough in the latest few builds?

When I play files with AC3 or DTS sound (that until about a week or two ago was successfully passed to my receiver) I now get white noise. Turning off passthrough makes file play as expected.

Here's a sample file: https://dl.dropboxusercontent.com/u/23469509/sample.mkv
Here's a debug log from when I try to play that file: http://pastebin.com/cxFP50fZ

your sample plays fine for me on 826b Newclock 4, getting passed to my VSX-922
(2014-08-29, 18:57)tech242 Wrote: Anyone else experiencing problems with audio passthrough in the latest few builds?

When I play files with AC3 or DTS sound (that until about a week or two ago was successfully passed to my receiver) I now get white noise. Turning off passthrough makes file play as expected.

Here's a sample file: https://dl.dropboxusercontent.com/u/23469509/sample.mkv
Here's a debug log from when I try to play that file: http://pastebin.com/cxFP50fZ

Are you sure you have volume at 100%? If not, the audio is not bitperfect and will not be decoded correctly by your receiver.
(2014-08-29, 21:55)Hypertown Wrote: Are you sure you have volume at 100%? If not, the audio is not bitperfect and will not be decoded correctly by your receiver.

Volume should be disabled when passthrough is active.
New OpenELEC Helix build: #0829
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.16.1 #1 PREEMPT Fri Aug 29 21:05:18 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug 27 2014 00:01:04
Copyright (c) 2012 Broadcom
version 6acafacba2a565f920610499c785831c2d5638bf (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140829210406-r19137-ga87be9d [Build #0829]

Based on tip of OpenELEC master (a87be9d1, changelog) and tip of XBMC master (8064b523, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.16.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master (5fe97d10)
  • Includes latest libcec master (81e38211)
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps (see here)
  • Includes PR5217: [python] add xbmc.abortEvent
  • Includes PR5222: videodb: Add column name on GROUP query otherwise sub query returns no rows
  • Includes PR5237: [WIP][3D] add support for stereomode switches in video playlist
  • Includes PR5244: [UX] keymap fixes - don't overload pause action with something else
  • Includes PR5245: [UX] consistent playback behavior for music and video
  • Includes PR5247: StringUtils: optimize Split(), new overloads for Split() and Tokenize()
  • Includes PR5273: [Fix] When changing subtitles the cached overlays must be cleared.
Build Highlights:
  1. newclock3-based build.
  2. BD+ support added
Build Details:
  1. OpenELEC:
    • bluez: update to bluez-5.22
    • projects/Cuboxi/options: add support for Hummingboard-IMX6Q
    • CuboxI: u-boot: sync with commit a06fada (supporting Hummingboard)
    • projects/*/options: add option to select AACS support
    • new package: add package 'libbdplus'
    • projects/Cuboxi/linux: sync kernel config with other projects
  2. XBMC:
    • fixed: don't hop to first item in list on deleting another one (PR:5291, 1 commit, 1 file changed)
    • [jenkins/win32] - speed up compilation by activating parallel builds (PR:5293, 2 commits, 4 files changed)
    • ffmpeg: fix failing filter caused by invalid time_base.num or aspect_rat... (PR:5300, 1 commit, 1 file changed)
    • AESinkALSA: Fix S24NE4MSB incorrectly reported as S24NE4 (PR:5297, 1 commit, 1 file changed)
  3. kernel 3.16.y:
    • bcm2708_fb : Implement blanking support using the mailbox property interface
    • Merge pull request #673 from trevd/rpi-3.16-fb
  4. Custom
    • Added: PR5273 - When changing subtitles the cached overlays must be cleared.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Edit: Looks like I botched this build of #0829b by using newclock3 patches... currently working on an update (#0829c)

Experimental newclock4 build uploaded: #0829c

Same as build #0829, but with newclock4 patches in place of newclock3. See here for details.

newclock4 additions since previous build #0826b:
  • omxrender: Hacks to reduce GUI rendering rate when playing video
  • omxcodec: experimental: enable deinterlace
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
If you downloaded #0829b, which should have been a newclock4 build but *ahem* wasn't, please download #0829c (link above) as its replacement.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I am still experiencing that the main menu items switch orders while scanning the library. After the library scan is over, this stops. This was not an issue with the Gotham builds, but happens since switching to Helix.

On separate note - some movies are not being picked up at library scan, but instead only when I click "scan for new content". Any ideas?

Thanks for your help and constant development!
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Hello i have the same Problem with AC3, DVD Player and Passthrough, since Version #0821 i did not hear anything when im using dvd player with ac3 sound.
With OMXplayer i have sound when i play an DVD Iso with ac3 sound and passthrough, but with DVDplayer, i have no sound when im playing dvd iso with ac3 sound and passthrough
Here is my log.
http://pastebin.com/wt0dzjSG
(2014-08-29, 19:04)popcornmix Wrote:
(2014-08-29, 18:57)tech242 Wrote: Anyone else experiencing problems with audio passthrough in the latest few builds?

Can you confirm that you are using a newclock3 build and playing with dvdplayer (rather than omxplayer)?

Does disabling "adjust display refresh rate to match video framerate" make any difference?
Can you identify the first build where this problem started occurring?

Using #0827 downloaded from this thread with dvdplayer set as defaultplayer and defaultdvdplayer in advancedsettings,xml.

Disabling "Adjust display refresh rate" doesn't seem to make a difference.

I THINK the problem first started in the early #0820s (#0822 perhaps?), but then again I haven't updated daily.
(2014-08-30, 10:21)tech242 Wrote: I THINK the problem first started in the early #0820s (#0822 perhaps?), but then again I haven't updated daily.

It would be useful if you can revert to an earlier version and identify the first version with the problem.
(2014-08-30, 12:14)popcornmix Wrote:
(2014-08-30, 10:21)tech242 Wrote: I THINK the problem first started in the early #0820s (#0822 perhaps?), but then again I haven't updated daily.

It would be useful if you can revert to an earlier version and identify the first version with the problem.

0820 works.
0821, 0822, and 0827 do not.
@Mister XY and @tech242

Thanks for info. I have an idea about the problem. Can you try this test build:
https://dl.dropboxusercontent.com/u/3669...hrough.elf

rename your existing start.elf, and rename this file to start.elf.
Note: this is a fixed 256M/256M memory split test build. Will only work on a 512M pi, and gpu_mem will be ignored.
(2014-08-30, 13:24)popcornmix Wrote: @Mister XY and @tech242

Thanks for info. I have an idea about the problem. Can you try this test build:
https://dl.dropboxusercontent.com/u/3669...hrough.elf

Updated to 0829, didn't work.
Replaced start.elf with test build, WORKS! Seems you nailed it. Smile
I have done it and now i have a passthrough with dvdplayer.
@Mister XY and @tech242

Thanks for quick testing. This fix will be in next official firmware update (maybe tonight), and should be in milhouse builds after that.
  •   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888