•   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
With New OpenELEC Helix build: #0727 I'm getting a stick pixel rainbow (little box that seems like the rainbow pixel startup) on top corner right in the hour numbers.
Is this a known problem?
(2014-07-29, 14:15)Mafarricos Wrote: With New OpenELEC Helix build: #0727 I'm getting a stick pixel rainbow (little box that seems like the rainbow pixel startup) on top corner right in the hour numbers.
Is this a known problem?

under-voltage indicator. It's in the release notes of build #0724.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I passed from 14 jun release to this one. I will check what you told there to see how to deactivate it. Thanks.
(2014-07-29, 11:19)slack3r Wrote:
Quote:When I press ENTER on my remote in the Gateway field the IP address dialog box appears, but you're saying when you press ENTER nothing happens - no response?
I don't know how to say it in English, but pressing Enter I'm get back to 'IPV4' item on left column. Nothing else happens.

After much bisecting, the Gateway dialog bug is caused by PR4987, specifically [stdstring] get rid of CStdString in dialogs - somewhere in this patch is the problem, presumably the network dialog behaviour is now either a little broken, or changed (with respect to blank/null fields). It's a big patch, and as I'm not a C++ coder I won't be digging any deeper!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-29, 15:22)Milhouse Wrote: After much bisecting, the Gateway dialog bug is caused by PR4987, specifically [stdstring] get rid of CStdString in dialogs - somewhere in this patch is the problem, presumably the network dialog behaviour is now either a little broken, or changed (with respect to blank/null fields). It's a big patch, and as I'm not a C++ coder I won't be digging any deeper!

Ok, thank you so.

The final question: have you the same issue with DNS dialog?
(2014-07-29, 16:31)slack3r Wrote: Ok, thank you so.

The final question: have you the same issue with DNS dialog?

Yes, it's the same problem - when the DNS field is not blank the IP address dialog will appear, but when the field is blank the IP address dialog fails to appear.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-28, 07:48)delinend Wrote:
(2014-07-27, 21:14)delinend Wrote:
(2014-07-27, 20:01)Milhouse Wrote: Is this a 256MB or 512MB Pi? The default <cachemembuffersize> is now 2MB on 256MB Pis, and 20MB on 512MB Pis.

Is the FTP-buffering behaviour the same with omxplayer and dvdplayer?

Can you go back through older builds until you find a version which doesn't buffer over FTP? Do you get the same behaviour with stock builds?

It's a 512MB Pi running 1GHz.
I only use omplayer, as it only runs for all my contet.
I'll try older versions tomorow, but it's a new thing, that I was trying to play Blu-ray via FTP. Have not tryed it before. Only used FTP to playback SD, until yet.
But it look strange that the FTP protocol use 50% more CPU than the SMB.
I have allso tryed to test my FTP server localy, at I can pull 10 times more bandwith from it, than the Pi playback via FTP use. So it's not my FTP server that have a problem.

I have allso tryed to set cachemembuffering to 50MB, but no luck. Still 98-100% CPU load on Blu-ray playback.

I have just tryed Gotham (openELEC 4.0.7) and last build #0727, and both have the same issue when using the FTP protocol connector.

When I Playback Blu-ray via FTP the CPU load is 98-100% and the video stop/start each 50-60 sec.
When i Playback Blu-ray via SMB the CPU load is 50-70% and playback works fine.

It's the same CPU load with dvdplayer and omxplayer. But I see, that dvdplayer use much more memory, when I playback.

It look like there is some issue whith the FTP protocol, that takes too much CPU time.

Here my Overclock:
arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6

Here my advancedsettings.xml :
<advancedsettings>
<video>
<defaultplayer>omxplayer</defaultplayer>
<defaultdvdplayer>omxplayer</defaultdvdplayer>
</video>

<ftp>
<remotethumbs>true</remotethumbs>
</ftp>
</advancedsettings>

Best regards

Anyone that have an idea, how I trace this issue down ?

Best regards.
(2014-07-29, 21:12)delinend Wrote: Anyone that have an idea, how I trace this issue down ?

Best regards.

To be honest I've no idea. In theory FTP should be fairly efficient but clearly there's a problem with the code, at least with your particular setup. Has it always been like this? Try going back through the old builds.

As this excessive FTP loading affects both stock and custom OpenELEC builds it would seem to be a core issue and you might be better off asking in a more general thread that may attract the attention of a developer with knowledge of the FTP code.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-07-22, 17:59)Milhouse Wrote:
(2014-07-22, 17:55)Heiko123 Wrote: Ohhh with one of the latest builds, I can't play all h264 files. Huh

It is now the same problem how in raspbmc!

Is it possible to change the codec?

Which build works/doesn't work? What file - need mediainfo, a sample file or debug log (wiki).

Try increasing GPU mem (128 on a 256MB Pi, 256 on a 512MB Pi) and see if that helps.

Hello,

With the new version, I have got the same problem within h264 videos (video-cache is setted 265MB).
I'm back to pre-version and all is good.

Can you look to this problem, please.
(2014-07-30, 06:54)Heiko123 Wrote: Hello,

With the new version, I have got the same problem within h264 videos (video-cache is setted 265MB).
I'm back to pre-version and all is good.

Can you look to this problem, please.

Not a chance, not without more concrete information.

It's still not clear which version works/doesn't work - try being precise, like actually stating the build numbers.

You also haven't submitted a debug log, or any sample media with which to reproduce the problem, as previously requested.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
This is an old error......

Buzzy sound when chapter change/shift, on playback of MPEG2/ISO videos.
It's not alltime, but offen 3-6 times, on one movie playback with 10-15 chapters.

I don't know if this is the right thread, to post the error....

I hear the Buzzy sound on:
Last Helix.
Gotham 13.2 (openELEC 4.0.7).
And also on Windows 7 XBMC 14.0 GIT 20140721 !?!?!

Same problem with omxplayer and dvdplayer.

But if I playback the ISO via VLC (on a Win7), there is NO Buzzy sound, on chapter change.

Btw. I have a small ISO (1 min.) with 2 chapters, where the Buzzy sound is to hear.

Best regards.
(2014-07-30, 15:59)delinend Wrote: This is an old error......

Buzzy sound when chapter change/shift, on playback of MPEG2/ISO videos.
It's not alltime, but offen 3-6 times, on one movie playback with 10-15 chapters.

I don't know if this is the right thread, to post the error....

I hear the Buzzy sound on:
Last Helix.
Gotham 13.2 (openELEC 4.0.7).
And also on Windows 7 XBMC 14.0 GIT 20140721 !?!?!

Same problem with omxplayer and dvdplayer.

But if I playback the ISO via VLC (on a Win7), there is NO Buzzy sound, on chapter change.

Btw. I have a small ISO (1 min.) with 2 chapters, where the Buzzy sound is to hear.

Best regards.
not the right thread. start a new one
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
(2014-07-30, 15:59)delinend Wrote: I hear the Buzzy sound on:
Last Helix.
Gotham 13.2 (openELEC 4.0.7).
And also on Windows 7 XBMC 14.0 GIT 20140721 !?!?!

As Martijn says, if it affects multilple platforms then post it in a generic (not pi-specific) thread where more devs will see.
You'd may as well get a debug log file ready as that will be the first question.
Providing the sample that produces will let others report if they see the same issue.
(2014-07-30, 16:24)popcornmix Wrote:
(2014-07-30, 15:59)delinend Wrote: I hear the Buzzy sound on:
Last Helix.
Gotham 13.2 (openELEC 4.0.7).
And also on Windows 7 XBMC 14.0 GIT 20140721 !?!?!

As Martijn says, if it affects multilple platforms then post it in a generic (not pi-specific) thread where more devs will see.
You'd may as well get a debug log file ready as that will be the first question.
Providing the sample that produces will let others report if they see the same issue.

Thanks popcornmix.

I have now done that :-)

Best regards
New OpenELEC Helix build: #0801
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 3.15.8 #1 PREEMPT Fri Aug 1 20:03:41 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug  1 2014 18:05:07
Copyright (c) 2012 Broadcom
version 158db03216ab9f49243655d4d325da3264567104 (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140801200228-r18864-gc01f799

Based on tip of OpenELEC master (c01f799, changelog) and tip of XBMC master (219d0e1, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.15.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master
  • Includes latest libcec master
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps
  • Includes PR4990: Allow larger font size
Build Highlights:
  1. New firmware with GPIO fix for Hyperion/Lightberry.
  2. New kernel 3.15.8 (from 3.15.y branch, as OpenELEC yet to merge 3.15.8)
  3. zram support dropped, as nobody is pushing for this upstream.
Build Details:
  1. Firmware (Aug 1):
    • firmware: arm_display: Fix size of warning with lower resolutions. See: link
    • firmware: gpioman: Add ability to set PLLs and gpio clocks
    • firmware: arbiter: Increase HVS priority to 12. See: link
    • firmware: gpioman: Add drive strengths to force gpio bank0 to 8mA (as it was before gpioman). See: link
    • firmware: OV5647 tuner. Avoid a global pointer for tuning config.
    • firmware: Add basic flash driver just using two GPIOs.See: link
    • firmware: Add MMAL parameters for disabling stills and video denoise algos. See: link
    • firmware: mmal: Support omx flag OMX_BUFFERFLAG_DECODEONLY
  2. OpenELEC:
    • xbmc: add PR5107
    • libdrm: update to libdrm-2.4.56
    • ffmpeg: update to ffmpeg-2.3.1
  3. XBMC:
    • [pvr] recover lost functionality for menu hooks and find similar programs (PR:5097, 2 commits, 4 files changed)
    • [pvr] some fixes and cleanups after window rewrite (PR:5102, 2 commits, 5 files changed)
    • ffmpeg: fix deadlock caused by calling avctx->thread_count after codec_o... (PR:5101, 1 commit, 2 files changed)
    • [confluence] fix wrong control id in element 'onleft' of scrollbar control in pvr timer and search window (PR:5116, 1 commit, 2 files changed)
    • [pvr] fix hiding the "go to parent directory" item in the root of the recordings list (PR:5118, 1 commit, 1 file changed)
    • [pvr] fix the path split-up in CPVRTimers::GetDirectory() which results in no timer is returned (PR:5120, 1 commit, 1 file changed)
    • [linux] Make checking for command existence more consistent and POSIX compatible (PR:5085, 1 commit, 1 file changed)
    • [PiSink] Improvements to reduce chances of underrun (PR:5089, 2 commits, 1 file changed)
    • [omxplayer] Explictly choose deinterlace method for 1080i (PR:5092, 1 commit, 1 file changed)
    • [pvr] bump add-ons (PR:5119, 1 commit, 2 files changed)
    • fix: Temperature unit alignment (PR:5043, 1 commit, 1 file changed)
    • [release] bump to 14.0 alpha2 (PR:5117, 1 commit, 1 file changed)
    • cmake: common addons depends buildsystem (PR:5014, 11 commits, 36 files changed)
    • [addons] sync with repo
    • [pvr] fix hiding the "go to parent directory" item in the root of the
    • [win32] fix custom build tool output of version.txt to include XBMC_PC.rc
    • binary addons: update README
  4. kernel 3.15.y:
    • spi: bcm2708: add device tree support
    • BCM2708: don't register SPI controller when using DT
    • spi: bcm2835: make driver available on ARCH_BCM2708
    • i2c: bcm2708: add device tree support
    • bcm2708: don't register i2c controllers when using DT
    • i2c: bcm2835: make driver available on ARCH_BCM2708
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 53
  • 54
  • 55(current)
  • 56
  • 57
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888