•   
  • 1
  • 64
  • 65
  • 66(current)
  • 67
  • 68
  • 156
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
Below the log file. I may be too impatient. Let me let it "sit" overnight and see whether it eventually work out.

https://www.paste.to/DKswLCG
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Yes, give it some time - it's got a few databases to update - it will need to upgrade the video database in sequence from v78 to 79 to 85 to 86 to 87 to 88 and finally to 89...

Once it finishes, check the log carefully for errors!
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Thanks for the last builds. Videos are working great for me on r18930.
Now my only problem is with airplay. It's very unstable.
I use it with an iphone on iOS 7.1.2
It often works the first time when i boot my Pi.
But the it gets quite messy. For example right now if i connect to AirPlay (and play as this is what actually starts the stream) then i see on my phone that it is connecting but it disconnects after a few seconds.
My main problem is actually that i don't see any log related to Airplay . I have set the debug log level in my advancesettings
Code:
<loglevel hide="true">2</loglevel>
Am i missing something, or isn't there any airplay log?

I also should mention that i have tried with and without:
Code:
<audio>
     <defaultplayer>omxplayer</defaultplayer>
</audio>

UPDATE: i just thought of something, why not get the log from my phone!
Code:
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164540 wlan.N[1293] IO80211AWDLPeerManager::configureStrategy() AirPlay services:2, others:0 schedstate:Minimum insertInfraForAirplay(1), _useInfraOnSocialTimeslots(1), _setMasterChannelToInfra(1), dynamic_off(1)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164605 wlan.N[1294] awdl-interfaceStateChange: Channel 36 is not allowed in this locale; default allowed channel 6
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164634 wlan.N[1295] awdl-interfaceStateChange: [reason: Mdns] ENABLE-AWDL  (state 0x5 CONFIGURED QUIET _syncState 1 numservices 3 (valid 2) valid_infra 1 cur_infra_channel 36 awdl_solo 0 _mdns_trigger 1 AwdlStateMachine)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164679 wlan.N[1296] awdl-interfaceStateChange get infra channel valid 1 infraChannel 36 flags 20 _stateFlags 5 strategy 1 masterChannel 36/0 syncConfigured channelConfigured
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164831 wlan.A[1297] AppleBCMWLANProximityInterface::setSYNC_ENABLED(): set AWDL->ON pm 8 minExt 7 MasterChan 36/0 step 7 [36 36 36 36]
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164854 wlan.A[1298] AppleBCMWLANProximityInterface::doSetSyncState(): Cancelled fAWDLOffTimer
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.164946 wlan.N[1299] awdl-interfaceStateChange did enable state 3
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167752 wlan.N[1300] IO80211AWDLPeerManager::updateLocalRequests() Added Advertising Service
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167830 wlan.N[1301] IO80211AWDLPeerManager::configureStrategy() AirPlay services:2, others:0 schedstate:MinimumFast insertInfraForAirplay(1), _useInfraOnSocialTimeslots(1), _setMasterChannelToInfra(1), dynamic_off(1)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167884 wlan.N[1302] awdl-interfaceStateChange: Channel 36 is not allowed in this locale; default allowed channel 6
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167912 wlan.N[1303] awdl-interfaceStateChange: [reason: Mdns] ENABLE-AWDL  (state 0x3 CONFIGURED SYNC-ACTIVE _syncState 1 numservices 3 (valid 2) valid_infra 1 cur_infra_channel 36 awdl_solo 0 _mdns_trigger 1 AwdlStateMachine)
Aug 15 18:40:55 mguillon-iPhone kernel[0] <Debug>: 104263.167954 wlan.N[1304] awdl-interfaceStateChange get infra channel valid 1 infraChannel 36 flags 20 _stateFlags 3 strategy 1 masterChannel 36/0 syncConfigured !channelConfigured
Aug 15 18:40:59 mguillon-iPhone kernel[0] <Debug>: AppleH6CamIn::setPowerStateGated: 0
Aug 15 18:40:59 mguillon-iPhone kernel[0] <Debug>: AppleH6CamIn::power_off_hardware
Aug 15 18:41:01 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:01.311830 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:03 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:03.355202 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:05 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:05.398542 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:05 mguillon-iPhone kernel[0] <Debug>: 104273.229386 wlan.A[1305] AppleBCMWLANProximityInterface::setSYNC_ENABLED(): set AWDL->OFF
Aug 15 18:41:07 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:07.441886 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:09 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:09.485273 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:11 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:11.528664 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:13 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:13.571982 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:15 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:15.615331 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:17 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:17.658704 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:19 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:19.702045 PM [AirPlay] ### Audio buffer full for get: 4096 > 0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356219 PM [AirPlay] ### Endpoint "XBMC (OpenELEC)" options error: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356604 PM [AirPlay] Start summary: TP=WiFi E=RSA L=2000 ms Bonjour=5 ms Connect=4 ms Auth=0 ms Ann=0 ms Setup=0 ms Rec=0 ms Total=30012 ms Err -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.356998 PM [AirPlay] Disconnected from 192.168.1.20:36666
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.357382 PM [AirPlay] ### Endpoint "XBMC (OpenELEC)" start failed: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.357736 PM [BonjourBrowser] Reconfirming PTR for XBMC (OpenELEC)._airplay._tcp.local. on en0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.358043 PM [BonjourBrowser] Reconfirming PTR for [email protected] (OpenELEC)._raop._tcp.local. on en0
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.358621 PM [AirPlay] Tore down for stream GeneralAudio
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359081 PM [AirPlay] Posted 'com.apple.AirTunes.endpointStartError' with -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359216 PM [AirPlay] Posting kAudioDevicePropertyDataSourceInfoForID: item 77 error: -6722/0xFFFFE5BE kTimeoutErr
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359711 PM [AirPlay] Client stop finished
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.359901 PM [AirPlay] Quiescing endpoint 'XBMC (OpenELEC)'
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.360126 PM [AirPlay] Posting EndpointDeactivated on quiesce for item 77
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: >vad< ERROR:    18:41:21.361 [tid 0x1024a4000] [158]: CAException thrown from property listener: 4294960569.
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.371728 PM [AirPlay] Stopping HAL audio for AirPlay < Output >
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Notice>: 2014-08-15 06:41:21.375221 PM [AirPlay] Client stop finished
Aug 15 18:41:21 mguillon-iPhone mediaserverd[50] <Error>: 18:41:21.512 ERROR:     [0x1029f4000] >aqme> 241: (0x1310825b0): scope 1, element 0, tag=0x0, 2 channel descriptions [L, R]: error -10851

PS: i am asking here because i remember reading on some post a comment from Memphiz that airplay issues might be distrib related

Thanks
(2014-08-15, 17:16)Milhouse Wrote: Yes, give it some time - it's got a few databases to update - it will need to upgrade the video database in sequence from v78 to 79 to 85 to 86 to 87 to 88 and finally to 89...

Once it finishes, check the log carefully for errors!

Is that correct, I've done extensive DB testing and the logs I see show XBMC looking backwards from the version it hopes for and then doing a conversion from there for example directly from 78 to 89. SQL doesn't show the intermediate steps.

Thanks
(2014-08-15, 20:03)goRt Wrote: Is that correct, I've done extensive DB testing and the logs I see show XBMC looking backwards from the version it hopes for and then doing a conversion from there for example directly from 78 to 89. SQL doesn't show the intermediate steps.

Thanks

You might be right, it's been a long time since I had to upgrade more than on db version.

Edit: Just checked the code and it will upgrade through each version although it may not output that it is doing so explicitly. It may not create the intermediate databases but will perform all the steps necessary to migrate from 79 to 89.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Helix build: #0815
(Supercedes previous build)

Code:
# uname -a
Linux openelec 3.16.1 #1 PREEMPT Fri Aug 15 22:12:41 BST 2014 armv6l GNU/Linux

# vcgencmd version
Aug 12 2014 18:21:28
Copyright (c) 2012 Broadcom
version f32b2bbfdea55d48c9a52b92e5c798f9aa5f47bc (tainted) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20140815221129-r19018-g3f60dde

Based on tip of OpenELEC master (3f60dde1, changelog) and tip of XBMC master (fa5bf23f, changelog) with the following modifications:
  • Includes newclock3 patches
  • Excludes the OpenELEC fernetmenta patches due to conflicts with newclock3
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-3.16.y
  • Excludes the OpenELEC xbmc-001-newclock3 patch in favour of sourcing these and possibly more recent patches directly from newclock3 branch
  • Default setting for "Show RSS Feed" changed to disabled
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest libnfs master (2e630bbd)
  • Includes latest libcec master (81e38211)
  • Includes libcec double-key suppression.
  • Includes libcec CEC Standby Fix.
  • Increase scan interval of PeripBusCEC from 5000 to 60000, reducing CPU loading by about 2% (1GHz Pi) every 5 seconds (even when CEC is "disabled")
  • Includes CONFIG_COREDUMP=y to allow creation of coredumps
Build Highlights:
  1. newclock3-based build.
  2. New 3.16.1 kernel.
  3. Added /usr/bin/configrpi256.sh to easily enable swap, increase vm.swappiness (in /storage/.config/autostart.sh) and set gpu_mem_256=112 on 256MB devices. These settings may improve performance, as it has done for Raspbmc when running on 256MB R-Pi. To enable the new settings, run the following command on a a 256MB Pi:
    Code:
    /usr/bin/configrpi256.sh
    then reboot.

    It shouldn't be necessary to use this command on a 512MB Pi, but running it shouldn't do any harm - it will enable swap and set vm.swappiness, but will leave your memory split unchanged.

    You can view swap usage with "bcmstat.sh cgx".

    To disable: rm /storage/.config/swap.conf, and set whatever memory split you require in /flash/config.txt.
  4. New SDCard driver added, not enabled by default.

    popcornmix Wrote:There is a new sdcard driver in 3.16 tree.

    Make sure these are in the kernel config:
    CONFIG_DMA_BCM2708=y
    CONFIG_DMA_ENGINE=y
    CONFIG_DMA_VIRTUAL_CHANNELS=y
    CONFIG_MMC_BCM2835=y
    CONFIG_MMC_BCM2835_DMA=y
    CONFIG_MMC_PIO_DMA_BARRIER=2

    By default you get the old driver, but you can choose the new driver with (added to cmdline.txt)
    Code:
    bcm2708.bcm2835_mmc=1

    This is expected to become the default sdcard driver in the future. It should avoid some of the issues of the old driver, like polling with interrupts disabled, and could improve performance and avoid interfering with other drivers (e.g. USB or LIRC).

    Testers are encouraged, and backing up the sdcard before testing would be advisable.

    I've been using it over the last week without any issues.

    So, add "bcm2708.bcm2835_mmc=1" to the end of your line in /flash/cmdline.txt to enable the new driver. Once enabled, you should see the following in dmesg:
    Code:
    [    1.544512] Load BCM2835 MMC driver
Build Details:
  1. OpenELEC:
    • linux: add support for dvbsky s950v3 / s952v3
    • linux: update to linux-3.16.1
    • libressl: update to libressl-2.0.5
    • Created a patch from the work Valve did on the xpad kernel driver.
    • linux: add support for dvbsky s950v3 / s952v3 (PR:3398, 1 commit, 3 files changed)
    • Ignore diagonals for iMON PAD in keyboard mode
    • linux: fix patch
    • linux: move patch
    • adds support for multiple extension points in addon.xml
    • linux: remove unused ptrace fix
    • binutils: remove unused cloog patch
    • gmp: remove unused patches
    • xbmc: merge xbmc-config.service into xbmc.service
    • connman: merge hostname.service into connman.service
    • connman: merge loopback.service into connman.service
    • expat: clean up autoreconf hacks
    • usbutils: update usb.ids
    • pciutils: update pci.ids
  2. XBMC:
    • gitignore: Add libstagefrightICS/Makefile (PR:5219, 1 commit, 1 file changed)
    • [jenkins] - change to workspace before trying to checkout the submodule - might fix the latest jenkins issues
  3. newclock3:
    • squash to 7e420ed9b3a3af29fe165e27782633a0d08c12f9
    • [AirTunes] - Don't leave audio_flush uninitialised
  4. kernel 3.16.y:
    • VCHIQ: Make service closure fully synchronous (drv)
    • Add new bcm2835_mmc (sdcard) driver and dma driver
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Experimental newclock4 build uploaded: #0815b

Same as build #0815, but with newclock4 patches in place of newclock3. See here for details.

newclock4 additions since previous build #0813b:
  • renderer: bump buffers to 5
  • omxrenderer: Don't skip reconfigure when dimensons are the same
  • squash to 7e420ed9b3a3af29fe165e27782633a0d08c12f9
  • [AirTunes] - Don't leave audio_flush uninitialised
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Airplay video streaming seems to have been broken for some time now. I'd been using #528 for the past few months. It seems #714b broke it, as #714 and earlier work and later builds don't (edit: up to #815). I did not try every build before and after, just enough to narrow it down. I did check #718 in case it was something to do with the warnings regarding #714b, but airplay didn't work there either.

The log spits out:
ERROR: Action - thread AirPlayServer, Unhandled exception caught in thread process, aborting. auto delete: 0

This is with the latest ios version (7.1.2), streaming video from Safari.
@edwr: Have you tested build #0815? I don't have a current iOS device so can't really help with Air-* problems.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
It indeed just took a bit longer. So, it has not re-started. Unfortunately, no change with speed of library scanning, so need to look into other things that may lead to this.

Amber skin appears to look fine, but I am not using PVR function, so cannot judge.

One very weird thing is that the items of the main menu (movies, tvshows, etc) randomly shift orders. Not always, but occassionaly there are moving. So, that's really weird and I have no idea how to trouble-shoot this. Maybe someone else have seen such issues before?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
(2014-08-16, 03:35)Milhouse Wrote: @edwr: Have you tested build #0815? I don't have a current iOS device so can't really help with Air-* problems.

The airtunes change was what prompted me to try again earlier today, but in case I'm going crazy, I just checked again and can confirm it's still not working. Same error in the log, as well.

edit: this seems to be the specific commit affecting airplayserver
[stdstring] get rid of CStdString in network/
https://github.com/xbmc/xbmc/commit/6c3a...97f1430744
Hello Milhouse,

Something is wrong with virtual keyboard and all text entry fields. I'm no longer able to input text using my remote's SMS like 0-9 buttons. It was possible in official builds.
(2014-08-16, 08:35)darzur Wrote: Something is wrong with virtual keyboard and all text entry fields. I'm no longer able to input text using my remote's SMS like 0-9 buttons. It was possible in official builds.

Can you provide an example of how to reproduce this problem? Test it with the stock Confluence skin, any other skin may require changes.

Also, what language and keyboard layout are you using? Check the new "Character set" and "Keyboard layouts" options in Settings -> Appearance -> International - you might need to adjust them. Note: You'll need to set the Settings Level to Standard (or above) to see the Character set and Keyboard layout fields.

The virtual keyboard (Language=English, Character set=Default, Keyboard layout=QWERTY) is working correctly for me, for example when using (Global) Search. Jumping through the Movies library using the 2-9 keys (2=abc, 3=def, 4=ghi etc.) is also working as it should.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Good morning. Dvdplayer doesn't work for me since build 18920. I've been upgrading Openelec without testing anything and yesterday I had to downgrade. I've checked every build (even the experimental ones) between 18920 to 19018 (I skipped 18927, 18930 and 18934...) Omxplayer works fine but with dvdplayer (the one I have by default) all I get is sound, subtitles and a flashing screen in all the files I've tried.
Sorry if this have been reported before, I've been on holidays (now I have taken a look at the posts but not read all of them)
Thank you and regards
@anonimo2001: please upload a full debug log (wiki) from build #0815, covering the period when you try to play a movie with dvdplayer.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 64
  • 65
  • 66(current)
  • 67
  • 68
  • 156
  •   
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888