Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-09-05, 14:42)h.udo Wrote:
(2014-09-03, 20:31)h.udo Wrote:
(2014-08-26, 14:39)h.udo Wrote: [...]

I'm also seeing something fishy with newclock4 OSD and video FPS decoupled mechanism. Behaviour goes like this:

Power on RPi >> OSD FPS stays around 30 like it does with newclock3
After a while(?) >> OSD FPS drops to 2 and stays there

After FPS drop, OSD becomes very sluggish and unresponsive. I'm seeing something like 5 secs to respond to remote control, i.e. nearly unusable.

It feels like the CPU is busy with something and can't process commands fast enough. Videos play nice and without problems.

All in all, excellent work guys!

h.udo

Finally had the time to investigate this one.

This doesn't occur with newclock3, only 4. I can't pinpoint what's causing it. It takes a few hours to show this behaviour (the debug log spans over 14h) and I have absolutely no idea what's causing it.

What I find curious is that GUI render stays at exactly 2.00FPS. No variation whatsoever.

Debug log, cleaned from CEC and PVR crap. Complete debug log is available but is >18MB.

bcmstat log with GUI at ~30FPS and 2FPS.

Thanks for all the hard work!

h.udo

Hi popcornmix,

New debug log from another Pi with the same behaviour. I enabled debug, rebooted the Pi and did absolutely nothing with it. Just left it running over night (my Pis are always on) and the result is the same: a very laggy GUI running at precisely 2fps.

If you need more info, debug logs, etc., just let me know. I'm on the same timezone and if you feel it can help, I can give you SSH credentials to both Pis.

By any chance, are you using CEC?

I've noticed this type of behavior on my pi if I haven't used it in a bit (very sluggish UI). I have an LG TV and when I switch to another Simplink source (LG's name for CEC) and back to the pi, it seems to be back to normal again.
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by ahplk - 2014-09-07, 00:50
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.