Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-10-16, 13:00)popcornmix Wrote: Default is 175 (ppm). It has not changed for a long long time.
Framerate is not significant, but how well the video timestamps and audio timestamps match the data is significant.

Run with mmal, sync video to display and set A/V sync to resample and watch the codec info.
The "rr" parameter shows how much audio needs to be resampled to keep the audio and video clocks synced.

While omxplayer uses a different algorithm, it still has to do a similar compensation.
It alllows up to 0.1% adjustment in HDMI pixel clock, but limits each change step to that specified by hdmi_clock_change_limit.
hdmi_clock_change_limit=50 equates to allowing 0.005% hdmi clock adjustment per step.

I suspect that either your 25Hz videos are encoded in such a way that the timestamps require significant adjustment (can be verified with "rr" number varying from 1.00 or oscillating),
or your receiver is more fussy in that mode.
Thanks for the detailed explanation.
I have tested the video I extracted the sample from and I can see that it varies (not so frequently) from 0.98 to 1.05 during the first 5 minutes.

Quote:Note: The default settings work fine for 99% of TVs/receivers - there are just some models that are unusually fussy - what receiver are you using?
It's a recent LG TV (32LB650).

I'm perplexed though - I was getting the same behavior with old videos I'm sure I've watched at least one time (i.e. Avatar, my sister recently watched it again for the third time).

Am I supposed to find the maximum value between 50 and 175, or it doesn't have any effect (performance/artifacts/...)?

(Note: I'm not sure about local laws, so I'll delete the sample later day.)
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by menakite - 2014-10-16, 16:02
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888