Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)
(2014-11-19, 00:02)Milhouse Wrote: New OpenELEC Helix build: #1118

One feature I'd quite like testing is using dvdplayer (i.e. disable omxplayer acceleration), with "adjust display refresh rate to match video" and "sync playback to display".

On other platforms, the recommended A/V sync method is "resample audio".
This is required as audio and video devices may have asynchronous clocks, and will gradually drift apart causing a lipsync error. Correction may also be needed due to errors in the timestamps in the file (e.g. some rounding issue in the encoding tools) or after a glitch (e.g. error in broadcast TV, or after removing adverts from a file).

To correct this, you have to do something unwanted:
You can skip/duplicate a video frame. You may notice a stutter on the video.
You can skip/duplicate audio samples. You may notice an audio glitch when this occurs.
You can resample the audio by a small amount to speed up or slow down the audio to catch up with video. This is considered the best option, but it still degrades audio, and can't be used with passthrough (which falls back to duplicate/drop).

On the Pi there is a new option "Adjust PLL". This avoids all the unwanted behaviours, and corrects audio/video sync by subtly altering the HDMI pixel clock (though a PLL).
This should allow perfect A/V sync with no video or audio artifacts.

Try it. The codec info ('o' key) will show the value of the PLL (1.00000 would be normal, 1.00015 would be running fast to decrease the audio offset, and 0.99985 would be running slow to increase the audio offset). The "err:" value is how far off audio and video are. It should *slowly* move towards zero. I've made the PLL adjustment pretty slow for now, so it may take a minute or two to get to zero. Some TV/receivers will drop-out if the PLL is moved too quickly.

Currently there is a bug that means audio/video don't start in sync (affects all platforms), so you often see ~-50ms offset at start of video, but that should quickly reduce. FernetMenta is aware of this, so hopefully that will be a fix for this soon.

So, give it a try and report back if there are any issues with video smoothness, any audio glitches or out-of-sync issues, or any tv/receiver drop-outs. Also report if the "err:" term ever fails to end up close to zero.
  Thread Closed
 
Thread Rating:
  • 8 Vote(s) - 4.88 Average


Messages In This Thread
Re: RE: - by Mafarricos - 2014-06-04, 20:21
Live tv issues again - by pootler - 2014-06-04, 23:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3, - by removed151214 - 2014-08-04, 23:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-19, 00:11
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-08-21, 20:42
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:20
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:34
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-22, 22:44
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 01:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-23, 23:24
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-09-25, 01:38
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:12
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-01, 18:26
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-05, 01:07
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 03:48
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 04:06
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by removed151214 - 2014-10-11, 11:29
RE: OpenELEC Testbuilds for RaspberryPi Part 3 - by popcornmix - 2014-11-19, 00:31


Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 3 (Kodi 14.0)4.888
This forum uses Lukasz Tkacz MyBB addons.