•   
  • 1
  • 7
  • 8
  • 9
  • 10
  • 11(current)
Release script.toolbox
hello,

i ve some txt and XML files on my system (data from my weather station)

is it e.g. possible to show infos from this files in Kodi?

samples.txt
Code:
actual_solar_irradiance_wqm 260
actual_thb0_height_m 10
actual_thb0_height_ft 33
actual_thb0_temp_c 15.9
actual_thb0_temp_f 60.6
actual_thb0_hum_rel 74
actual_thb0_hum_abs 10.0

or sample.xml
Code:
<?xml version="1.0" standalone="yes"?>
<weather>
    <actual>
        <actual_solar_irradiance_wqm>260</actual_solar_irradiance_wqm>
        <actual_thb0_height_m>10</actual_thb0_height_m>
        <actual_thb0_height_ft>33</actual_thb0_height_ft>
        <actual_thb0_temp_c>15.9</actual_thb0_temp_c>
        <actual_thb0_temp_f>60.6</actual_thb0_temp_f>
        <actual_thb0_hum_rel>74</actual_thb0_hum_rel>                                                
    </actual>
</weather>

Is it possible, to show the actual temp value (here 15.9) in Kodi?

Regard
Reply
I bump into an error related to ToolBox Script (when running kodi on apple tv 4)
It showed up when setting up the fTV skin home menu
I got the log here, can anyone check it out for me?

log file: http://pastebin.com/1PfPLgBt

anyway to fix it ?
Thanks a lot.

the video (when the error occur) : https://goo.gl/photos/9Aky9nPiHvPEJtKL8
Reply
Phil, should it still work to call the extrafanart function from skin settings like so?

Code:
RunScript(script.toolbox,info=extrafanartmovie)

I'm running a recent Krypton nightly under Windows 10. When I run the script as shown above from skin settings, the progress dialog never appears on screen like it does when running from the script.toolbox program icon.

Here's my debug log, which makes it look like script.toolbox ran correctly.

http://pastebin.com/qZbmMnNR

Thanks!
Reply
(2015-12-30, 12:26)thy1225 Wrote: I bump into an error related to ToolBox Script (when running kodi on apple tv 4)
It showed up when setting up the fTV skin home menu
I got the log here, can anyone check it out for me?

log file: http://pastebin.com/1PfPLgBt

anyway to fix it ?
Thanks a lot.

the video (when the error occur) : https://goo.gl/photos/9Aky9nPiHvPEJtKL8

It looks like you have a Pillow/PIL problem. I ran into a similar error (ImportError: No module named PIL) and found that pillow was not installed.
Reply
Hey guys, is there opportunity to get Blur Background with toolbox and how can I enable it on my skin? Thanks Smile
Reply
I can not get it to install on an Android box running Jarvis 16.1. It does not even show up in the official Kodi addons list. If I try to manually install, I get "Python version 2.0 could not be satisfied"
Reply
(2016-07-03, 12:33)emre.ay Wrote: Hey guys, is there opportunity to get Blur Background with toolbox and how can I enable it on my skin? Thanks Smile

iirc:
RunScript(script.toolbox,info=blur,id='"IMAGE_TO_USE"',radius=RADIUS_SIZE,prefix=RETURN_IMAGE_ID)

Or you can use script.colorbox Smile
https://github.com/BADMS/script.colorbox

If using jarvis install from kodi official repo.
Use skin.eunique as a reference as instructions on git are now for unreleased kypton version (use my skin.mimix as reference for usage and instructions on git for krypton).
Reply
Hey guys!

The version.txt in the userdata folder file is edited when updating my build telling the version of the build.
Can this script print out what's in that text file somewhere in kodi?

The file contains:

Code:
<build>build01</build><version>1.1.0</version>
<build>build02</build><version>1.7.0</version>

I want a text like "Build version: x.x.x"
How do I implement the script in my xonfluence skin?

Thanks for your support!

/ T
Reply
Hello all, I am trying to use blurred albumart as my music visualization for a skin that does not have it built in and I am having trouble figuring out how to add the functionality to the MusicVisualisation.xml.

I have added the following at the top of the xml
Code:
<onload>RunScript(script.toolbox,info=blur,id='"$INFO[MusicPlayer.Cover]"',radius=20,prefix=AlbumArt)</onload>


And then I added the following image control to display the image but it doesn't work:
Code:
<control type="image">
    <texture>$INFO[Window(Visualisation).Property(AlbumArt.ImageFilter)]</texture>
    <width>100%</width>
    <height>100%</height>
    <aspectratio align="center">scale</aspectratio>
</control>


Can someone help me understand what I'm doing wrong?
Reply
The image may not be ready in time for use with onload.
Reply
Thanks for the reply badaas,

I thought that loading time may be an issue but I'm not sure how to fix/work around the probelm. I find it especially strange because Aeon Nox 5 has an option to use blurred album art as a visualization but I'm not sure exactly how it was implemented because I'm not actually a skinner/coder.
Reply
Yes! I finally figured it out after almost 2 days of continuous trying/googling on how to use/implement the "ToolBox" script. After carefully combing through the Aeon Nox XMLs for Kodi 16.1 (Jarvis) I got it working. For anyone else who may want to use blurred album art as your Music Background just add these items to the respective files as indicated by the XML code comments "<!--Example Comment-->"

Code:
<!--Loads the ToolBox Script Add-On in order blur album art images for the Now Playing window. Put this in Startup.xml-->
<onload condition="System.HasAddon(script.toolbox)">RunScript(script.toolbox,daemon=True,radius=10)</onload>

<!--Variable that contains blurred Album Art to be used as the background image for the Now Playing window. Put this in Variables.xml-->
<variable name="VizBackgroundVar">
    <value>$INFO[Window(home).Property(ImageFilter)]</value>
</variable>

<!--MultiImage Control used to display blurred album art as Now Paying Background. Put this in MusicVisualisation.xml-->
<control type="multiimage">
    <description>Blurred Album Art</description>
    <posx>0</posx>
    <posy>0</posy>
    <width>100%</width>
    <height>100%</height>
    <visible>yes</visible>
    <aspectratio>scale</aspectratio>
    <fadetime>2000</fadetime>
    <imagepath background="true">$VAR[VizBackgroundVar]</imagepath>
    <animation effect="fade" start="100" end="20" time="0">Conditional</animation>
</control>



Thanks again for the help badaas!
Reply
Is there a way to do an "Update all" on a daily basis in the background?

Thanks.
Reply
  •   
  • 1
  • 7
  • 8
  • 9
  • 10
  • 11(current)



Logout Mark Read Team Forum Stats Members Help
script.toolbox2
This forum uses Lukasz Tkacz MyBB addons.