Solved Issue with video quality/deinterlacing
#1
Hey all,
So I've upgraded to Kodi RC3 (I think so, I'm current per apt-get update/grade). Ever since switching to Kodi vs XBMC, I've had issues with deinterlacing. When set to auto, anything that needs deinterlacing disabled/off, is a white screen unless I manually go change it to disabled. Auto will just result in white screen, but audio/interface is fine.

Some things are extremely "shakey", for lack of a better word. It seems to be hit or miss as to the correct setting, however, leaving it as Auto is almost always wrong.

Has the selection process changed for deinterlacing? Did I forget something else and am just attributing this to the wrong factor?

Thanks for any help in advance!
Nothing to see here....
Reply
#2
Provide the info that is needed, start with a Debug Log
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#3
(2014-12-22, 23:22)fritsch Wrote: Provide the info that is needed, start with a Debug Log

That's my debug log. I tested two that used to create the problem, but didn't see at first (2 TMNT videos).
Line 1543 is the start of video that "bounces/shakes".
Line 1971 is the start of the video that goes white when auto is left on (also white on "bob"?).

Any tips would be extremely helpful, as I didn't see anything that stood out to me in the log.
Nothing to see here....
Reply
#4
Under Video -> Playback -> (Expert Settings) -> Disable Mpeg-4 codec. Better now?

Quote:18:54:44 T:140151541217024 ERROR: CMixer::InitCycle - interlace method: 1 not supported, setting to AUTO
18:54:44 T:140151549609728 NOTICE: VDPAU::COutput registered output surfaces
18:54:44 T:140151541217024 ERROR: CMixer::InitCycle - interlace method: 1 not supported, setting to AUTO
18:54:44 T:140152542312192 DEBUG: CDVDPlayer::HandleMessages - player started 2
18:54:44 T:140151549609728 NOTICE: VDPAU::COutput registered output surfaces
18:54:44 T:140151541217024 ERROR: CMixer::InitCycle - interlace method: 1 not supported, setting to AUTO
18:54:44 T:140151549609728 ERROR: Previous line repeats 1 times.
18:54:44 T:140151549609728 NOTICE: VDPAU::COutput registered output surfaces

Please provide: DISPLAY=:0 vdpauinfo | pastebinit
and also: dpkg -l |grep mesa | pastebinit

Under System -> Settings -> Debugging, please enable Video Component Logging and provide another Debug Log
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#5
(2014-12-23, 09:27)fritsch Wrote: Please provide: DISPLAY=:0 vdpauinfo | pastebinit
http://paste.ubuntu.com/9605357/

(2014-12-23, 09:27)fritsch Wrote: and also: dpkg -l |grep mesa | pastebinit

http://paste.ubuntu.com/9605360/

I'll do the other one when I'm home and have access to the machine directly.
Nothing to see here....
Reply
#6
Mmh, not nice. That's a real nvidia. I thought of the A4 radeon integrated graphics before.

Can you try with a whiped .xbmc / .kodi directory?

Something is odd here.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
#7
Can do. I actually think I'm going to wipe the machine and start over on the OS. I'll make this as solved, and start another if the issue persists. Thanks for your help!
Nothing to see here....
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Issue with video quality/deinterlacing00
This forum uses Lukasz Tkacz MyBB addons.