Can't get working - No tuners detected
It took me a while to find out that I had to install the unofficial repo and install TVH from there. Now I just need to get my tuner working. It worked when I tried it a while ago so I know it's compatible with the RPi/OE.

When I go to the Web GUI, there's nothing listed under TV Adapters and no drop-down, so it doesn't seem to have the drivers installed.

It's a K-World dual tuner, I think maybe a 299U. From dmesg, it seems to be dvb_usb_af9035. I've pasted the output here if someone could help me please:

My brother's Freeview STB has just stopped working, so it would be great if I could setup his RPi to replace it using one of these tuners (I bought three of them on sale!).
You need to install the drivers
(2015-03-02, 16:39)docsavage7966 Wrote: You need to install the drivers

That really doesn't help me I'm afraid.

I checked the label and it's actually the UB499-2T T09*=0

This page says it should use the dvb-usb-it9137-01.fw driver, which is already included in OE.

It looks like it's properly identified here
could you post the 02_System.log file ?
the stick should be supported since kernel 3.15
Sure, thanks for taking a look:
I thought I'd try the tuner on my RPi B running Gotham but despite having tvheadend 4.1.2 enabled, trying to open doesn't work at all. I'll try updating it to OE 15 and see what happens.
OK, with my RPi B running build #303 from here it's working and I can see the tuner in the config page, although I think there should be two showing as this is a dual tuner unit?

Tried it with build #303 on my RPi v2 and still doesn't show any tuners in the Web GUI.
Here's the 03_Hardware.log from my v2, where as you can see it detects the USB tuner as a "Zolid Mini DVB-T Stick"

The 02_System.log doesn't seem to have any reference to it however, unlike on the B where it shows:

[ 2.296726] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
[ 2.394884] usb 1-1.3: New USB device found, idVendor=1b80, idProduct=e409
[ 2.394913] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 2.394928] usb 1-1.3: Product: DVB-T TV Stick
[ 2.394943] usb 1-1.3: Manufacturer: ITE Technologies, Inc.
With my RPi v2, I can get the tuner working if I unplug and reconnect it after booting. Otherwise it doesn't work at all. I don't have to do this with it in my RPi B.
You could try attaching it to a powered USB hub.
Why would that be necessary, does the RPi v2 output less power on the USB ports than the RPi B?
You could try setting max_usb_current=1 in your config.txt file. This will increase the default current available to the usb ports.

(2015-06-18, 13:30)MikeB2013 Wrote: You could try setting max_usb_current=1 in your config.txt file. This will increase the default current available to the usb ports.


Thanks but I'm fairly sure I already tried that. I'll double-check but for some reason the tuner isn't being initialised by the v2 software on boot, only if I reconnect it after boot, which doesn't seem to point to a lack of current available but some bug specific to the v2 software.
Working now with OE testbuild #809 and the latest tvh Smile

Logout Mark Read Team Forum Stats Members Help
Can't get working - No tuners detected0
This forum uses Lukasz Tkacz MyBB addons.