•   
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14(current)
Release Vimeo v4.X.X - KODI 14.X Helix
(2020-02-27, 00:15)jay.kody Wrote:
(2020-02-26, 07:27)Yubby Wrote: ALSO !  A strange issue has arisen...   If you search for "Iceland" you recieve an error (regardless of the 'settings' for resolution):

2020-02-25 21:20:51.913 T:139984090674944   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.KeyError'>
                                            Error Contents: 'hls'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.vimeo/addon.py", line 3, in <module>
                                                plugin.run()
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/plugin.py", line 95, in run
                                                search(handle, query)
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/plugin.py", line 144, in search
                                                collection = listItems.from_collection(api.search(query, "videos"))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 99, in search
                                                return self._map_json_to_collection(res)
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 154, in _map_json_to_collection
                                                video_url = self._extract_url_from_search_response(item.get("play"))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 235, in _extract_url_from_search_response
                                                return video_files["hls"]["link"]
                                            KeyError: 'hls'
                                            -->End of Python script error report<--
2020-02-25 21:20:51.982 T:139983438300928   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/search/?query=Iceland
2020-02-25 21:20:51.985 T:139985026230464   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/search/?query=Iceland) failed
2020-02-25 21:22:07.945 T:139984904374016 WARNING: Attempt to use invalid handle -1 

 That sucks. I love those beautiful videos from Iceland. Love

Issue confirmed and tracked in: https://github.com/jaylinski/kodi-addon-vimeo/issues/19 (I'll release a fix shortly.) 
Yes, "Iceland" exists again (I didn't know that I could 'purchase' it...).
Now, a possible 'related' issue, is if you search for "Florence", and scroll through the results (I have 20 items per page),  when you get to the '3rd' page, and select 'next page', it returns this error...

2020-02-28 14:29:38.669 T:139983427868416 WARNING: Attempt to use invalid handle -1
2020-02-28 14:30:01.527 T:139983147783936   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: 'NoneType' object has no attribute '__getitem__'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.vimeo/addon.py", line 3, in <module>
                                                plugin.run()
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/plugin.py", line 49, in run
                                                collection = listItems.from_collection(api.call(args.get("call")[0]))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 93, in call
                                                return self._map_json_to_collection(res)
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 164, in _map_json_to_collection
                                                video_url = self._extract_url_from_search_response(item.get("play"))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 248, in _extract_url_from_search_response
                                                return video_files["hls"]["link"]
                                            TypeError: 'NoneType' object has no attribute '__getitem__'
                                            -->End of Python script error report<--
2020-02-28 14:30:01.625 T:139983184721664   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?action=call&call=%2fvideos%3fper_page%3d20%26total%3d20%26query%3dFlorence%2520-wedding%26fields%3duri%252Cresource_key%252Cname%252Cdescription%252Ctype%252Cduration%252Ccreated_time%252Clocation%252Cbio%252Cstats%252Cuser%252Caccount%252Crelease_time%252Cpictures%252Cmetadata%252Cplay%26page%3d4
2020-02-28 14:30:01.632 T:139985026230464   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?action=call&call=%2fvideos%3fper_page%3d20%26total%3d20%26query%3dFlorence%2520-wedding%26fields%3duri%252Cresource_key%252Cname%252Cdescription%252Ctype%252Cduration%252Ccreated_time%252Clocation%252Cbio%252Cstats%252Cuser%252Caccount%252Crelease_time%252Cpictures%252Cmetadata%252Cplay%26page%3d4) failed
Reply
(2020-02-26, 23:57)jay.kody Wrote:
(2020-02-26, 02:32)Yubby Wrote: Wow, you did a lot of work in such short a time...
I have re-tested on all of my units (with the various audio-output hardware and settings) without issue.
Now, how does one use the 'search template' ? 

It's documented on the wiki: https://kodi.wiki/view/Add-on:Vimeo (In short: the "{}" will be replaced by your search query.) 
Successfully tested it...
Searched for "Florence" and confirmed that there were annoying 'wedding' videos in the results.
Configured the 'template' to be  " {}  -wedding "
Re-Searched and there were no 'wedding' videos in the results...
Reply
(2020-02-29, 00:31)Yubby Wrote: Yes, "Iceland" exists again (I didn't know that I could 'purchase' it...).
Now, a possible 'related' issue, is if you search for "Florence", and scroll through the results (I have 20 items per page),  when you get to the '3rd' page, and select 'next page', it returns this error...

2020-02-28 14:29:38.669 T:139983427868416 WARNING: Attempt to use invalid handle -1
2020-02-28 14:30:01.527 T:139983147783936   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: 'NoneType' object has no attribute '__getitem__'
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.vimeo/addon.py", line 3, in <module>
                                                plugin.run()
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/plugin.py", line 49, in run
                                                collection = listItems.from_collection(api.call(args.get("call")[0]))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 93, in call
                                                return self._map_json_to_collection(res)
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 164, in _map_json_to_collection
                                                video_url = self._extract_url_from_search_response(item.get("play"))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 248, in _extract_url_from_search_response
                                                return video_files["hls"]["link"]
                                            TypeError: 'NoneType' object has no attribute '__getitem__'
                                            -->End of Python script error report<--
2020-02-28 14:30:01.625 T:139983184721664   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?action=call&call=%2fvideos%3fper_page%3d20%26total%3d20%26query%3dFlorence%2520-wedding%26fields%3duri%252Cresource_key%252Cname%252Cdescription%252Ctype%252Cduration%252Ccreated_time%252Clocation%252Cbio%252Cstats%252Cuser%252Caccount%252Crelease_time%252Cpictures%252Cmetadata%252Cplay%26page%3d4
2020-02-28 14:30:01.632 T:139985026230464   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?action=call&call=%2fvideos%3fper_page%3d20%26total%3d20%26query%3dFlorence%2520-wedding%26fields%3duri%252Cresource_key%252Cname%252Cdescription%252Ctype%252Cduration%252Ccreated_time%252Clocation%252Cbio%252Cstats%252Cuser%252Caccount%252Crelease_time%252Cpictures%252Cmetadata%252Cplay%26page%3d4) failed 

Thanks for the report! Confirmed and tracked: https://github.com/jaylinski/kodi-addon-vimeo/issues/23
Reply
Finally got around to making sure that version 5.1.2 was installed, and retested the 'paging' without encountering 'that' issue...

Thanks !
Reply
Doesn't work search history with non-english words.
Reply
(2020-05-17, 11:34)Lirk Wrote: Doesn't work search history with non-english words.
Yeah, this is a known issue: https://github.com/jaylinski/kodi-addon-vimeo/issues/34

I'll try to fix it next week.
Reply
I've some trouble playing a video through the addon. I'm calling "plugin://plugin.video.vimeo/play/?video_id=123" but the video doesn't always play. I have no idea why it sometimes does and sometimes doesn't.
Is this url format the right one? The github page also mentions "plugin://plugin.video.vimeo/play/?[video_id]". Do you need the "video_id=" or not?

Additional question: is there a way to start the video at a specific time mark, like adding a "t=2m42s" or something like that?
Reply
(2020-09-17, 08:09)pa79 Wrote: I've some trouble playing a video through the addon. I'm calling "plugin://plugin.video.vimeo/play/?video_id=123" but the video doesn't always play. I have no idea why it sometimes does and sometimes doesn't.
Is this url format the right one? The github page also mentions "plugin://plugin.video.vimeo/play/?[video_id]". Do you need the "video_id=" or not?

Additional question: is there a way to start the video at a specific time mark, like adding a "t=2m42s" or something like that?
Can you tell me a video ID that isn't playable? Then I can investigate.
The documentation (https://github.com/jaylinski/kodi-addon-vimeo#api) lists an example for playing a video. plugin://plugin.video.vimeo/play/?video_id=123 is correct.
Starting at a specific time mark is not supported right now.
Reply
I'll check for an id later. What I get as an error is "Api JSON seems to be invalid".
Reply
Hmm, can't seem to edit my post.

Here's an id: 415450272. (local tv, not really a cinematic master piece Wink )

As I'm still a kodi newbie, the problem is probably on my end but thanks for your reply anway. I've experimented with using "li.setProperty('IsPlayable', 'true')" and not. I suppose for calling a plugin you've got to omit this part?
I'm also not setting a mime type since I don't know which one you should use for a plugin call. Maybe that's a problem?
Reply
(2020-09-17, 18:09)pa79 Wrote: Hmm, can't seem to edit my post.

Here's an id: 415450272. (local tv, not really a cinematic master piece Wink )

As I'm still a kodi newbie, the problem is probably on my end but thanks for your reply anway. I've experimented with using "li.setProperty('IsPlayable', 'true')" and not. I suppose for calling a plugin you've got to omit this part?
I'm also not setting a mime type since I don't know which one you should use for a plugin call. Maybe that's a problem?
I can't reproduce the issue on my end. Can you send me the error from the log? (https://kodi.wiki/view/Log_file)
Reply
Code:
2020-09-17 18:53:14.224 T:2197136240 WARNING: CreateLoader - unsupported protocol(plugin) in plugin://plugin.video.vimeo/play/?video_id=438518823
2020-09-17 18:53:14.224 T:2197136240   ERROR: InputStream: Error opening, plugin://plugin.video.vimeo/play/?video_id=438518823

2020-09-17 18:53:16.476 T:2329928560   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.RuntimeError'>
                                            Error Contents: Api JSON seems to be invalid
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.vimeo/addon.py", line 3, in <module>
                                                plugin.run()
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/plugin.py", line 84, in run
                                                collection = listItems.from_collection(api.resolve_id(video_id))
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 139, in resolve_id
                                                return self._map_json_to_collection(res)
                                              File "/storage/.kodi/addons/plugin.video.vimeo/resources/lib/vimeo/api.py", line 230, in _map_json_to_collection
                                                raise RuntimeError("Api JSON seems to be invalid")
                                            RuntimeError: Api JSON seems to be invalid
                                            -->End of Python script error report<--
2020-09-17 18:53:16.672 T:3011654992   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.vimeo/play/?video_id=438518823]


Sorry for your time, but the problem seems to be definitely on my side.

First, the first two rows I get them a lot, because for every listitem for the videos I do a setInfo('video',...) and a setProperty('IsPlayable', 'true') but because it's not a video file url but a plugin url it throws this error.
If I do a listitem.setInfo('files',...), it doesn't throw the error but it's also not playable either because it's not a video anymore.

Second, I have a function that creates the url for the plugin call by just adding the video id at the end.
There's some code getting the video id and at the end only does a
Code:
return "plugin://plugin.video.vimeo/play/?video_id="  + link[0]
where link is a list that has the id in the first list element. I also tried str(link[0]) to be sure it adds a string and it doesn't work either. I put up a xbmcgui.Dialog().ok() to check and the url is alright. Weirdly enough, if I hardcode the link as in
Code:
return "plugin://plugin.video.vimeo/play/?video_id=438518823"
it finally works and did play the video! There must be some Python thing (maybe incompatible types?) I don't know about. My platform is LibreElec with Kodi 18.8 and Python 2.7 on a Raspberry Pi 4.
Reply
I investigated further and have found out that something's wrong with the video channel on vimeo. There are lot of videos missing on the channel page that are embedded on another website. Even if I take the video ids and try to find them on vimeo, I don't get a result though they are playable on that other website. I suppose it's possible that some privacy setting hides the video from vimeo but still leaves the possibility to embed them elsewhere. In that case they're not playable through the vimeo addon. Sorry to have bothered you.
Reply
(2020-09-20, 10:40)pa79 Wrote: I investigated further and have found out that something's wrong with the video channel on vimeo. There are lot of videos missing on the channel page that are embedded on another website. Even if I take the video ids and try to find them on vimeo, I don't get a result though they are playable on that other website. I suppose it's possible that some privacy setting hides the video from vimeo but still leaves the possibility to embed them elsewhere. In that case they're not playable through the vimeo addon. Sorry to have bothered you.
That's actually a plugin issue I should fix. And I think I can reproduce it.
I created an issue for it here: https://github.com/jaylinski/kodi-addon-vimeo/issues/43
Reply
I just released version 5.2.0 with some new features and a bugfix: https://github.com/jaylinski/kodi-addon-...tag/v5.2.0

Kodi v19 (Matrix) version will follow soon.
Reply
  •   
  • 1
  • 10
  • 11
  • 12
  • 13
  • 14(current)



Logout Mark Read Team Forum Stats Members Help
Vimeo v4.X.X - KODI 14.X Helix1
This forum uses Lukasz Tkacz MyBB addons.