•   
  • 1
  • 188
  • 189
  • 190(current)
  • 191
  • 192
  • 506
  •   
Kodi DSPlayer – DirectShow Player for Windows
Tamuro i dont know about the install.bat as MCP-HC wuldnt work otherwise, which option are u using in DSPlayer re. the codecs that could be the bugger thats playing havoc.

Im working flawless but may tinker looking at the modified xml configs above that seem to expand on mine, i really hope you track down the problem as its awesome when working; what a shame we've lost the ability for the project to continue Sad
Reply
(2016-02-12, 17:03)Wanilton Wrote: @Tamuro, you need extract the zip file and run the "install.bat." (admin mode in context menu)

I already did that. If I hadn't, then it wouldn't be working in mpc-hc for me, but it is.
Reply
(2016-02-10, 16:28)oldpoem Wrote:
(2016-02-10, 15:50)Bjur Wrote:
(2016-02-10, 12:00)oldpoem Wrote: If you have enough CPU load to spares , software decoding is best way to go. You'll get rid of some dxva decoding artifact which occurs on some weird encoded files. I encountered most of these artifacts on Intel though while has much lesser problem with NVidia. HW decoding save CPU loads but did not provide better quality picture so on most modern machine which is not atom or similar low powered CPU. Disabled hw decoding is safe choice.

Most of MadVR task run on GPU which is different load. So be sure to check if high load is CPU load or GPU load. But so called Higher CPU load shouldn't affect playback at all unless it closes to 100% which would causes frames drops. Yes it might lead to more noises to due more heat and increased fan speed. But I doubt it would be that much higher cpu load on i3 machine , extra 10-20% increased CPU loads is usually considered little on overall impact. Pushing madvr settings would get much more heat & noise from your GPU card / fans than push up your cpu anyway.


Also if you decide to upgrade madvr be sure to try reset & reconfigure madvr settings. Because between time of Kodi 15 DSPlayer to latest dsplayer madvr is the most changed component. DSPlayer code hasn't changed much or at all since aracnoz left. All Wanilton did was to keep DSPlayer part compiled with latest Kodi base. He did update internal lavfilters a bit and change few codes to let it compiled successfully. But in term of DSPlayer codebase nothing really changes. So I think it's better to check if your old madvr settings is the cause. It's better to did new madvr settings anyway since a lot has changed.

Thanks for the very elaborating answer OldpoemSmile
Regarding the software decoding, it that something you choose in Video settings in Kodi or is it in LAVFilter?
I think I read somewhere DSPlayer doesn't use Kodi menu settings.

Oh and 1 more question!
I have my settings.bin from when it was working fine. If I reset to default and overwrite settings.bin would that be okay or should I manually input the settings?
I'm guessing the reg key is newer than the settings.bin, so I'm afraid if I just put settings.bin in folder it would be overwritten be default regkey.

Video settings in Kodi refer to dvdplayer only. While DSPlayer (if) using LAVFilter which you can manually settings outside DSPlayer or can use gui setting in DSFilter list to set as well.

I personally don't use settings.bin now so not sure about that. It's recommend to manually config madvr again if your settings is too old. Just few minutes.
Have tried to update madvr and kodi and reset madvr Settings and copy in settings.bin. It still gives me dropped frames after updating version. I have none in lavfilter for decoder. Don't get it. Can I use the older lavfilter dll files and replace the newer. Could that be a solution for get it working like before. I have rolled back now but my other clients are 16 not 15.2
Reply
(2016-02-12, 20:05)Derek Wrote: Tamuro i dont know about the install.bat as MCP-HC wuldnt work otherwise, which option are u using in DSPlayer re. the codecs that could be the bugger thats playing havoc.

Im working flawless but may tinker looking at the modified xml configs above that seem to expand on mine, i really hope you track down the problem as its awesome when working; what a shame we've lost the ability for the project to continue Sad

I am using all the current versions as of 3 days ago. This is really bumming me out because after a lot of research and trying things out I settled on this setup being perfect for me and I can't get it to work.Sad I will post the settings when I get home.
Reply
I mean in video setting in kodi DSP under the codec type used i think internal/external etc i cant say exactly as im compiling somthing and dont want to run DSP till its done, maybe its that which is causing the problems as i myself experienced problems with this initally and im grabbing at straws to try and get you up and running. when this compiles i'll run it and give a full explenation but if you look theres not a whole lot of settings and it refers to codecs with 3 options one being internal or something such like which i think is what i use; sorry i cant be more forthcomming at the moment but will post a screenshot as soon as i possibly can.

Best of luck in the meantime.
Reply
(2016-02-12, 20:44)Derek Wrote: I mean in video setting in kodi DSP under the codec type used i think internal/external etc i cant say exactly as im compiling somthing and dont want to run DSP till its done, maybe its that which is causing the problems as i myself experienced problems with this initally and im grabbing at straws to try and get you up and running. when this compiles i'll run it and give a full explenation but if you look theres not a whole lot of settings and it refers to codecs with 3 options one being internal or something such like which i think is what i use; sorry i cant be more forthcomming at the moment but will post a screenshot as soon as i possibly can.

Best of luck in the meantime.

Awesome. I really appreciate you taking the time to help me out.
Reply
(2016-02-12, 21:03)Tamuro Wrote: Awesome. I really appreciate you taking the time to help me out.

No problem i cant contribute to Kodi on the coding front so im happy to help people via the forum as i appreciate the work put into this awesome software; again just gutted DSP is unlikley to continue unless some genius windows coder takes the rains.

Bout an hour to finish compile then i'll try and get you sorted buddy.
Reply
(2016-02-12, 20:27)Bjur Wrote:
(2016-02-10, 16:28)oldpoem Wrote:
(2016-02-10, 15:50)Bjur Wrote: Thanks for the very elaborating answer OldpoemSmile
Regarding the software decoding, it that something you choose in Video settings in Kodi or is it in LAVFilter?
I think I read somewhere DSPlayer doesn't use Kodi menu settings.

Oh and 1 more question!
I have my settings.bin from when it was working fine. If I reset to default and overwrite settings.bin would that be okay or should I manually input the settings?
I'm guessing the reg key is newer than the settings.bin, so I'm afraid if I just put settings.bin in folder it would be overwritten be default regkey.

Video settings in Kodi refer to dvdplayer only. While DSPlayer (if) using LAVFilter which you can manually settings outside DSPlayer or can use gui setting in DSFilter list to set as well.

I personally don't use settings.bin now so not sure about that. It's recommend to manually config madvr again if your settings is too old. Just few minutes.
Have tried to update madvr and kodi and reset madvr Settings and copy in settings.bin. It still gives me dropped frames after updating version. I have none in lavfilter for decoder. Don't get it. Can I use the older lavfilter dll files and replace the newer. Could that be a solution for get it working like before. I have rolled back now but my other clients are 16 not 15.2

Don't copy back settings.bin , that was no point in reset settings and write over with old settings.bin. You should set madvr from scratch and see if the problem still exist.
Reply
I dont think its a MadVR settings problem as MPC-HC is working perfectly i beleive, i think its a DSP config problem or not problem but miss setting.
Reply
(2016-02-12, 16:03)Tamuro Wrote: Ok so I clicked on the madVR exe. file located in the folder where I unzipped madvr which started madvr and put the icon in the taskbar. From there I was able to click on the taskbar setting and set it from "only show when madVR is in use" to "always show in taskbar". However, the fact that it wasn't showing up when I started a ripped bluray movie within' kodi made me question whether it was even working correctly.

So I maxed out all the sharpening enhancements in madvr while kodi was minimized just to see if the settings where being applied to the movie. Well, when brought kodi back up to full-screen the image did not change at all. So basically madvr is not working with kodi for me. Not sure what the problem is.

I tested out mpc-hc which I still have installed and configured with madvr just to make everything worked there and it is working flawlessly. So basically I am stumped.

Change DSPlayer "Manage settings with Kodi" ftom default "Load and Save with DSPLayer Database" to "Disabled" or "Load from active madvr profile". The way DSPlayer works with madvr is sligghtly different from MPC-HC. By default if you run media file once DSPlayer would save your madvr settings per file in db and use that value regardless of what changed in madvr control panel. If you want to change any value you need to change via Kodi GUI. Disable this feature revert DSPlayer to use whatever settings in madvr control panel at the time.
Reply
Ah interesting i didnt know it was capable of saving settings on a per file basis, i have mine working great and i HOPE a screenshot of the DSPlayer settings tab will help Tamuro get his running; but as you say if MPC-HC works differently theres no saying that will get it working but im hopeful. Nerd
Reply
Yes that is interesting. That can be good and bad. It allows you to have custom settings for each media file.

I am still dumb founded as to why madvr doesn't show up in the taskbar even when I set it to "show when active". It will only show if I force it to stay there the entire time. Even if i'm not running any media or media player and just sitting on the desktop.
Reply
Someone mentioned before but does 3D work in the latest nightly from Wanilton?
Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub
Reply
(2016-02-12, 22:38)Tamuro Wrote: Yes that is interesting. That can be good and bad. It allows you to have custom settings for each media file.

I am still dumb founded as to why madvr doesn't show up in the taskbar even when I set it to "show when active". It will only show if I force it to stay there the entire time. Even if i'm not running any media or media player and just sitting on the desktop.

That makes me think maybe madvr is not running when dsplayer is active. hopeully soon we can get to the bottom of it, my cpu cores are doing their best to get the work done so i can help Smile
Reply
(2016-02-12, 22:52)Derek Wrote:
(2016-02-12, 22:38)Tamuro Wrote: Yes that is interesting. That can be good and bad. It allows you to have custom settings for each media file.

I am still dumb founded as to why madvr doesn't show up in the taskbar even when I set it to "show when active". It will only show if I force it to stay there the entire time. Even if i'm not running any media or media player and just sitting on the desktop.

That makes me think maybe madvr is not running when dsplayer is active. hopeully soon we can get to the bottom of it, my cpu cores are doing their best to get the work done so i can help Smile

Yeah very strange. I'm on windows 10 too so who knows if something isn't compatible. I noticed another thing last night as well. When in Kodi and watching an mkv bluray movie, if I hit "o" I get the filter info but if I hit "ctrl J" I don't get the row of information from madvr. I really think even though i have madvr set in GUI for renderer, internal set for filters and regardless of which setting I use for "Manage settings for Kodi" that it isn't working for some reason. If madVR is set to show in taskbar when in use then it should pop up in the bar once I fire up a move in Kodi and it doesn't unless I force it on all the time. Which would then mean madVR would be running the entire time my PC is on but not necessarily working in DSplayer.

And if this helps, I'm running the latest madVR 90.8, I'm on Jarvis rc3 and used the latest DSplayer for Jarvis rc3. Also, it shouldn't matter where I unzipped madVR correct? Meaning it doesn't have to be on my main "C" drive where windows/Kodi is installed. I have also not configured any files. Meaning I haven't installed any external filters, I didn't change any roots or anything. Basically I have everything back to default.
Reply
  •   
  • 1
  • 188
  • 189
  • 190(current)
  • 191
  • 192
  • 506
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347