Win HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
(2016-10-12, 17:21)brazen1 Wrote: I don't know? Perhaps your Epson 5010 does not have 'Smart' enough capabilities?
If that's the case, one of the other methods will work.

Since PDVD does not match refresh rate with a 2D, something is really whacked. Set the desktop and Kodi at 60Hz period! Changing these to 24Hz are not going to help diagnose your problem. Under general tab in PDVD, reset never show again dialogs. Start a title and match refresh rate prompt will appear. Enable it and retry.

Are you using a fresh install of Kodi during these tests?
Backup your original and install a nightly so nothing is carrying over.
Adjust Kodi per post #1.
Add some titles including 3D with proper naming per post #1.
Just trying to eliminate anything obvious overlooked.
Are you using an advancedsettings.xml with anything related to 3D control in it?
If so, you need to edit it out or set the whole advancedsettings.xml aside for now.
That may be the only problem? If not, continue.....

Since a 2D is switching to 3D, then you have to control Nvidia nvstlink.exe using the original setup post #1 with both 2D and 3D .bats and playercorefactory (post #3) for non-smart.
You will also need to setup task scheduler post #46.
Nvidia stereoscopic will always be off and everything at 60Hz only changing to 24Hz during playback. You will have to manually turn stereoscopic on for 3D titles and off when finished. Here is how I used to do it:

Create 3D ENABLE.bat. I placed mine in the Documents folder.

@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /enable

EXIT


Create 3D DISABLE.bat also in the Documents folder.


@echo OFF

"C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvstlink.exe" /disable

EXIT

Install plugin.program.advanced.launcher-master https://github.com/angelscry/plugin.prog...d.launcher
There is nothing to configure. Open the app. Select default. Select context menu (Keyboard C). Select Create New Launcher. Navigate to 3D ENABLE.bat you just created. Do the same for 3D DISABLE.bat. These now appear as links in Advanced Launcher. Select context menu again and add each link to Favorites. I created a 3D MOVIES folder in my main menu. I then created a favorites link in 3D MOVIES submenu. When I want to use an external player to render a 3D title, I navigate to this submenu and select 3D ENABLE before I start the external player and select 3D DISABLE when finished.

This method should work for you. Let me know.....

Unfortunately we're back to where I had originally started in the thread I mentioned earlier. Much of what you suggested here has already been done by me before I even made the thread or used your instructions. The only instructions I had borrowed from you were the playercorefactory.xml/playiso.bat for launching PowerDVD as external player.

I already had 3DEnable & 3DDisable batch files from a solution I found at Anandtech a couple weeks ago, which I had been using in the interim while I tried to figure this out. In fact my method is simpler. I have the two batch files mapped to two unused buttons on my remote control. I don't need to install or use the Advanced Launcher to enable/disable 3D using nvstlink. I'm able to do that at the press of a button on my Remote Control.

I'm not sure what you're using the Task Scheduler for because I didn't see any need for it. All my 2D media runs at 24Hz, My desktop & games run at 60Hz, and when I want to watch 3D, I press the button on my Remote Control to switch to 1080p 3D @ 24Hz, and once I'm finished watching 3D, I press the other button which switches me back to 24Hz.

Let me also clarify something else, this has absolutely nothing to do with my Epson 5010 Projector or it's 'smart capabilities', which is something both me & Host505 were trying to mention in the other thread.

Here's why:

I've been using the EXACT SAME hardware - from my Epson 5010 & Yamaha RX-A2000 to the HDMI Cables, the HTPC and everything else in between - for the last 6 years!! I never had this issue - I never had to switch between 2D & 3D using buttons or batch files or go through these tedious setups. Everything worked flawless. Heck! 6 years ago I had little knowledge of refresh rates and frame rates and stuff. All my HD Media played at 24Hz - Smooth & Stutter free. All my 3D Media played in 3D, smooth & stutter free at 24Hz, in PowerDVD. All the Refresh Rate switching happened automatically - I had no intervention whatsoever.

There is 1 thing and only 1 thing which changed between all of those flawless 6 years and last month: nVidia GTX 1080.

For 6 years I had Intel HD3000 Graphics (The embedded chip in the Intel i5 Processor). Last month I replaced Intel HD3000 with nVidia GTX 1080 and suddenly all of these problems started.

So this has absolutely & only to do with nVidia GTX and it's drivers. Not my projector, not my receiver, and not my setup.

I also already did the Reset on the Dialog boxes in PowerDVD to make sure I match refresh rate in PowerDVD.

Again, using all of the instructions you provided, after making all the necessary adjustments, I'm still where I started.

If I leave "Stereoscopic 3D" enabled in nVidia Control Panel:

- 2D within Kodi tries to match refresh rate, switching it to 24Hz, which does not exist in "2D" Resolutions in nVidia Control Panel, only in 3D, and therefore my display switches to 3D.
- Same thing happens trying to play 2D in PowerDVD.
- 3D in PowerDVD works flawlessly.

If I leave "Stereoscopic 3D" disabled in nVidia Control Panel:

- Everything else works fine; Desktop, Kodi, Games & all run at 60Hz. All 2D Media runs smooth at 24Hz as Kodi matches Refresh Rate. All 2D media runs smooth at 24Hz in PowerDVD as PowerDVD matches Refresh Rate.
- However, PowerDVD does not switch display to 3D Automatically -- which used to happen with Intel HD3000. Now, I have to do it manually using Remote Buttons.

I have no doubts your instructions are working for you and others --- I still believe in your skills, knowledge & capabilities far more then mine -- and therefore I don't understand why it doesn't work the same way for me -- but it's not a Projector issue. It's an nVidia GTX 1080 issue. I've even come in contact with other people using nVidia having the same issues; while other using either AMD cards & Intel chips don't have this issue.

Again - Not trying to say you're wrong or your instructions don't work; just trying to be specific, they are not working for my setup, and its' not a Projector issue.

I'm actually to take some time to try your instructions one more time.

I have 2 questions for you:

i. In your instructions for PowerDVD, where you say:
Code:
PowerDVD 16:
[b]Enable Match Refresh Rate when you see the pop-up for the 1st time and choose not to show you again.[/b]
Enable Hardware Acceleration.
Turn off all enhancements.

Does it matter if you play 2D media or 3D media? Or should I play one or the other & then hit 'Yes' on the match refresh rate?

ii. In your nVidia Control Panel instructions below:
Code:
Nvidia:
In this exact order,
Download driver, create new desktop folder, and point it to unzip there. Delete folder after install unless you have a reason to keep it.
Choose Custom Install/Clean Install.
Uncheck 3D Vision Controller Driver unless you need it for some reason.
Uncheck Experience unless you want to add a Windows Credential and be reminded for updates.
Open Control Panel.
Adjust Image Settings with Preview. Quality. Apply.
Set Up Stereoscopic 3D Enable.
The Vision Test Window will open. Select Next and Next again.
Your panel will engage 3D. Select the proper images in the next 2 screens including the scrambled box with a pop-out box inside it.
Finish.
You will return to the desktop in low res 3D mode.
Select Change Resolution in Control Panel.
You will see HD 3D 720 is selected. Change it to HD 3D 1080. Change resolution to 23 or 24 Hz (Doesn't matter). Change Color Format, Depth, and Range to RGB, 12bpc, and FULL.
Select Apply and keep changes before reverting.
[b]Now select your native resolution for Ultra HD, HD, SD. Mine is 4k x 2k 3840 x2160. Change Refresh Rate to 60Hz. Select Apply.[/b]
Make sure RGB Full is still set. Depth will be blank. It's ok. It will revert to 8, 10, or 12 bit depending on the content it's fed in the future.
Remember to play a 2D title, pause it, minimize the player, and readjust these settings if need be. Do the same for 3D and Windows desktop, all individually. Adjust TV settings at the same time. For example. You are playing a 2D title in KODI or PDVD. Check your panel INFO button. It should show you are playing at 24Hz. Minimize it while paused. Check Nvidia Control Panel color format, depth and range. You should still be at RGB Full. Change if needed. It will remember and you will never have to do it again. Check your TV settings are proper. This too will change depending on what you have input but will remember so you don't have to do it again.

Do you leave Stereoscopic 3D "Enabled" or "Disabled" in the control panel. In a previous instruction you had mentioned Disable it after making all the adjustments. However, in this post you didn't mention that. Just wanted to clarify.

Thanks again for your help.
Reply
 
Thread Rating:
  • 39 Vote(s) - 4.49 Average


Messages In This Thread
RE: Kodi 3D Guide - by brazen1 - 2015-06-15, 22:20
RE: Kodi 3D Guide - by brazen1 - 2015-06-15, 22:29
RE: Kodi 3D Guide - by michaelsammler - 2015-06-22, 00:38
RE: Kodi 3D Guide - by brazen1 - 2015-06-23, 17:15
RE: Kodi 3D Guide - by michaelsammler - 2015-06-24, 02:23
RE: Kodi 3D Guide - by brazen1 - 2015-06-24, 17:22
RE: Kodi 3D Guide - by michaelsammler - 2015-06-25, 09:26
RE: HOW TO - Kodi 2D & 3D Guide Internal & External Players Incl afedchin build - by luci5r - 2016-10-12, 19:10
HELP! - by brazen1 - 2018-08-22, 18:50
RE: HELP! - by zxaura1 - 2018-08-24, 09:32
Problem with DXVA scaling videos - by obstler - 2018-10-27, 10:13


Logout Mark Read Team Forum Stats Members Help
HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players4.4939