•   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
#46
(2015-07-09, 09:48)Gizmo81 Wrote: Hi, at moment I'm at 701 and I want to wait for beta of Kodi 16 before I switch to a higher of your builds.
I have a problem in kodi 15 which you maybe can fix in 16, because you also fixed the other library clean problem
with source no longer available, but it was.
My problem now: CreateLoader - Unsupported protocol(plugin) in plugin://plugin.video..... warning during video library clean.

I see you've started a thread which is the best option - if a PR becomes available I'll include it in a Kodi 16 build.

PS. I'd suggest adding to your thread a full debug log (wiki) that includes the "Unsupported protocol(plugin)" messages as your description of the message isn't very clear (it's not complete, for a start).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#47
(2015-07-09, 11:57)Milhouse Wrote:
(2015-07-09, 09:48)Gizmo81 Wrote: Hi, at moment I'm at 701 and I want to wait for beta of Kodi 16 before I switch to a higher of your builds.
I have a problem in kodi 15 which you maybe can fix in 16, because you also fixed the other library clean problem
with source no longer available, but it was.
My problem now: CreateLoader - Unsupported protocol(plugin) in plugin://plugin.video..... warning during video library clean.

I see you've started a thread which is the best option - if a PR becomes available I'll include it in a Kodi 16 build.

PS. I'd suggest adding to your thread a full debug log (wiki) that includes the "Unsupported protocol(plugin)" messages as your description of the message isn't very clear (it's not complete, for a start).

Thanks, I've added the whole block with update and clean library.
#48
Version #0701 and #0703

With these 2 versions, when I play flac stereo 16/44.1 (CD quality) file, I get 4-5 drops / hour. Drops are 1/4 second.
I use to play in "Media info" view
With ssh/top %CPU is 78-92 depending of the file.
When I change to full screen view % CPU drop at 15-25. I didn't test long time with this screen.

I never had drop with stereo CD quality flac file so far.

With HD I have drops as well but not more (4-5/hour).
Few versions ago (15) this was good without drop even multichannel HD flac.

Did you notice that?
Is it a regression?

My config (not playing)
http://xbmclogs.com/pxx7peu6q

Let me know if you need more info/test.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
#49
@MrNice: could you possibly narrow down the build when this started happening?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#50
I'll try but I don't have any clue when it started.
So it could take some time due to the very low frequency of the drops.

Let me know: Is the %CPU usual for a RPi1 512 playing stereo 16/44.1 file?
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
#51
(2015-07-09, 19:54)MrNice Wrote: Let me know: Is the %CPU usual for a RPi1 512 playing stereo 16/44.1 file?

No 78-92% is not usual.

I'm playing a FLAC 16 bits/44.1 kHz/2 channels file here on a 1GHz Pi1 (Model B) and CPU load is 26%, which is basically just above idling (I don't use any music visualisations).

Can you test with stock Confluence, no visualisations?

Edit: Looking at your debug log, you're already using stock Confluence. Hmmm... try a clean .kodi with default settings (mv .kodi .kodi.bak), in case an add-on or setting is causing a problem?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#52
New OpenELEC Isengard build #0709: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.1 #1 Thu Jul 9 21:54:02 BST 2015 armv6l GNU/Linux

# vcgencmd version
Jul  8 2015 18:11:40
Copyright (c) 2012 Broadcom
version 9702675b541cff9f37d30decd45f5e21bf4d9a34 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150709215313-#0709-ga7bea58 [Build #0709]

# vcdbg log msg 2>&1 | grep DTOK
001559.642: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (a7bea58d, changelog) and tip of XBMC master (a6c686ba, changelog) with the following modifications: Build Highlights:
  1. CVariants (with fix)
Build Details:
  1. OpenELEC:
    • pvr-addons: bump hts, myth, vbox (a7bea58d)
  2. XBMC:
    • Problem with display of .idx/.sub (Vobsub) subtitles - Trac ticket #11006 work (PR:7, 3 commits, 2 files changed)
    • [xbmc] Fix includes of CVariant and some improvements (PR:7287, 2 commits, 194 files changed)
    • remove slingbox support (PR:7446, 3 commits, 27 files changed)
    • configure.ac: update verification of shairplay (PR:7458, 1 commit, 1 file changed)
    • Ffmpeg bump 27 master (PR:7415, 3 commits, 2 files changed)
    • various compiler warnings (PR:7459, 3 commits, 3 files changed)
    • [confluence] fix missing "Not Rated" condition (PR:7423, 1 commit, 1 file changed)
    • Adjust return in GetModificationDate (PR:7463, 1 commit, 1 file changed)
    • [xbmc][cvariant] Rework the move constructor a bit to make it safe and proper. Not run… (PR:7464, 1 commit, 1 file changed)
    • Inject CPPFLAGS (e.g. to disable FORTIFY) (PR:7229, 1 commit, 1 file changed)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: PR:7462: [backport-resurrect] added: also hide thumbs for unwatched episodes option to show plot is off
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#53
(2015-07-09, 20:10)Milhouse Wrote: Edit: Looking at your debug log, you're already using stock Confluence. Hmmm... try a clean .kodi with default settings (mv .kodi .kodi.bak), in case an add-on or setting is causing a problem?

Version #0607
Did it and reboot.
Removed GUI sound, didn't change all other settings.
When I am on the menu bar window without activity (waited 20 s) ssh/top %CPU kodi.bin is 10.5-14.2 %.
When I am on the "Music, Music add-ons, Add music" list without activity (waited 20 s) ssh/top %CPU kodi.bin is 55.5-59.1 %.
When I am on the "Media info" window not playing no activity (waited 20 s) ssh/top %CPU kodi.bin is 69.5-70.5 %.
When I am on the "Media info" window playing 2ch/16/44 (waited 20 s) ssh/top %CPU kodi.bin is 93.5-94.5 %

Edit:
Version #0411, same values.
If you want a log, please let me know the ssh Command Line to avoid installing the add-on.
Let me know what next.
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
#54
Thanks for the Mouse-Wheel-Support,

but in *0708b* and on the build *0709* i am not able to selective anything in the list.
The Window goes down and up. ..can not score any selection.

I use a newer Logitech Mouse over 2,4GHz Freq.

Ohh - if i move my mouse (watching Video) it make a search run.

I don't can handle my Pi2 on this way, sorry.

The Arrow have no selective Funktion if i go over the Menu bar....
#55
New OpenELEC Isengard build #0710: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.1 #1 Fri Jul 10 21:13:18 BST 2015 armv6l GNU/Linux

# vcgencmd version
Jul  8 2015 18:11:40
Copyright (c) 2012 Broadcom
version 9702675b541cff9f37d30decd45f5e21bf4d9a34 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150710211231-#0710-ga7bea58 [Build #0710]

# vcdbg log msg 2>&1 | grep DTOK
001573.474: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (a7bea58d, changelog) and tip of XBMC master (f3ec74bb, changelog) with the following modifications: Build Highlights:
  1. Fix for recent skin settings change
  2. Include updated RTL8812AU/RTL8821AU driver - should improve 5GHz connectivity (see thread)
Build Details:
  1. XBMC:
    • [langinfo] Remove unused code (PR:7460, 1 commit, 1 file changed)
    • [pvr] bump pvr.vbox to v2.0.1 (PR:7442, 1 commit, 1 file changed)
    • [skinsettings][fix] Missing skinsetting tag is not an error and shouldn't be treated as o… (PR:7474, 1 commit, 1 file changed)
    • FIX: [droid] broken video calibration (PR:7475, 1 commit, 1 file changed)
  2. rtl8812AU_8821AU_linux/master (wuzzeb):
    • New commits in this build:
      • Merge pull request #2 from wuzzeb/master (e4773ef0)
      • Add Netgear A6100 Customer ID (575c99ff)
      • Merge pull request #3 from kpanic/netgear-a6100-customer-id (1a8dfaae)
      • Removed ^M from ioctl_cfg80211.c so now it compiles! (df335518)
      • Merge pull request #5 from v1kko/master (a30713db)
      • Fix compilation issue for undeclared function during debug mode (6dff839c)
      • Merge pull request #9 from Harshavardhana/master (fcc8da8c)
      • Added Vendor and Product ID for Edimax EW-7811UTC (2fd20ceb)
      • Merge pull request #15 from scrivy/master (a32fae16)
      • fix grsecurity issue: assignment of member ‘free_hal_data’ in read-only object (4465ca77)
      • Added new usb interface (Buffalo WI-U2-433DM) (20d8cc56)
      • Merge pull request #18 from dtamada/master (fa67cc90)
      • Added support for TP-Link Archer T4U AC1200 (8b8a75c9)
      • Merge pull request #21 from archshift/master (935057fa)
      • os_dep/linux/os_intfs.c: Do not set iftype to monitor when closing dev (3b100107)
      • os_dep/linux/ioctl_cfg80211.c: Set iftype to station when allocating wdev (d6d0ba72)
      • Add dkms configuration file (707c52d7)
      • Update usb_intf.c (265d1d28)
      • Removed extra cfg80211_rx_mgmt parameter for 3.19 kernel (41e70a32)
      • Added some support for devices. (5f0cbf9e)
      • Forgot to delete a line (4043e042)
      • Turned power save to off.. thought I did this (c588d714)
      • This seems to fix building when DBG = 1 (8c2a02dc)
      • Merge pull request #40 from bits3rpent/master (614ffdd8)
      • Merge pull request #36 from mpoly/patch-1 (c23d0ad0)
      • Merge pull request #31 from vicentllongo/dkms (8b0baf81)
      • Merge pull request #27 from andreas-hofmann/master (a4c6e0c2)
      • Merge pull request #17 from ITDefence/master (5cb3f782)
      • Ignore build files (9a00b2f7)
      • Add support for TP-Link Archer T4UH AC1200 thanks to @JudgeZarbi - fixes #35 (c87881c8)
      • Remove wrong usage of __no_const (2bf19d4f)
      • Support Linux 4.0.0, change enum NL82011 flags to match upstream changes - fixes #41 (d5fd80bd)
      • Typo BL->NL for 4.0.0 kernel (c33c3d4c)
      • exposed KVER make option to command line and added vagrant tests for Linux 4.0.1 to make check (c5a73124)
      • Merge pull request #45 from krichter722/vagrant_tests (2cadedc8)
      • changed simple -e bash test with md5sum validation of kernel .deb packages in vagrant compilation tests (5030184b)
      • added fetch.sh (0a1f7181)
      • Merge pull request #46 from krichter722/vagrant_tests_md5sum (446ac59e)
      • date-time warning suppression is not needed fixes #44 (12217798)
      • Fix cfg80211_rx_mgmt missing argument on 3.12.0 --> 3.19.0 kernels (6f6d2821)
      • Remove STATION_INFO_ASSOC_REQ_IES usage (ab1ec549)
      • Update for >= 4.0.0 (927b08e0)
      • Merge pull request #55 from hackdefendr/patch-1 (0d5fb760)
      • Fix compilation problems on 3.18 kernel fixes #52 (3914b777)
      • Cleanup makefile (4b53eb75)
      • Update README.md (77a5fb9b)
      • Merge pull request #56 from pgroenbech/patch-1 (bdb931b5)
      • Add Raspberry Pi system build option (aedcffa5)
      • Merge pull request #57 from rhadman/master (4dc31803)
      • Fix for Oops encountered using Edimax AC600 adapter. Logically this can occur on any system with any 5G interface using this driver. (acdb5afc)
      • Fix debug message if conditions. These were using if (BAND_ON_5G) type logic, but these values are values from an enum and need to be compared to something for (d06b500c)
      • Merge pull request #58 from rhadman/ac600-fix (b3759978)
      • Merge pull request #59 from rhadman/log-fix (54ceed74)
      • Update Makefile (7dab2796)
      • Update Makefile (41ce7f09)
      • EFUSE_MAX_MAP_LEN (e3485d17)
      • Make 2 messages info (ebdc61a8)
      • Merge pull request #62 from AndyPi/master (c0996edb)
      • Various (f951824a)
      • Update .gitignore (f1e0a177)
      • const u8 *mac (aa7a4b27)
      • Merge branch 'master' of https://github.com/AndyPi/rtl8812AU_8821AU_linux (b36411ad)
      • Merge pull request #65 from AndyPi/master (c0154d92)
      • array IndexBW40_Base too small, generates error at O2 optimisation (3330897e)
      • warning: array subscript is above array bounds. Cribbed from v4.3.7_11618.20141029 (ff36d4da)
      • naive changes to osdep/linux/ioctl_cfg80211.c:4561 mgmt_tx parameter changes in 3.14 cribbed from file:/rtl8811AU_linux_v4.3.7_11618.20141029 (8c6e9c7e)
      • change calibration runs back to 3 (to reduce time spent calibrating) , hard-coded array size as 10. Cause is probably gcc compiler bug (b3b77917)
      • Revert "change calibration runs back to 3 (to reduce time spent calibrating) , hard-coded array size as 10. Cause is probably gcc compiler bug" (800fe88f)
      • change calibration runs back to 3 (to reduce time spent calibrating) , hard-coded array size as 10. Cause is probably gcc compiler bug (4bbf2d89)
      • Merge pull request #66 from AndyPi/master (6280806f)
  3. kernel 4.1.y:
    • New commits in this build:
      • Added support for 2 mcp2515 CAN Bus IC (c66887bb)
  4. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#56
(2015-07-10, 09:30)MrNice Wrote: Version #0607
Did it and reboot.
Removed GUI sound, didn't change all other settings.

So this was with a fresh .kodi folder, with completely default settings (other than GUI sounds)?

(2015-07-10, 09:30)MrNice Wrote: When I am on the menu bar window without activity (waited 20 s) ssh/top %CPU kodi.bin is 10.5-14.2 %.
When I am on the "Music, Music add-ons, Add music" list without activity (waited 20 s) ssh/top %CPU kodi.bin is 55.5-59.1 %.
When I am on the "Media info" window not playing no activity (waited 20 s) ssh/top %CPU kodi.bin is 69.5-70.5 %.
When I am on the "Media info" window playing 2ch/16/44 (waited 20 s) ssh/top %CPU kodi.bin is 93.5-94.5 %

Sorry for being thick but I'm not entirely sure what you are referring to by "Media Info" window, nor do I have an "Add music" option in Music -> Add-ons (I have "Get more...") - can you provide screenshots of these windows, so that we're on the same page etc.

Not sure if it applies to Music, but make sure you have "Support browsing into archives" disabled as that option can randomly cause high CPU load whenever the Pi trawls your file system and stumbles across a file it thinks is an archive which then results in vast amounts of CPU and memory being consumed.

(2015-07-10, 09:30)MrNice Wrote: Edit:
Version #0411, same values.
If you want a log, please let me know the ssh Command Line to avoid installing the add-on.
Let me know what next.

To upload a log using ssh: "paste /storage/.kodi/temp/kodi.log" then post the url.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
#57
Quote:So this was with a fresh .kodi folder, with completely default settings (other than GUI sounds)?
Yes, fresh .kodi folder, only removed GUI sound.

Quote:Sorry for being thick but I'm not entirely sure what you are referring to by "Media Info" window, nor do I have an "Add music" option in Music -> Add-ons (I have "Get more...") - can you provide screenshots of these windows, so that we're on the same page etc.
What is the way to provide a screenshot? External camera or software? Sharing site?
Meanwhile, menu bar > Music > Select your attached storage > in the next screen select the album > open the sliding window at the left > "View options, View:" select until you see Media Info. Screen has the list of the album files at left and the selected album folder.jpg at right and info under the picture.
I just tested this is the same %CPU with Media Info, List, Big list. Just Thumbnail is around 80% instead around 93%.

Quote:Not sure if it applies to Music, but make sure you have "Support browsing into archives" disabled as that option can randomly cause high CPU load whenever the Pi trawls your file system and stumbles across a file it thinks is an archive which then results in vast amounts of CPU and memory being consumed.
I never changed this parameter but was enable. So I disabled it. Unfortunately, same %CPU (even after reboot).
Is enable the default?

New log with some play:
http://sprunge.us/NGQQ

Edit:
Meanwhile, menu bar > Music > (This is where you have "Music, Music add-ons, Add music") Select your attached storage >
Config, audio player only:
2T HDD <USB> RPi2/Kodi <HDMI> Denon AVR-2313 <HDMI> LG TV 55UF860V
#58
Latest builds great on a pi 2 with my shiny new full HD 3d projector. Only one odd thing I keep seeing. On pause my pj loses hdmi signal every time and I need to cycle inputs to get it back. I know Optima pjs have low gain on the hdmi. I've got an in line booster and have upped hdmi boost to 5 along with setting hdmi_clock_change_limit to 50. Is there any other setting I should look for to mitigate this?its as if the pi momentarily drops the hdmi output and doesn't get it back until I cycle inputs or replug.
#59
(2015-07-10, 17:55)doldi Wrote: Thanks for the Mouse-Wheel-Support,

but in *0708b* and on the build *0709* i am not able to selective anything in the list.
The Window goes down and up. ..can not score any selection.

I use a newer Logitech Mouse over 2,4GHz Freq.

Ohh - if i move my mouse (watching Video) it make a search run.

I don't can handle my Pi2 on this way, sorry.

The Arrow have no selective Funktion if i go over the Menu bar....

First of all, thanks for the great work. Big Grin

Same here, i've tried with a wired Logitech and Microsoft mouse.
When i don't use the scroll function it all works good, but when i only once use the scroll function i get the same strange behaviour as written above and i have to reboot my RPi2.
#60
(2015-07-11, 10:19)MrNice Wrote: What is the way to provide a screenshot? External camera or software? Sharing site?

With a keyboard, use PrintScreen (I think). From ssh, "texturecache.py screenshot". You may need to select the location to save the first screenshot, choose the "screenshots" folder as you can access this folder over Samba when uploading.

I'd recommend imgur.com for sharing.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 2
  • 3
  • 4(current)
  • 5
  • 6
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510