•   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-07-17, 16:55)zaphod24 Wrote: So far I've avoiding setting the over voltage so as not to set the warranty bit. Be interesting to see how your PI gets along after running for a bit.

You can remove the force_turbo=1 and then over_voltage is allowed without setting warranty bit.
Now as long as the arm is busy enough (it may be for 1080i video, especially if PVR is enabled) you should be in turbo mode all the time when playing.

If not, you can force the governor to be in turbo mode:
Code:
echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

(untested, but I think that may work). This doesn't set the warranty bit.
(2015-07-17, 16:55)zaphod24 Wrote: So far I've avoiding setting the over voltage so as not to set the warranty bit. Be interesting to see how your PI gets along after running for a bit.

Already had at 3 upped to 4 im at 1100Mhz im not worried about overvolting not going to do any damage and by some off chance it did its only $30-35.
(2015-07-17, 15:20)M32134c╘ Wrote: I noticed but forgot to mention is there is no keyboard cursor when typing not big deal just giving heads up

I'll include a potential fix for that (PR7532) in the next build if it isn't already merged.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Isengard build #0717: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.2 #1 Fri Jul 17 21:03:41 BST 2015 armv6l GNU/Linux

# vcgencmd version
Jul 16 2015 19:12:56
Copyright (c) 2012 Broadcom
version bc619b5e5aa64f2b5fdd24f6b6a4e61907027a35 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150717210253-#0717-g3994967 [Build #0717]

# vcdbg log msg 2>&1 | grep DTOK
001580.454: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (39949671, changelog) and tip of XBMC master (2f0e73fd, changelog) with the following modifications: Build Highlights:
  1. Potential fix for missing cursor in keyboard dialog
Build Details:
  1. OpenELEC:
  2. XBMC:
    • fix musicvideo artist artwork not being loaded from the musicdb (fixes #16120) (PR:7511, 1 commit, 1 file changed)
    • [guilib] fadelabel not reading scroll tag (PR:7454, 1 commit, 8 files changed)
    • [PVR Addons] Fix XbmcStreamProperties::GetStreamData to actually return the stream found (PR:7525, 1 commit, 1 file changed)
    • [PVR] Series Recordings - Some cleanup and small fixes (PR:7508, 4 commits, 2 files changed)
    • Add disabled textures for radio buttons and spin controls (PR:7505, 2 commits, 9 files changed)
    • [Confluence] disabled textures + version bump (2f0e73fd)
  3. pvr.hts:
    • Fix support for instant timers. (PR:62, 1 commit, 1 file changed)
  4. newclock4:
    • New commits in this build:
      • fix high cpu load caused by false positive frame limiter (7f8ade53)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: PR:7532: [guilib] fix cursor not always shown in keyboard dialog (fixes #16134)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Could Hifiberry Digi and Hifiberry Digi+ owners confirm if they are still having problems (as originally reported here) when using the latest build, thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Keyboards cursor is working just one thing if you delete everything you type the first letter remains visible once you start typing it goes away.

(2015-07-17, 16:55)zaphod24 Wrote: So far I've avoiding setting the over voltage so as not to set the warranty bit. Be interesting to see how your PI gets along after running for a bit.

It didn't help I even removed my GPU OC still happened. I was watching tv and switched TV input to my pi2 and screen was black it did this twice and other times i was browsing around and the UI went all weird.
Ive never had these issues with any other build but maybe something changed IDK testing #0717 ATM
(2015-07-17, 23:55)M32134c╘ Wrote: Keyboards cursor is working just one thing if you delete everything you type the first letter remains visible once you start typing it goes away.

Confirmed - it appears that PR7532 requires a little more work. Cursor also doesn't appear until you start typing, when it should be visible as soon as the dialog is opened.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-07-17, 23:55)M32134c╘ Wrote: It didn't help I even removed my GPU OC still happened. I was watching tv and switched TV input to my pi2 and screen was black it did this twice and other times i was browsing around and the UI went all weird.
Ive never had these issues with any other build but maybe something changed IDK testing #0717 ATM

Can you switch deinterlace method to "Bob" and remove overclock.
If you still see issues then can you confirm the latest build you believe is stable?
I switched to Bob and removed all overclocks and it still eventually freezes but i can hear my inputs being made i left it alone and eventually it goes to black screen

Last build i didn't have this problem was #0714

I did run debug log with last build and it happens not sure if this will help.

http://sprunge.us/OaRN
(2015-07-18, 02:07)M32134c╘ Wrote: I did run debug log with last build and it happens not sure if this will help.

Your crashlog is from #0715 and the crash is being caused by ApplicationMessenger - try #0715b, as that fixes the ApplicationMessenger crash.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
i did that one also still had problems i tried every release

edit

crap that was kodi.old log ignore it
Replicated it again here is the logs
IDK what one is needed.

Kodi.log
http://sprunge.us/CMFF

Kodi.old.log
http://sprunge.us/UaXJ

edit

it happened again when i plugged in my USB thumb drive message about it mounting then screen went all crazy again maybe the ApplicationMessenger still causing problems?
(2015-07-18, 02:07)M32134c╘ Wrote: Last build i didn't have this problem was #0714

If #07014 is definitely good and #715b is bad, and it still fails with advanced deinterlace disabled, then I think we still have issues with the ApplicationMessenger PR.
There still seem to be other problems reported on that PR.
Good to know thought i was going crazy and maybe my device had issue. Ill test new build when released.
Running 0717. Had an overclock (core_freq=500,v3d_freq=500,h264_freq=500,over_voltage=2) as well as performance for the scaling governor and advanced deinterlacing running this morning. After watching live TV for a while and then exiting, the weird menu navigation problem happened again. The temp was around 64c and this is what was in the log:

09:54:21 42978.957031 T:1967968256 NOTICE: DecodeJpegToTexture: unable to decode to texture special://skin/backgrounds/tv.jpg 1280x720

I've disabled the overclock and gone back to bob deinterlacing to see if the problem occurs.
  •   
  • 1
  • 8
  • 9
  • 10(current)
  • 11
  • 12
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510