•   
  • 1
  • 68
  • 69
  • 70(current)
  • 71
  • 72
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
New OpenELEC Jarvis build #0906: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.6 #1 Sun Sep 6 21:21:06 BST 2015 armv6l GNU/Linux

# vcgencmd version
Sep  2 2015 15:06:26
Copyright (c) 2012 Broadcom
version 65d10bdd7b509391aaf143b30b66246461909f94 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150906210246-#0906-g51eea0c [Build #0906]

# vcdbg log msg 2>&1 | grep DTOK
001735.069: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (51eea0c6, changelog) and tip of XBMC master (7e1a62f1, changelog) with the following modifications: Build Highlights:
  1. libnfs updates. May possibly fix issue reported by @Leopold (see issue #124)
Build Details:
  1. XBMC:
    • fixed, AEDelayStatus is a struct, not a class (PR:7973, 1 commit, 1 file changed)
  2. libnfs:
    • socket: fix deadlock in rpc_reconnect_requeue (PR:127, 1 commit, 1 file changed)
    • socket: also reconnect on write errors (PR:122, 1 commit, 1 file changed)
    • Fix OSX build. (c078a423)
  3. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I have installed build #0905 over OE 5.95.3 and it has used a older movie database than the OE build. Don't know exactly but it looks like a ~1 month older one.
(2015-09-07, 07:34)querty1000 Wrote: I have installed build #0905 over OE 5.95.3 and it has used a older movie database than the OE build. Don't know exactly but it looks like a ~1 month older one.

Can't really do much with a report like that. You need to confirm what database was used in the migration, as these builds will try to migrate the v93 database you were using with 5.95.3. A debug log (wiki) would be helpful.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I asked about overclock settings a few days ago but no one answered (*sniff*). I'll assume since LiveTV is laggy on a stock Pi2 running the latest Millhouse that you're all overclocking to a degree... I suppose my real question is, are you using force_turbo=1, and are you overvolting? If yes, to what degree?
Just tried build #0906 and had some issues with a missing OSD. The AV information overlay would appear (that appears when you press 'o'), but the other stuff - navigation menu at the bottom, time top right etc - wouldn't.

Does this sound like something I should post a log for or is it a known thing?

(Think someone else has mentioned this - and it's probably an OE thing - but the default key mapping for Media Centre RC6 remotes has changed as well)
New OpenELEC Jarvis build #0907: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.6 #1 Mon Sep 7 22:39:27 BST 2015 armv6l GNU/Linux

# vcgencmd version
Sep  2 2015 15:06:26
Copyright (c) 2012 Broadcom
version 65d10bdd7b509391aaf143b30b66246461909f94 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150907223839-#0907-g51eea0c [Build #0907]

# vcdbg log msg 2>&1 | grep DTOK
001713.850: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (51eea0c6, changelog) and tip of XBMC master (6adfe050, changelog) with the following modifications: Build Highlights:
  1. Kodi: rework repository updating
  2. Update pvr.mythtv
  3. mmalrenderer and mmalcodec updates
Build Details:
  1. XBMC:
    • [binary addons] add bootstrapping logic to download addon build definitions from separate repository (PR:7774, 5 commits, 87 files changed)
    • [Confluence]]PVR] Re-add channel icons before timer title (was accide… (PR:7962, 1 commit, 1 file changed)
    • [guilib] The output buffer of IImage:Big Grinecode should be a const pointe… (PR:7965, 1 commit, 5 files changed)
    • [depends] remove no more needed libmp3lame (PR:7974, 1 commit, 2 files changed)
    • [addons] rework repository updating (PR:7874, 8 commits, 22 files changed)
    • [music] Change the way the (album)artists tag are handled (PR:7486, 1 commit, 8 files changed)
  2. pvr.mythtv:
    • 3.3.0 (PR:31, 44 commits, 73 files changed)
    • fix timer state for 'not recording' without conflict (0b925598)
    • fix translation for string 30421 (306db7ad)
    • set of european translations for 30421 (725a519d)
    • create definitions for time values in right place (b527d15c)
    • group globals for the 'record template' (5e1a0f51)
    • clarify what is 'Reset' for programInfo (7b38be06)
    • [cppmyth] track protocol connection error (02a853de)
    • track connection error (0d060f09)
    • new localized strings to notify connection failure (887950b2)
    • notify addon failure (8f8f0f07)
    • more verbosity for notification strings (6152c8c3)
    • [cppmyth] check other services in wsapi init (212f8a1f)
    • [cppmyth] sync upstream 2.3.0 (caa6b39f)
    • [pvr.mythtv] Bump version 3.3.0 (8b7f976d)
  3. newclock4:
    • New commits in this build:
      • [mmalrenderer] Add SetCodecControl function (c5d0b875)
      • [mmalcodec] Enable concealed error frames, but discard them when returned (0fb5927c)
    • Updated commits in this build:
      • [mmalcodec] refector the decoder flags logic to avoid stalls on seek (25354222 => 56ed2ecb)
    • Commits no longer in build:
      • [mmalrenderer] Add SetCodecControl function and prefer to return pictures when renderer is low (disabled) (c6c3aa2a)
      • [mmalcodec] Prefer to return pictures when render queue is low (0d6f7173)
      • Revert "[mmalcodec] Prefer to return pictures when render queue is low" (a1f06328)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Added: PR:7976: [mysql]Add support for hyphenated database names when copying databases
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-09-07, 22:17)buddy123 Wrote: I asked about overclock settings a few days ago but no one answered (*sniff*). I'll assume since LiveTV is laggy on a stock Pi2 running the latest Millhouse that you're all overclocking to a degree... I suppose my real question is, are you using force_turbo=1, and are you overvolting? If yes, to what degree?

You'll have to be a lot more specific.
Are you saying the video lags the audio?
Are you saying the video has frame drops?
Are you saying the GUI is laggy when video is playing in the background?
Do you have an MPEG2 codec licence?
Do you have omxplayer acceleration enabled?
(2015-09-08, 00:02)noggin Wrote: Just tried build #0906 and had some issues with a missing OSD. The AV information overlay would appear (that appears when you press 'o'), but the other stuff - navigation menu at the bottom, time top right etc - wouldn't.

Does this sound like something I should post a log for or is it a known thing?

Not known about by me. Does it do it every time (e.g. straight after boot)?
Does it do it with confluence?
Does reverting to an earlier build fix it? What was the first build with the problem?
(2015-09-08, 12:39)popcornmix Wrote:
(2015-09-08, 00:02)noggin Wrote: Just tried build #0906 and had some issues with a missing OSD. The AV information overlay would appear (that appears when you press 'o'), but the other stuff - navigation menu at the bottom, time top right etc - wouldn't.

Does this sound like something I should post a log for or is it a known thing?

Not known about by me. Does it do it every time (e.g. straight after boot)
Will play again when I have time.
Quote:Does it do it with confluence?
Yes - I seldom use any other skin on my Pi 2s.
Quote:Does reverting to an earlier build fix it? What was the first build with the problem?

Will let you know. (Again when I have time)

Thanks for the amazing work on the Pi 2 builds. I'm incredibly grateful for the excellent support.
New OpenELEC Jarvis build #0908: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.1.6 #1 Tue Sep 8 23:41:49 BST 2015 armv6l GNU/Linux

# vcgencmd version
Sep  2 2015 15:06:26
Copyright (c) 2012 Broadcom
version 65d10bdd7b509391aaf143b30b66246461909f94 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20150908234058-#0908-g51eea0c [Build #0908]

# vcdbg log msg 2>&1 | grep DTOK
001733.080: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (51eea0c6, changelog) and tip of XBMC master (3f18aa64, changelog) with the following modifications: Build Highlights:
  1. Switch to newclock5 branch, replacing DVDPlayer with refactored VideoPlayer.
    (2015-09-03, 13:22)FernetMenta Wrote: Kodi's video player is one of the oldest and most important components of the application. New features and ports to new platforms have long outgrown the original architecture of player. From its internal name "dvdplayer" you can tell how old this component is. In order to cope with current and future requirements like Ultra HD, MVC, 10bit depth, or PiP some elementary changes need to be done. The problem is that those changes require adjustments of platform dependent code. This dependency tremendously slows down development.

    Ideally video player is a self contained component or service with its own life cycle and versioning. This would allow updates and upgrades independently from the main application. One platform could choose to stay with version X while others go with version Y. Maybe video player itself will be comprised of services with its own versions: decoders, demuxers, video/audio renderers, etc.

    This is a long way and we need to get started somewhere. I requested this sub-forum to get platform devs involved, document and discuss what has been done so far, next steps, etc.
    Probably best for @popcornmix to explain expected benefits etc.
Build Details:
  1. XBMC:
    • remove file operation log spam (PR:7979, 1 commit, 2 files changed)
    • [readme] typos and cleanup including whitespaces. (PR:7988, 1 commit, 7 files changed)
    • Corrected label order for songs when ordering by dateadded (PR:7987, 1 commit, 1 file changed)
    • [readmes] Final revision (PR:7990, 1 commit, 4 files changed)
    • Disable CPU temp test on windows (PR:7985, 1 commit, 1 file changed)
    • [mmalcodec] Use settings constants (PR:7981, 1 commit, 1 file changed)
    • [omxplayer] Flush EOS message from queue to avoid it turning up after a seek (PR:7980, 1 commit, 2 files changed)
    • TexturePacker: some cleanup and win32 buildsystem fixes (PR:7961, 3 commits, 4 files changed)
    • [musiclibrary] Made top albums sortable by play count (PR:7884, 1 commit, 1 file changed)
  2. pvr.mythtv:
    • 3.3.1 (PR:32, 2 commits, 45 files changed)
    • Fix syntax in strings file for transifex (PR:33, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • renderer: promote interface up to BaseRenderer (d098cb8d)
      • renderer: refactor RenderManager and LinuxRendererGL (5eb8842a)
      • renderer: fix forced deinterlacing for non-render methods (227147c9)
      • make video renderer non-global (7f31193d)
      • move VideoRenderers (db9d9d5b)
      • rename dvdplayer to VideoPlayer (8980f4fb)
      • AE: refactor IAudioCallback (188a10fd)
      • move audio sync to AE - WIP (43a74418)
      • fixup: Remove build artefact from git tree (5c4547d8)
      • fixup: Fix bug in HasFrame (42d5f51d)
      • [GLES] Fix build with VideoPlayer (509b8ffe)
      • [omxplayer] Update to support VideoPlayer renderer (ade84c05)
      • [MMAL] Update to support VideoPlayer renderer (fcc31e20)
      • pi: fixup some pi patches to VideoPlayer (daa385bd)
      • [DVDDemuxFFmpeg] Ignore extradata for unknown stream types (bbc8d321)
  4. kernel 4.1.y_rebase:
    • New commits in this build:
      • BCM270X_DT: README - add note on indentation (08f17a88)
      • bcm2708-dmaengine: Use more DMA channels (but not 12) (df518282)
      • RaspiDAC3 support (bba9094e)
      • config: Add SND_SOC_ADAU1701 module (01cf510f)
      • spi: bcm2835: set up spi-mode before asserting cs-gpio (0ea0a921)
      • spi: bcm2835: fix overflow in calculation of transfer time (90a45e29)
      • BCM270X_DT: Add SDIO overlay (e0664c2c)
      • Add /dev/gpiomem device for rootless user GPIO access (4e178f3d)
      • tpa6130a2: Add headphone switch control (deb277db)
      • staging: fbtft: Add reset to fbtft_init_display_dt() (a95e79da)
      • BCM270X_DT: mz61581: Revert to spi-bcm2708 (316c4fc6)
  5. Additional commits/pull requests/changes not yet merged upstream:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-09-09, 01:40)Milhouse Wrote: Probably best for @popcornmix to explain expected benefits etc.

Currently it should behave pretty much as before, but there are internal architectural changes.

Now the video renderer is no longer a single global object, but something that is created and destroyed as needed.
In theory this could allow multiple players in the future (e.g. picture-in-picture).

There are planned improvements that will probably only come to VideoPlayer and not dvdplayer, so supporting VideoPlayer means we don't miss out. E.g.

(2015-09-04, 23:13)FernetMenta Wrote: In v15 a/v synchronization to clock was changed. The former mechanism was dead end and led to a couple of non-solvable issues. Versions prior to 15 adjusted large audio sync errors (> 100ms) by synchronizing the clock to audio. This made video and subtitles suffer from audio errors. Malfunctioning audio could ruin video completely.

Now audio and video sync to clock independently when a stream is started. This chnage requires follow-ups that have not implemented yet. When synchronization is started, audio stream has to be muted and flushed, otherwise the sync process which adds and drops audio packets to the queue would be audible.

The solution is to move this process from VideoPlayerAudio to the audio engine. This task has high priority on my todo list.

If you spot a change in behaviour from the previous build (good or bad) then report it here.
why youtube order is not the same after updating to alfa 3
this is how is looks now
Image
and this is how it supose to look
Image

build OpenELEC-RPi.arm-6.0-devel-20150902231737-#0902-g4aff2c2
http://forum.kodi.tv/showthread.php?tid=...pid2096442
is latest build that have working order
(2015-09-03, 17:07)metaron Wrote:
(2015-09-01, 23:07)popcornmix Wrote:
(2015-08-31, 21:02)metaron Wrote: I'm having problems seeking / with 4:3 to 16:9 transitions on RPi with the latest build (New OpenELEC Jarvis build #0830: RPi) using both the OMXPlayer and MMAL acceleration options. This seems to affect channels when they use different formats/bitrates for ads and shows.

Thanks for detailed bug report. I can see the cause of the MMAL issue. If you disable deinterlace it should work correctly again (would be useful if you can confirm that).

Basically the video_decode component can generate notification messages. One of these is aspect ratio has changed.
However when deinterlace is enabled we tunnel video_decode to image_fx (which does the deinterlace) and that's where the notification goes, and kodi doesn't see it.

I suspect I'll need to plumb in similar notifications from image_fx to fix this problem.

Yes, I can confirm that with interlace disabled using MMAL kodi correctly changes aspect ratio but that with deinterlace set to 'auto' or 'on' the change in aspect doesn't occur.

Disabling deinterlace also fixes the lockup problem in OMXPlayer mode, so good news all round :-).

@popcornmix - thanks for the fix (I think?)
Builds #0908 and #0907 allow me to skip across the aspect change with both OMXPlayer and MAML acceleration with deinterlace set to 'half' on my PI2.

The aspect fix works on my original RPi as well, but it looks like it can't cope with 'half' deinterlace method.
The strange thing is after experimenting with different builds, I now have two SD cards. Both with build #0824 for RPi.
  • One gives me deinterlace options: Auto select, MMAL - Bob (half), MMAL - Bob, MMAL - Advanced (half), MMAL - Advanced.
  • The other just shows 'half' and the option to change deinterlace method is greyed out.
This is testing playback using the same file. I even tried a 'soft' reset on the one only showing 'half' but it didn't seem to make any difference to the deinterlace options presented.

I'm guessing there's some option/config file which was set up by an earlier build on one sdcard, but not the other which enables MAML deinterlace methods - but where is it and how do I set it up manually?
(2015-09-09, 19:55)metaron Wrote:
  • One gives me deinterlace options: Auto select, MMAL - Bob (half), MMAL - Bob, MMAL - Advanced (half), MMAL - Advanced.
  • The other just shows 'half' and the option to change deinterlace method is greyed out.

I suspect you don't have the MPEG2 codec licence on the second one.
(2015-09-09, 19:59)popcornmix Wrote:
(2015-09-09, 19:55)metaron Wrote:
  • One gives me deinterlace options: Auto select, MMAL - Bob (half), MMAL - Bob, MMAL - Advanced (half), MMAL - Advanced.
  • The other just shows 'half' and the option to change deinterlace method is greyed out.

I suspect you don't have the MPEG2 codec licence on the second one.

Correct. (I was just checking that when your posting came through!)

I thought MMAL playback didn't use the MPEG2 codec, but I guess you still need it for the MMAL deinterlace methods :-(.

Anyway, unfortunately it seems I was a little hasty in saying my issue was fixed. With the codec installed and build #0908 loaded, back the aspect ratio issue came. Guess I need to be a little more patient...
  •   
  • 1
  • 68
  • 69
  • 70(current)
  • 71
  • 72
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510