Problem with an HDMI 7 inch LCD (Waveshare)
#31
(2016-04-12, 23:54)DaniiSahne Wrote: Thank you rascas,

anything worked fine until the step to install kodi via apt-get. Then the message appears:

Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
kodi : Hängt ab von: kodi-bin (>= 2:17.0~git20160313.188ff0e-1~jessie) aber 2:15.2-2~jessie soll installiert werden
        Empfiehlt: libva-intel-vaapi-driver ist aber nicht installierbar

As it seems apt-package kodi is depending on kodi-bin. Also libva-intel-vaapi-driver must be installed but isn't installable.
If I try to install kodi-bin, another message appears and points out that kodi-bin is depending on libcrossguid1. And after try to install this package message came with:

Code:
E: Package 'libcrossguid1' has no installation candidate


I don't know what it's wrong here. Confused

You also enabled the unstable repo (which isn't in the instructions) but not correctly. First, follow only the instructions that I have provided, carefully.
Reply
#32
EDIT:

Okay, after some short brainwork and nice try I got the solution.
I have added the repo source how you called in your description with:

Code:
deb http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /

On the Pipplware Site there is named another repo source. So I added this, too.

Code:
deb http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary /

..made an..

Code:
apt-get update && sudo apt-get dist-upgrade

And 'et voila' I was able to install kodi via:

Code:
apt-get install kodi

After starting kodi via link in LXDE start panel, there were these lines again. So I tried something. And seemingly Kodi wants to have an input or an update of changing of the menu at first. After I tapped on an menu entry (I didn't saw anything at this moment, only these lines) the video output switched normally. Resolution is okay and the input works also fine.
Thank you so much for helping me!RoflBig Grin

Image

But why these lines appear at the beginning?
Image

greetingsWink
Reply
#33
EMPTY
Reply
#34
(2016-04-13, 00:07)rascas Wrote:
(2016-04-12, 23:54)DaniiSahne Wrote: Thank you rascas,

anything worked fine until the step to install kodi via apt-get. Then the message appears:

Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
kodi : Hängt ab von: kodi-bin (>= 2:17.0~git20160313.188ff0e-1~jessie) aber 2:15.2-2~jessie soll installiert werden
        Empfiehlt: libva-intel-vaapi-driver ist aber nicht installierbar

As it seems apt-package kodi is depending on kodi-bin. Also libva-intel-vaapi-driver must be installed but isn't installable.
If I try to install kodi-bin, another message appears and points out that kodi-bin is depending on libcrossguid1. And after try to install this package message came with:

Code:
E: Package 'libcrossguid1' has no installation candidate


I don't know what it's wrong here. Confused

You also enabled the unstable repo (which isn't in the instructions) but not correctly. First, follow only the instructions that I have provided, carefully.

Okay. In order to do it correctly, how I can fix this with these depending packages?
Reply
#35
Not sure why those lines appear. I didn't understand if it is working fine now... If that lines appear only when starting up Kodi, it shouldn't be a problem (at least a big one), maybe some bug in how the screen, rpi and kodi comunicate.

(2016-04-12, 23:54)DaniiSahne Wrote: Thank you rascas,

anything worked fine until the step to install kodi via apt-get. Then the message appears:

Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
kodi : Hängt ab von: kodi-bin (>= 2:17.0~git20160313.188ff0e-1~jessie) aber 2:15.2-2~jessie soll installiert werden
        Empfiehlt: libva-intel-vaapi-driver ist aber nicht installierbar

As it seems apt-package kodi is depending on kodi-bin. Also libva-intel-vaapi-driver must be installed but isn't installable.
If I try to install kodi-bin, another message appears and points out that kodi-bin is depending on libcrossguid1. And after try to install this package message came with:

Code:
E: Package 'libcrossguid1' has no installation candidate


I don't know what it's wrong here. Confused

If Kodi already starts up and is working fine, the dependency problem is already solved.
Reply
#36
(2016-04-13, 00:56)rascas Wrote: Not sure why those lines appear. I didn't understand if it is working fine now... If that lines appear only when starting up Kodi, it shouldn't be a problem (at least a big one), maybe some bug in how the screen, rpi and kodi comunicate.

I said that because for now it is the first time that it is working. Yes, you're right. Not all is working fine.
But I am really surprised about that.

I doesn't make sense to me that this package is expected: libva-intel-vaapi-driver
Reply
#37
(2016-04-13, 01:04)DaniiSahne Wrote: I said that because for now it is the first time that it is working. Yes, you're right. Not all is working fine.
But I am really surprised about that.

I doesn't make sense to me that this package is expected: libva-intel-vaapi-driver

That is not a dependency, it is a suggested one if you have an intel chip, which is not the case, obviously. Like I said the dependencies should be already corrected, you can check by updating the system and not having any errors.
Reply
#38
Should have bought one that was tested on kodi. Wow! You've been searching. https://www.youtube.com/watch?v=WbxRf8BejnY
Reply
#39
@rascas

When follow your instruction on https://www.raspberrypi.org/forums/viewt...75#p936238

I come only to step
Code:
sudo apt-get install kodi

Then I get this again:
Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
kodi : Hängt ab von: kodi-bin (< 2:16.0-2~jessie.1~) aber 2:17.0~git20160313.188ff0e-1~jessie soll installiert werden
        Empfiehlt: libva-intel-vaapi-driver ist aber nicht installierbar
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

It looks similar to the previous try to install.
Reply
#40
You did something wrong, don't now what, I cannot reproduce it. Did you updated with dist-upgrade before installing kodi ?

Code:
sudo apt-get update && sudo apt-get dist-upgrade
Reply
#41
Yep I've done.
Should I only let the
Code:
deb http://pipplware.pplware.pt/pipplware/dists/jessie/main/binary /

as one repository alone in /etc/apt/sources.list.d/pipplware_jessie.list without the others in /etc/apt/sources.list? Comment out? So that pipplware-Repo is the only Repo?

If not, I have it done right.
Reply
#42
I've tried it again via the instruction. The result was the same.
Reply
#43
You just have to follow the instructions. There is nothing that says to remove other repos. By adding the unstable repo, you already did not follow the instructions accordingly, altough it shoud work fine, at least without that error.
Any more questions about it, use the topic of Kodi in that link. This is getting offtopic.
Reply
#44
Okay.


To show you, what comes when I make an apt-get update && apt-get dist-upgrade, here it is..

Code:
[email protected]:~# apt-get update && apt-get dist-upgrade
Get:1 http://archive.mene.za.net jessie InRelease [3346 B]
Hit http://archive.raspbian.org jessie InRelease                                                                        
Hit http://pipplware.pplware.pt  InRelease                                                                              
Hit http://archive.raspberrypi.org jessie InRelease                                                                      
Get:2 http://archive.mene.za.net jessie/contrib armhf Packages [13.3 kB]                                                
Hit http://http.debian.net jessie-backports InRelease                                                                    
Hit http://archive.raspbian.org jessie/main Sources                                                                      
Hit http://archive.raspbian.org jessie/contrib Sources                                                                  
Hit http://pipplware.pplware.pt  Packages                                                                                
Ign http://archive.mene.za.net jessie/contrib Translation-en                                                            
Hit http://archive.raspbian.org jessie/non-free Sources                                                                  
Hit http://archive.raspberrypi.org jessie/main armhf Packages                                                            
Hit http://archive.raspbian.org jessie/rpi Sources                                                                      
Hit http://archive.raspberrypi.org jessie/ui armhf Packages                                                              
Hit http://mirrordirector.raspbian.org jessie InRelease                                                                  
Hit http://mirrordirector.raspbian.org jessie/main armhf Packages                                                        
Hit http://http.debian.net jessie-backports/main armhf Packages                        
Hit http://mirrordirector.raspbian.org jessie/contrib armhf Packages                    
Hit http://mirrordirector.raspbian.org jessie/non-free armhf Packages                  
Hit http://mirrordirector.raspbian.org jessie/rpi armhf Packages                                                        
Hit http://http.debian.net jessie-backports/main Translation-en                                                          
Ign http://archive.raspberrypi.org jessie/main Translation-en                                                            
Ign http://archive.raspberrypi.org jessie/ui Translation-en                            
Ign http://pipplware.pplware.pt  Translation-en                  
Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
Ign http://mirrordirector.raspbian.org jessie/main Translation-en
Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
Fetched 16.6 kB in 12s (1354 B/s)                                                                                        
Reading package lists... Done
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  kodi-bin libao-common libao4 libcec3 libcrossguid1 liblockdev1 libmicrohttpd10 libmysqlclient18 libnfs4 libpcrecpp0
  libpulseeight-platform1 libshairplay0 libtinyxml2.6.2 libva-x11-1 mysql-common pypy-upstream-doc python-bluez
  python-imaging python-simplejson
Use 'apt-get autoremove' to remove them.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reply
#45
Okay, there was an "apt-get autoremove" to do. I shall read the info-messages.
Could install Kodi now.

EDIT: But now after starting Kodi there is the Display-Problem again and it not switch to normal.
Reply



Logout Mark Read Team Forum Stats Members Help
Problem with an HDMI 7 inch LCD (Waveshare)1
This forum uses Lukasz Tkacz MyBB addons.