•   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
I've continued looking at scripting for sending keystrokes after installing new version 0.4.9 (Thanks logi85)...

I've realised that sendkeys isn't doing anything in Edge.. and probably the other browser too on Windows 10 Sad Chrome key-presses work independently of Kodi.

Launcher script for Edge:

I suggest adding /f to the end of TASKKILL /im MicrosoftEdge.exe otherwise any old Edge session isn't closed before launch.

The line attempting to call sendkeys to maximise the Edge window causes the script to end before Edge closes. If the line is removed the "Push BACK to go back"... etc screen remains up on Kodi until Edge is closed.
Reply
I submitted a pull request containing scripts that will enable MCE style remotes on linux (and others) as well as turn down the volume (netflix starts full volume which is annoying.)

it has a dependency on xbindkeys which you will need to install using apt-get possibly.
Reply
@jeremy White

Have you tried adding

Code:
Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"
EndSection


to your xorg.conf ?
Reply
(2016-01-09, 05:16)Jeremy White Wrote:
(2016-01-09, 02:17)logi85 Wrote: I guess you use a Nidia gpu right? This flag seams to be Nidia only. However if vsync is enabled in driver, the card only draws full screens so there should be no tearing. Had this issues with Nidia but now I use Intel gpu.

No. I'm on an Intel GPU.

The tearing wasn't hugely noticeable until it was gone. Not sure why you are not seeing it. I only have a few testbeds myself.

But, I'm pretty sure lxdm won't do proper compositing.

I am not sure if that helps but with Openelec and Netflix over Chromium I also had bad tearing.
What I did was create a custom Xorg.conf and now no more taring.

Code:
Section "Device"
  Identifier  "Device0"
  Driver      "intel"
  Option "TearFree" "true"
  VendorName  "INTEL Corporation"
EndSection

I am using a braswell AsRock Beebox n3150
Reply
(2016-01-08, 01:56)j41224 Wrote: I have an issue where once I issue the command alt + f4 that the browser closes, shows Kodi briefly, then the show starts again. It's an endless loop unless I quickly close Kodi as well. This is the case on Kodi 15.2 and Windows 7 on 32 and 64 bit using Flix2Kodi 0.4.7. This is on the Chrome Browser.

I am also having this issue with Chrome, endless loop. Kodi 14.2 Win7 64bit, Chrome 47.0.2526.106 m

I think I've narrowed the problem down... when I go into a show then select a specific season and then episode, then stop watching it (I'm using the autohotkey script from tree_and_kite), it does NOT open the chrome browser again and I can continue in Kodi. When selecting the show and clicking "continue watching" (i.e via the context menu button, normally C on the keyboard) then it will start the endless loop when you try to close Chrome... is this something that would show up in logs?
Reply
Would it be possible on Openelec to add an option to switch the frame rate to 24p when starting to stream a movie form netflix?
And then switch back when returning to Kodi.

I know that dynamic framerate switching is not possible but maybe with an extra setting we can adjust it semi-manually.
For example by pressing the context menu and then have an extra option "play 24p" or something like that
Reply
(2016-01-09, 09:12)bmac88 Wrote:
(2016-01-08, 01:56)j41224 Wrote: I have an issue where once I issue the command alt + f4 that the browser closes, shows Kodi briefly, then the show starts again. It's an endless loop unless I quickly close Kodi as well. This is the case on Kodi 15.2 and Windows 7 on 32 and 64 bit using Flix2Kodi 0.4.7. This is on the Chrome Browser.

I am also having this issue with Chrome, endless loop. Kodi 14.2 Win7 64bit, Chrome 47.0.2526.106 m

I think I've narrowed the problem down... when I go into a show then select a specific season and then episode, then stop watching it (I'm using the autohotkey script from tree_and_kite), it does NOT open the chrome browser again and I can continue in Kodi. When selecting the show and clicking "continue watching" (i.e via the context menu button, normally C on the keyboard) then it will start the endless loop when you try to close Chrome... is this something that would show up in logs?

Try using 'continue watching' without the AHK script running just to make the script isn't interfering with anything.

If it still loops, post your log.
Reply
(2016-01-09, 03:02)tree_and_kite Wrote: here's the new script: https://dl.dropboxusercontent.com/u/1122...etflix.zip

do this:

1. run keypressOSD.exe and make sure your number buttons show correctly
2. run close.exe
3. open chrome
4. press '5' and chrome should close and you're good to go
5. if step 4 fails trying closing chrome with '0'

please try this with other browsers too

RoflBig GrinNod

Yes, I am very happy!! The last hurdle is taken! Thanks so much! Everything works perfectly!!

In Chrome: 5 & 0 closes the window
In Edge & IE: 5 closes the window, 0 does not seem to do anything..

Finally I can get rid of my keyboard again! Great work!

Soon I will make the same setup on my Nuc in the living room, and then I can test 5.1 and 1080p. I'll come back with my findings here..

Logi85 and Zero also thanks again for all the great work you have done so far!
Reply
(2016-01-06, 18:16)Cassiuss Wrote: Also tried to program alt+F4 on my harmony remote (that I am using downstairs, upstairs I have a cheap chinese MCE remote) but can't get this to work as well..

And tried to remap some keys with LM Remote keymap, but this did not work as wel..

Maybe one of the things that I have tried is interfering with the other, I don't know, but it is starting to get annoying Big Grin

Haven't read the entire thread, maybe you already fixed this. It worked for me after disabling the MCERemote addon.
Make sure the key you program onto the Harmony is linked with the proper activity and/or device.
Reply
(2016-01-09, 13:45)Cassiuss Wrote:
(2016-01-09, 03:02)tree_and_kite Wrote: here's the new script: https://dl.dropboxusercontent.com/u/1122...etflix.zip

do this:

1. run keypressOSD.exe and make sure your number buttons show correctly
2. run close.exe
3. open chrome
4. press '5' and chrome should close and you're good to go
5. if step 4 fails trying closing chrome with '0'

please try this with other browsers too

RoflBig GrinNod

Yes, I am very happy!! The last hurdle is taken! Thanks so much! Everything works perfectly!!

In Chrome: 5 & 0 closes the window
In Edge & IE: 5 closes the window, 0 does not seem to do anything..

Finally I can get rid of my keyboard again! Great work!

Soon I will make the same setup on my Nuc in the living room, and then I can test 5.1 and 1080p. I'll come back with my findings here..

Logi85 and Zero also thanks again for all the great work you have done so far!

Excellent. Glad it's working for you.

0 not working in other browsers is expected behaviour so don't worry about that.
Reply
Hi, Ive just installed v0.49 on windows 10 and I found with explorer, edge and chrome the Netflix login page loads fine. Do you normally have to manually login to Netflix or is this process supposed to be automated ?
Reply
Yes, you have to login manually on first run.
Reply
(2016-01-09, 10:20)tree_and_kite Wrote:
(2016-01-09, 09:12)bmac88 Wrote:
(2016-01-08, 01:56)j41224 Wrote: I have an issue where once I issue the command alt + f4 that the browser closes, shows Kodi briefly, then the show starts again. It's an endless loop unless I quickly close Kodi as well. This is the case on Kodi 15.2 and Windows 7 on 32 and 64 bit using Flix2Kodi 0.4.7. This is on the Chrome Browser.

I am also having this issue with Chrome, endless loop. Kodi 14.2 Win7 64bit, Chrome 47.0.2526.106 m

I think I've narrowed the problem down... when I go into a show then select a specific season and then episode, then stop watching it (I'm using the autohotkey script from tree_and_kite), it does NOT open the chrome browser again and I can continue in Kodi. When selecting the show and clicking "continue watching" (i.e via the context menu button, normally C on the keyboard) then it will start the endless loop when you try to close Chrome... is this something that would show up in logs?

Try using 'continue watching' without the AHK script running just to make the script isn't interfering with anything.

If it still loops, post your log.

Just confirmiing I have this looping issue too and the AHK script isn't the cause.

Here's my log http://pastebin.com/hb0rBqVu


@logi85

Could you add the ability to use an exe instead of a cmd file in the custom folder?
Reply
It's a little bit off topic, sorry about that, but I have googled for the last hour or so without solution.

the problem: in Chrome I get 720p, so I decided to go with IE to get 1080p. But in IE I can not play/pause with any button. I tried spacebar/return/ctrl+p, and the menu will pop up, but it does not pause the stream.. Then I tried pretty much every key (on my keyboard), with no result, googled but without result as well.. Does anyone here know if it is possible to pause a movie in IE with a key press?

I also thought that IE supported 5.1 sound, but apparently that is not true either.. According to netflix surround is not possible when streaming from a browser:
https://help.netflix.com/en/node/14163
"5.1 surround sound is not currently supported while streaming on a computer using Microsoft Silverlight or HTML5. However, it is supported in the Netflix app for Windows 8."

I assume Edge will make no difference then? Does edge use Silverlight or HTML5?

Now I realized I haven't tried Edge for my pause/play problem, I will try later on.. (assuming that Edge will support 1080p) and report back..

EDIT: Ok, Edge gives me 1080p and the play/pause works with enter/spacebar (ok button on my remote) but it does not start in full screen.. So I'll stick with IE for now, and will use my phone as a mouse if I need to pause it..
Reply
(2016-01-10, 04:49)tree_and_kite Wrote:
(2016-01-09, 10:20)tree_and_kite Wrote:
(2016-01-09, 09:12)bmac88 Wrote: I am also having this issue with Chrome, endless loop. Kodi 14.2 Win7 64bit, Chrome 47.0.2526.106 m

I think I've narrowed the problem down... when I go into a show then select a specific season and then episode, then stop watching it (I'm using the autohotkey script from tree_and_kite), it does NOT open the chrome browser again and I can continue in Kodi. When selecting the show and clicking "continue watching" (i.e via the context menu button, normally C on the keyboard) then it will start the endless loop when you try to close Chrome... is this something that would show up in logs?

Try using 'continue watching' without the AHK script running just to make the script isn't interfering with anything.

If it still loops, post your log.

Just confirmiing I have this looping issue too and the AHK script isn't the cause.

Here's my log http://pastebin.com/hb0rBqVu


@logi85

Could you add the ability to use an exe instead of a cmd file in the custom folder?

Hi, much easier, just call the exe in a custom script. And keep in mind to block until browser closed.
Reply
  •   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.