19 Nov 2019 - TVDB are still in the process of fixing a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are still working to rectify the problems.

  •   
  • 1
  • 167
  • 168
  • 169(current)
  • 170
  • 171
  •   
Release Kanzi: Amazon Alexa skill for Kodi
any chance for google assistant support?
Reply
(2019-06-11, 17:22)Skank Wrote: any chance for google assistant support?
That would need a complete rewrite, effectively a different project afaik
Reply
(2019-06-11, 18:53)CHBMB Wrote:
(2019-06-11, 17:22)Skank Wrote: any chance for google assistant support?
That would need a complete rewrite, effectively a different project afaik 
damn Undecided
Reply
"An error has occurred in response to the requested skill"

Which logs I can look at to narrow down the error.

App was deployed to heroku.

I use ipv6 because i only have a dslight-COnnection to the internet (unity media)
MLD 5.4
OctopusNet
Libreelec
Reply
Oh ... i see 

==> 2019-06-16T18:48:20.098922+00:00 app[web.1]: ConnectionError: HTTPConnectionPool(host='sopport.dynv6.net', port=8080): Max retries exceeded with url: /jsonrpc (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f6625a18dd0>: Failed to establish a new connection: [Errno 101] Network is unreachable',))

But i dont know why ...
MLD 5.4
OctopusNet
Libreelec
Reply
It seems so, that heroku only support ipv4.

What do I have to do so I can re-deploy to aws ?
MLD 5.4
OctopusNet
Libreelec
Reply
I have solved this now so that I use a Portmapping Service (feste-ipdotnet) to complete.

Question to the developers: Is the skill ip6 capable?
MLD 5.4
OctopusNet
Libreelec
Reply
just waiting for my Fire Stick to arrive and test this... Thanks for your work
Reply
Right i’m nearly there but confused!

DEFAULT]
# The Kodi webserver only supports HTTP, but if you've set up a reverse HTTPS
# proxy you can change this to https.
scheme   = https
address  = https://www.dynu.com/en-US/ControlPanel/...X0DER=SQBE**************
port     = 8080
# If using a reverse proxy you might need to add an extra bit to the url
# before "jsonrpc" (don't use slashes before or after).
subpath  =
username = kodi
password = *********

What details exactly do i enter for address and scheme above?
Reply
(2019-07-15, 18:21)captainfearless Wrote: Right i’m nearly there but confused!

DEFAULT]
# The Kodi webserver only supports HTTP, but if you've set up a reverse HTTPS
# proxy you can change this to https.
scheme   = https
address  = https://www.dynu.com/en-US/ControlPanel/...X0DER=SQBE**************
port     = 8080
# If using a reverse proxy you might need to add an extra bit to the url
# before "jsonrpc" (don't use slashes before or after).
subpath  =
username = kodi
password = *********

What details exactly do i enter for address and scheme above?

All looks ok in command prompt, green ticks all the way and skill deployed, but problem with response etc.
Reply
Okay i'm a whisker away now! If someone can just give me a leg up?

My port forwarding is working, i can access Kodi via the ddns domain, but still no skill action.

Are my scheme and address entries correct?

Do i need to add an extra bit to the url? 

# The Kodi webserver only supports HTTP, but if you've set up a reverse HTTPS
# proxy you can change this to https.
scheme   = http
address  = mydomain.ddns.net
port     = 8080
# If using a reverse proxy you might need to add an extra bit to the url
# before "jsonrpc" (don't use slashes before or after).
subpath  =
username = kodi
password = 88888898888
Reply
i was wondering if i can get some help with this, the kodi.config file fails when i deploy unless i put a 192.168.X.XX address in the address field, i have already tried with my actual ip address and i have a ddns.net address also, both fail.
it always fails on "updating slot values" Any thoughts?
Reply
I feel your pain!, mine was succeeding but still the skill didn’t work. Now it fails on slot values, and I haven’t changed the config file!!
Reply
(2018-04-26, 22:56)yumakuga Wrote: So, after a few mails back and forth with m0ngr31, turns out to be something on my end I still haven't traced down the cause of. Tethered the PC to the mobile so I was completely outside of my network and everything went without a hitch. Working brilliantly now. Thank you again for maintaining the skill and for the additional help.
and this is how ive resolved it, worked flawlessly, thankyou.
Reply
(2019-06-02, 02:10)paperw8 Wrote: Trying to use Kanzi for the first time. Followed the instructions in the documentation for the most simple setup (Heroku with no additional init configuration besides username, password, address and port), and I am getting 'lexigram deploy kanzi' to run semi-successfully until the last step, "Deploy skill". Here it just continuously shows the spinning yellow line while stating " -> Deploying skill information". All other steps seem to have been performed correctly but I can't get past this step. Any ideas why this is happening and what I can do about it?

In the tutorial it states, "Before you can add a custom skill to Alexa, Amazon requires that you have a 'developer' account." you actually have to open two accounts  Alexa Developers Account and AWS Developers Account. If you don't have both accounts set up the lexigram login command will return with the message "There is no vendor ID for your account." You can't deploy skills without a vendor ID.
Reply
  •   
  • 1
  • 167
  • 168
  • 169(current)
  • 170
  • 171
  •   
 
Thread Rating:
  • 15 Vote(s) - 4.6 Average



Logout Mark Read Team Forum Stats Members Help
Kanzi: Amazon Alexa skill for Kodi4.615