Thread Rating:
  • 10 Vote(s) - 4.2 Average
Skin MOD - Aeon MQ5 for Kodi 17 Krypton
#61
(2016-11-09, 02:13)scott967 Wrote:
(2016-11-08, 16:12)j0k3r Wrote: ...thanks alot Angelina that helped me Wink

But I have one problem with this skin, everytime I go back to my Home Screen, I get an error
that my Favourites Script makes some Probs, how can I fix that or disable that Favourites
Script?

Thanks for helping Big Grin

Need to see the debug log (wiki) posted to site like pastebin and linked to here.

scott s.
.

Thanks for helping Wink

Heres the Kodi.log :

http://pastebin.com/vMrqQxGJ
Reply
#62
Thanks for posting your log. The problem is in the script, script.favourites. The script is looking for your favourites.xml file (this file is created or updated by Kodi in your userdata folder when you add something to favourites). It looks like Kodi thinks the file exists, but when the script tried to open the file to read it is failing.

so the first thing is can you see if you have the file favourites.xml in your userdata?

I have passed your report to the developer's thread for script.favourites:
http://forum.kodi.tv/showthread.php?tid=...pid2453677

It is probably best to follow-up in that linked thread as I'm not sure I can provide much additional help on this.

At least, other than the annoyance of the notification it doesn't cause problems, except you won't see any favourites widgets on the home window.

scott s.
.
Reply
#63
Thanks for helping me our with that problem, is that the problem that causing the errors?

Code:
20:33:48 T:6158905344 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.IOError'>
Error Contents: (2, 'No such file or directory', u'/var/mobile/Containers/Data/Application/69598EFF-C2DD-4D78-8128-64E076F4A72D/Library/Caches/home/userdata/favourites.xml')
Traceback (most recent call last):
File "/var/mobile/Containers/Data/Application/69598EFF-C2DD-4D78-8128-64E076F4A72D/Library/Caches/home/addons/script.favourites/default.py", line 146, in <module>
Main()
File "/var/mobile/Containers/Data/Application/69598EFF-C2DD-4D78-8128-64E076F4A72D/Library/Caches/home/addons/script.favourites/default.py", line 22, in __init__
found, favourites = self._read_file()
File "/var/mobile/Containers/Data/Application/69598EFF-C2DD-4D78-8128-64E076F4A72D/Library/Caches/home/addons/script.favourites/default.py", line 46, in _read_file
self.doc = parse(self.fav_file)
File "/Users/Shared/jenkins/workspace/TVOS/tools/depends/xbmc-depends/appletvos9.1_arm64-target/lib/python2.7/xml/dom/minidom.py", line 1918, in parse
File "/Users/Shared/jenkins/workspace/TVOS/tools/depends/xbmc-depends/appletvos9.1_arm64-target/lib/python2.7/xml/dom/expatbuilder.py", line 922, in parse
IOError: (2, 'No such file or directory', u'/var/mobile/Containers/Data/Application/69598EFF-C2DD-4D78-8128-64E076F4A72D/Library/Caches/home/userdata/favourites.xml')
-->End of Python script error report<--
...when yes, maybe my tvOS version is not the right one because im on tvOS 9.0? dunno if that is right Wink Can I wipe that favourites script? Or is it used by your skin, or is
that a must-have add-on?
Reply
#64
A new release 9.2.2 is available on my GitHub for Kodi 17 (Krypton) Beta 6. See updated first post for info.

scott s.
.
Reply
#65
Scott,

I really hope you can help me out... I used to try switching to MQ7 for a while (on Krypton), but due to a lot of "stuff" happening around the Krypton MQ7 mods, and also me getting abysmal performance
on that skin due to all the bundled addons, I switched back to your Krypton Mod of MQ5 (after having used it on Jarvis and even before) and it is a godsend to be back - performance quadrupled, if not more.

So, everything is fine and dandy... but I have a peculiar and very specific issue with your MQ5 mod, that does NOT happen with Estuary on the Krypton Final.

I'm using Windows 10 as base, and every time when I "stop" a movie playing in 3D (H-OU, H-SBS, different video formats), Kodi crashes. I reproduced this with half a dozen files now, without fail, so I presume this is a general behaviour.

Does not happen with 2D Movies, does not happen with streams within Addons, but only with movies playing in Kodi 3D mode - I presume there is a bug somewhere in the handling of switching back from 3D to 2D interface, and I'm pretty sure you don't use a 3D TV so never tried out this specific feature...

I checked the log, but it seems kodi crashes even before something "wrong" can be written there.

Any idea what to check? If you need more info, I will provide what you need.
Reply
#66
I've made the experience with Kodi, that you should never mix, upgrade or do too much configuration stuff.

I upgraded from Jarvis to Krypton, used the same config. Everything seemed to be fine, only my remote stopped working. Nothing to see in the Logs. Spend a lot of time in investigating the problem. Due to a system update with a new kernel and some new driver versions I focused my investigations to the OS stuff.

After some days searching without any noticeable result I started with a completely fresh Kodi environment. And my remote returned working normally. Those problems I notice with every bigger Kodi update.

For that reason I have several Kodi configuration folders with different states, where I can go back easily. And additionally I use Git inside the Kodi folders to monitor the changes done.
Reply
#67
(2017-02-04, 01:18)kuldan Wrote: Scott,

I really hope you can help me out... I used to try switching to MQ7 for a while (on Krypton), but due to a lot of "stuff" happening around the Krypton MQ7 mods, and also me getting abysmal performance
on that skin due to all the bundled addons, I switched back to your Krypton Mod of MQ5 (after having used it on Jarvis and even before) and it is a godsend to be back - performance quadrupled, if not more.

So, everything is fine and dandy... but I have a peculiar and very specific issue with your MQ5 mod, that does NOT happen with Estuary on the Krypton Final.

I'm using Windows 10 as base, and every time when I "stop" a movie playing in 3D (H-OU, H-SBS, different video formats), Kodi crashes. I reproduced this with half a dozen files now, without fail, so I presume this is a general behaviour.

Does not happen with 2D Movies, does not happen with streams within Addons, but only with movies playing in Kodi 3D mode - I presume there is a bug somewhere in the handling of switching back from 3D to 2D interface, and I'm pretty sure you don't use a 3D TV so never tried out this specific feature...

I checked the log, but it seems kodi crashes even before something "wrong" can be written there.

Any idea what to check? If you need more info, I will provide what you need.

Don't have any way to test 3d here. I assume some problem with how Kodi is rendering UI windows. I was wondering if the fact that the skin is 720p is a factor? I am working on a 1080 version that might be worth testing.

scott s.
.
Reply
#68
Thanks Scott... first (and only) skin so far where I have this problem... if you have a 1080 version you can drop me a message and I'll gladly test Smile
Reply
#69
A new release 9.2.3 is available. Links and install tips are on the first post. There is also a new version of my repo (9.2.0).

I am working on a 1080 version of the skin. This will be a new version (probably 9.3.n). Note that Aeon MQ image collections for MQ6 or MQ7, including "themes" should work in MQ5 Kryptonmod. Just install them from the Brazil forum links (or any other location) and select them in skin settings. MQ5 Kryptonmod does not use skin.helper.service. That would make skinning a little easier but I think it has some performance costs. If you are having problems with skin.helper.service throwing exceptions or the like you might want to give MQ5 kryptonmod a spin. It doesn't have all the movie/tv show bells and whistles / widgets but might have a lighter performance footprint for you.

scott s.
.
Reply
#70
@scott967 firstly i would like to thank you for your continued on going work for keeping this MQ5 skin working. I love your skin and have been using it for a long time now.

I would like to make you aware that i have noticed a error in the new Krypton versions using this skin.

Normally you can get your media cases displaying the correct symbles on the cases. Like blueray logo etc. However since the update to the new version the sets media cases shows the standed cases instead.

I have checked incase its my error in settings but no its not. It seems sets no longer match up to the sets media cases and instead mismatch with the standard cases.

I'm unsure if this is fixable but i'd like to make you aware incase its a easy fix.

I am adding the sets media symble to the standard cases at the miniute as a alternative work around.

Thanks once again for your hard work.
Reply
#71
Hello. First off let me say I love this skin, as it has allowed me to upgrade to Krypton but keep the skin that made me fall in love with XBMC in the first place.

So, my question is: Is there a way to update the media flags for DTS:X and Dolby Atmos?
Reply



Aeon MQ5 for Kodi 17 Krypton4.210