ODROID C2 S905 2GB RAM HDMI 2.0 $46
(2016-06-21, 18:50)gnzb78 Wrote:
(2016-06-20, 10:27)wrxtasy Wrote: Sounds like you have an old C1 case. The C1+ cases are also compatible with the C2.

Yes i'll check with them to see what can be done

I ordered the black one for the C1+. The quality is ok for the price.

(2016-06-21, 18:57)gnzb78 Wrote:
(2016-06-20, 19:14)hoppel118 Wrote: Can you please describe where you see the buffering? I want to check if I also have this.

i tried the "after earth" 4k trailer and there was buffering on it (2 or 3 times)
(size is less than 2GB so pretty low)

i also tried (for test purpose only) the martian in 4k (MKV around 56GB)
during the movie i had buffering (2 times)

how does it appears :
movie stop and info bar appears displaying "buffering XX%"
buffering length was around 5 seconds
movie then resume automatically

i check and it seems that movies with issues are encoded with X264 codec (but in 4K)

those i tried in HVEC X265 doesn't seems to have the issue. maybe something to explore there

I check on the first page and maybe what i'm seeing is what is called "stuttering"

Thanks for clearing that. I don't have a 4k tv, so I can't test this. With my h264 bluray rips I don't have any buffering.

(2016-06-21, 16:46)hoppel118 Wrote: Sorry, for the double postings, but I think I found the cause for my problem. It has to do with the integrated amlogic hardware acceleration.

With the following settings I don't have the sound drops.

Code:
System - Settings -  Video - Acceleration:

Allow hardware acceleration - amcodec [o]
Accelrate MPEG2 [Never]
Accelrate MPEG2 [720p and up]

Now it uses Software acceleration for MPEG2 (dvd rips and vdr live tv). The cpu load average goes up to about 50% for all 4 cores, but it works. My bluray rips are still hardware accelerated and also work fine.

What can be done to get the hardware acceleration to work with vdr? (Maybe this is the wrong place for this question and off topic...)

Greetings Hoppel

Googled around and found the information that the raspberry needs a special license to play mpeg2. Hardkernel explains that H.264/H.265/VC1/MPEG4/MPEG2 is playable on Ubuntu Llinux (I know LibreELEC is not Ubuntu Linux):

Quote:Does it play 1080p contents well on Ubuntu Linux?
Yes, H.264/H.265/VC1/MPEG4/MPEG2 videos clips are playable with the XBMC/KODI in most cases.
But some variants of encoding options, a few video files can't play well.

@wrxtasy: Do I need any kind of license to get amlogic hardware acceleration for MPEG2?

At the moment the amlogic hardware acceleration works for me as follows:

- h264 - 1080p - bluray rips work as expected
- h264 - 720p - live tv works as expected
- mpeg2 - 576p - dvd rips work as expected
- mpeg2 - 576p - live tv works with one sound drop every minute (software acceleration works as expected)


Another source in the internet wrote, that it may be working with a default refresh rate of 50Hz. But this also doesn't work.

Greetings Hoppel
frontend software - tvOS | android tv | win10 | kodi krypton
frontend hardware - apple tv | nvidia shield tv | yamaha rx-a1020 | quadral 5.1 | samsung le40a789
backend software - debian | kernel 4.14 | proxmox | omv | zfs raid-z2 | docker | emby | vdr | vnsi | fhem
backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | dd max s8
Reply
 
Thread Rating:
  • 10 Vote(s) - 4.1 Average


Messages In This Thread
ODROID C2 S905 2GB RAM HDMI 2.0 $40 - by hoppel118 - 2016-06-22, 00:14


Logout Mark Read Team Forum Stats Members Help
ODROID C2 S905 2GB RAM HDMI 2.0 $464.110