•   
  • 1
  • 12
  • 13
  • 14
  • 15
  • 16(current)
[T3] 2.4GHz and IR Air Mouse Remote Control
(2017-10-13, 23:24)tylla Wrote: Finally I got hold of a T3-M remote.
Fun fact: it was ordered trough eBay from China, but after the first two orders both ended up arriving as an MX3 (so refunded), and the 3rd gave up the order after I double checked with them whether it is really a T3, the 4th order was finally a T3.
As I use it with Linux (Debian Jessie, Gnome3) I thought I will share my findings, maybe somebody will get some use of it.

First the functions:
The remote is a T3-M model, it has the audio feature.
It gets recognized on the USB as a composit HID device with vendor ID 0x1d57 (Xenta) product ID 0xad03 version 0x101.
Manufacturer name (Input device name in evtest device list): "FREEWAY TECHNOLOGY"
It has some subdevices: audio control, audio streaming, keyboard, mouse.
The state of the mouse gets memorized until battery changing.
The remote has 3 state changing buttons: TV, MOUSE DISABLE, Fn (on the backside), all other keys are sending valid, recognizable keycodes.

Now the keycode/value layout map. The position of each entry is matched with the physical position of the corresponding button on the remote. This is the air mouse/D-pad side, the keyboard side is pretty straightforward.
Code:
Keycode layout for the T3-M RF Remote and Air Mouse:
Normally all keycodes come through the keyboard device (the first in the evtest listing).
Keys marked with asterisk (*) change function according to the air mouse enable/disable function:
  - if mouse is disabled the normal keycodes are used.
  - if mouse is enabled, the normal keycodes are not sent for these two keys, instead alternative codes are sent through the second input device (mouse):
      KEY_ENTER(70028) ->    BTN_LEFT(90001)
      KEY_ESC(70029)   ->    BTN_RIGHT(90002)
The microphone key sends the keycode KEY_F16 right before starting the transmission of audio. It does not send anything at the end of transmission.


KEY_POWER (10081)

KEY_REWIND(c00b4)       KEY_FASTFORWARD(c00b3)  KEY_PREVIOUSSONG(c00b6) KEY_NEXTSONG(c00b5)
KEY_F3(7003c)           KEY_PLAYPAUSE(c00cd)    KEY_ZOOMIN(c022d)       KEY_ZOOMOUT(c022e)

           KEY_COMPOSE(70065)     KEY_HOMEPAGE (c0223)    KEY_UNKNOWN(700bb)

                                   KEY_UP (70052)
                 KEY_LEFT(70050)   *KEY_ENTER(70028)  KEY_RIGHT(7004f)
                                   KEY_DOWN(70051)

KEY_VOLUMEUP(c00e9)     *KEY_ESC(70029)         KEY_ENTER(70028)        KEY_PAGEUP(7004b)
KEY_VOLUMEDOWN(c00ea)   KEY_MUTE(c00e2)         MOUSE_ON_OFF(N/A)       KEY_PAGEDOWN(7004e)

KEY_1(7001e)            KEY_2(7001f)            KEY_3(70020)            KEY_CONFIG(c0183)
KEY_4(70021)            KEY_5(70022)            KEY_6(70023)            KEY_MAIL(c018a)
KEY_7(70024)            KEY_8(70025)            KEY_9(70026)            KEY_WWW(c008a)
TV_RF_IR_SWITCH(N/A)    KEY_0(70027)            KEY_BACKSPACE(7002a)    KEY_F16(7006b)

KEY_F4(7003d)           KEY_F5(7003e)           KEY_F6(7003f)           KEY_F7(70040)

These values can be used to create a map using udev:
Code:
#Keymap file for the T3-M RF Remote and Air Mouse devices
#This file goes as 60-keyboard.hwdb symlink into the /etc/udev/hwdb.d/ directory

#after changing this file, these commands should be run:
#udevadm hwdb --update
#udevadm trigger
#udevadm control --reload

keyboard:usb:v1D57pAD03*
KEYBOARD_KEY_10081=f24     #KEY_POWER - Power Button
KEYBOARD_KEY_700bb=tab     #KEY_UNKNOWN - Recent Button (double rectangles on each other)
Important: the forum engine eats the first (and single) space character in front of KEYBOARD_KEY_xxxx but it is a must.

The above code changes the Recent button to send a TAB code (aka. Fullscreen), and the Power button to send an F24 code.
The last is a hack for me to be able to make a custom script work, which will turn off the display on my machine (actually rather send the display to sleep) when I press Power.

Ps: as I currently own both MX3 (2 of them :-) and a T3-M remote I must say the T3-M is way more thought out than the MX3. The T3 only sends keypresses through that device where they belong while the MX3 was more of a mumble-jumble, sending some keys using the mouse some keys using the keyboard device. And btw. they changed the key codes for the PrevSong/NextSong - Rew/FF keypairs to better match the symbol on the key. Now I only miss the Win button... Smile

Ps2: now I see that the forum engine messes up my carefully layed out tables.... pfff.  


Hi. Where can I find the key codes please (tab;f24;stop...)? Thank you.... I have a T3-M v1D57pAD03 ....
Reply
...
Reply
Are you having poor reception with your T3 or MX3 Remote, keys randomly repeating, keys not registering when pressed? I found a hack that actually works and improves your remote reception and Kodi experience. I was having trouble with my lounge room T3 remote randomly doing weird stuff because the dongle was not receiving the commands correctly.  Solution, buy a 1m USB extension cable. Find an old CD push the end of the extension cable through the hole of the CD and plug the dongle into the extension cable. The CD acts as a reflector now the range of your remote increases dramatically.
Reply
My T3 was bad out of the box:
- drained the batteries very quickly. Seems to me it was in constant communication with the reciever. If I took it somewhere out of the range the LED would start rapidly flashing red and green.
- faint buzzing sound from the unit after keypresses until it went into standby
- Receiver would randomly register constant keypress ond Volume up/down keys resulting in volume go all the way up/down. Not a good feature to have when watching movies in the middle of the night with rest od the family sleeping Smile
- poor range comapring to the MX3
Receiver was in the front USB on my HTPC, about 4m from the couch with no obstacles between.
Went back to good old MX3-M that doesn't have any of the mentioned symptoms. Receiver plugged in the back of the HTPC inside wooden enclosure, together with USB DVB-T tuner and a bunch of cables, no problems.
Now searching for backup remote just in case MX3-M brakes down or something.
Reply
Hi c-shadow
What a pain, sounds like your remote was defective. Midnight full volume definitely not a feature I would want.

I have three T3 remotes each installed in different scenarios
Scenario 1
Bedroom T3, 3 to 4 metres from receiver, line of sight, and receiver plugged into front of HTPC. Batteries have been installed over 9 months. No problem at all, works as intended.
Scenario 2
Lounge T3, 6 to 7 metres from receiver, no line of sight, and receiver plugged into back of HTPC behind TV. Batteries have been installed over 9 months. Sometimes get random keys repeating or keys not registering while searching for movies.
Scenario 3
Projector T3, 3 to 4 metres from receiver, no line of sight, and receiver plugged into back of HTPC within a cupboard. Batteries have been installed over 9 months. Sometimes get random keys repeating or keys not registering while searching for movies.

The receiver appears to be the weak point of the T3 in scenario 2 and 3. However these problems have been eliminated in my case using the CD hack above. Hopefully the hack will help someone else with a similar T3 scenario.
Reply
Hi, I have this T3 remote that I bougth in Aliexpress in this link https://www.aliexpress.com/item/Newest-F...0.0.qerzlg and I try use it with Kodi (LIBREELEC) in Raspberry pi but the remote not do anything, only work the air mouse.

I have seen I can test with evtest and I have installed the SuperRePo and only see a file evtest in /var/media/root/usr/bin but when I execute then I get this error:

-sh: ./evtest: Permission denied

Others remotes like Rii MX3 works good. Can anybody tell me why not work this remote and how test and solve the problem?

Thanks in advance.
Reply
Please actually read the forum rules (wiki), especially the banned addons (wiki) list.

While you have that repo installed then you aren't eligible for any support or assistance here.
| Banned add-ons (wiki) | Forum rules (wiki) | First time user (wiki) | FAQs (wiki) | Troubleshooting (wiki) | Add-ons (wiki) | Free content (wiki) | Debug Log (wiki) | Free Movies/TV Shows |
Reply
(2017-12-06, 23:12)DarrenHill Wrote: Please actually read the forum rules (wiki), especially the banned addons (wiki) list.

While you have that repo installed then you aren't eligible for any support or assistance here.
Ok sorry, I not knew. I have deinstalled addon, I only had installed today trying solve the problem becouse I wanted use the program evtest and I read I had to install it, but when installed the execution said not have permission so not was useful.

I solved with the information in this link https://github.com/denilsonsa/udev-joystick-blacklist with this commands:
Code:
cd /storage/.config/udev.rules.d/
curl -o /etc/udev/rules.d/51-these-are-not-joysticks.rules \ https://raw.githubusercontent.com/denilsonsa/udev-joystick-blacklist/master/51-these-are-not-joysticks.rules
curl -o /etc/udev/rules.d/51-these-are-not-joysticks-rm.rules \ https://raw.githubusercontent.com/denilsonsa/udev-joystick-blacklist/master/51-these-are-not-joysticks-rm.rules

Then reboot the system and works.

I was looking to test the scancode of my remote like evtest without the banned addon? I find is possible with libreelec addon system-tools and I installed evtest with Libreelect system-tools addon, the process is easy:  Addons - Icon up (package) - Install from repository - LibreELEC Add-ons - Program Add-ons - System Tools - Install and not you can open ssh and use evtest:
Code:
LibreELEC:~ # evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:      MemsArt MA144 RF Controller
/dev/input/event1:      MemsArt MA144 RF Controller
/dev/input/event2:      MemsArt MA144 RF Controller
Select the device event number [0-2]:

but if I use any of these input not see the scancode pressed and in the screen show all possible events code and the text:
Code:
Properties:
Testing ... (interrupt to exit)
***********************************************
  This device is grabbed by another process.
  No events are available to evtest while the
  other grab is active.
  In most cases, this is caused by an X driver,
  try VT-switching and re-run evtest again.
  Run the following command to see processes with
  an open fd on this device
 "fuser -v /dev/input/event2"
***********************************************

Also I tried with commando getscandodes but the screen not shown any code or similar.

I could with the next commands:

Code:
systemctl stop kodi
systemctl stop eventlircd
evtest /dev/input/event0

You can change for the T3 evtest /dev/input/event0 for evtest /dev/input/event1 for test the air mouse or evtest /dev/input/event2 for key specials like explorer, mail and others.

After you can restar the services:

Code:
systemctl start eventlircd
systemctl start kodi
evtest /dev/input/event0

Regards
Reply
  •   
  • 1
  • 12
  • 13
  • 14
  • 15
  • 16(current)
 
Thread Rating:
  • 3 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[T3] 2.4GHz and IR Air Mouse Remote Control53