v17 replaygain doesn't seem to be working
#14
Here's my log, just a couple of tracks played to show that it appears to be picking up the correct ReplayGain values:

https://paste.ubuntu.com/23950870/

The two tracks I picked are actually the same song, one from the original album and one from a singles boxset. The original album is one that has always sounded noticeably quiet with the one from the singles boxset what I would perceive to be a more "normal" volume.

For information here are the tags for the two tracks

REPLAYGAIN_ALBUM_GAIN -2.87 dB
REPLAYGAIN_ALBUM_PEAK 1.000000
REPLAYGAIN_TRACK_GAIN -2.58 dB
REPLAYGAIN_TRACK_PEAK 0.909424

REPLAYGAIN_ALBUM_GAIN -7.11 dB
REPLAYGAIN_ALBUM_PEAK 0.996613
REPLAYGAIN_TRACK_GAIN -6.94 dB
REPLAYGAIN_TRACK_PEAK 0.985748

One thing that did strike me as odd, and this could well be my lack of understanding of exactly how ReplayGain works, is that while the gain figures seem logical, the first track which is much quieter has higher gain values, I was surprised to see the album peak for the quiet album at 1.000000 with the more normal sounding album with a lower peak value

Now obviously any issue here is with the method I've used to scan the tracks and write the tags, not a Kodi issue, but with the mention of a change in the way that Kodi handles clipping, and this is a total shot in the dark, could the previous version of Kodi masked something odd in my tagging that is now becoming apparent?

I will do some reading up on ReplayGain to improve my understanding and may do some testing with rescanning my files using different software and/or removing the peak tag to see what effect it has. If I find anything that might be useful I will report back otherwise hopefully we can get to the bottom of the sudden change in the new version of Kodi.

Anything more I can provide to help with any investigation let me know.
Reply


Messages In This Thread
RE: replaygain doesn't seem to be working - by Hallucyn8 - 2017-02-08, 01:34


Logout Mark Read Team Forum Stats Members Help
replaygain doesn't seem to be working0
This forum uses Lukasz Tkacz MyBB addons.