•   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
This is fixed with build #0422, 3D iso files play correctly.

(2017-04-22, 12:27)amediauser Wrote: With builds #0420 / #0421 Kodi crashes and restarts (see kodi_crash.log) when trying to play a 3D iso file, probably as a result of the ffmpeg buffer changes, #0419 plays correctly.

DEBUG: ffmpeg[5BDE03A0]: Assertion len >= s->orig_buffer_size failed at libavformat/aviobuf.c:535
Reply
Hi
Any plans in future to bring Vice (C64 Emulator) in builds?

Also, i have problems with arcade emulator (MAME), he is not opening .zip files, there is no response, you just hit a play button and nothing happens.

Thank you.
Reply
(2017-04-22, 13:38)SpokV Wrote: Sorry, my bad. Here it is.crashlog

Looks like amediauser's issue. Is it still present in latest build?
Reply
(2017-04-23, 13:20)popcornmix Wrote:
(2017-04-22, 13:38)SpokV Wrote: Sorry, my bad. Here it is.crashlog

Looks like amediauser's issue. Is it still present in latest build?

No. still a crash when playing net video. Same issue.
Here is the log for 422 crashlog
Reply
(2017-04-23, 12:16)vali Wrote: Any plans in future to bring Vice (C64 Emulator) in builds?

This will happen once someone does the port from the libretro repo Smile

(2017-04-23, 12:16)vali Wrote: Also, i have problems with arcade emulator (MAME), he is not opening .zip files, there is no response, you just hit a play button and nothing happens.

Add this to your advancedsettings.xml:

Code:
<advancedsettings>
  <videoextensions>
    <remove>.bin|.img|.iso|.zip</remove>
  </videoextensions>
  <musicextensions>
    <remove>.cue|.zip</remove>
  </musicextensions>
  <pictureextensions>
    <remove>.zip</remove>
  </pictureextensions>
</advancedsettings>
BTC: 1JtXwJdGdE9YnYgThWBT2StFCU5sEYkbVD (personal), https://kodi.tv/contribute/donate-bitcoin (foundation). Donations in the form of controllers, especially ones that don't work in Kodi, are also appreciated.
Reply
(2017-04-22, 23:50)rudrood Wrote: Start reading here:
http://forum.kodi.tv/showthread.php?tid=...pid2554178

Think your problem will be resolved by editing file smb.conf in /storage/.smb
Change: client max protocol = SMB3
To: client max protocol = SMB1

And restart

Perfect ! problem resolved with editing smb.conf

many thanks rudrood !

But now with new build all "windows/smb share" users must to modify the file after each new install ? or smb3 more diffused than the smb1 ?
Reply
(2017-04-23, 15:57)SpokV Wrote: No. still a crash when playing net video. Same issue.
Here is the log for 422 crashlog

We may need a crash log from a debug build to narrow this down more.
Either that or instructions of how to reproduce.
Reply
(2017-04-23, 17:34)levil1 Wrote: But now with new build all "windows/smb share" users must to modify the file after each new install ?

No, you should only need to make this change (once per client), assuming your server only "speaks" SMB1.

However SMB1 is deprecated by Microsoft as it's a major security risk, and they are (and have been for some time) warning/encouraging users to stop using SMB1 completely.

I believe Windows Server 2012 no longer supports SMB1 by default, hence the push towards a newer version of SMB.

You should contact your NAS vendor to see what they are doing about supporting a more recent version of SMB (Samba).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-04-23, 17:54)popcornmix Wrote:
(2017-04-23, 15:57)SpokV Wrote: No. still a crash when playing net video. Same issue.
Here is the log for 422 crashlog

We may need a crash log from a debug build to narrow this down more.
Either that or instructions of how to reproduce.

Where can i get a debug build?
Reply
I'll upload a debug build a bit later this afternoon.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-04-23, 18:16)SpokV Wrote: Where can i get a debug build?

Build #0422x: RPi2
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
New LibreELEC.tv Leia build #0423: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.10.12 #1 Sun Apr 23 21:05:50 BST 2017 armv6l GNU/Linux

# vcgencmd version
Apr 19 2017 13:34:02
Copyright (c) 2012 Broadcom
version e49fda6e8d837fd3cbac4900a141dd7fba7ca3e3 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20170423210234-#0423-gd8293a9 [Build #0423]

# Kodi version
(18.0-ALPHA1 Git:78cce57). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (d8293a9f, changelog) and tip of XBMC master (c5eb8487, changelog) with the following modifications: Build Highlights:
  1. smsc95xx: Use skb_cow_head to deal with cloned skbs
Build Details:
  1. LibreELEC.tv:
    • connman: fix ipv4 IP Forwarding bug (PR:1552, 1 commit, 1 file changed)
    • qtbase: fix stdlib.h build error (PR:1544, 1 commit, 1 file changed)
    • ffmpegx: fix build issue after openssl change (PR:1542, 1 commit, 1 file changed)
    • lirc cleanup: switch to upstream fixes and configuration (PR:1320, 11 commits, 31 files changed)
    • imx6-status-led: add support for som v1.5 from solidrun (PR:1561, 1 commit, 1 file changed)
  2. XBMC:
    • Create slovenian.xml (PR:11999, 1 commit, 1 file changed)
    • ADD: [droid] speech-to-text in keyboard (PR:11978, 4 commits, 16 files changed)
    • FileCache: Increase CHUNK_SIZE to 128 KB (PR:11619, 4 commits, 4 files changed)
  3. newclock5:
    • Commits no longer in build:
      • Increase CHUNK_SIZE to 128 KB (72639ffd)
      • NFSFile: Return max chunksize possible (4aa68a93)
      • DVDDemuxFFMPEG: Increase FFMPEG_FILE_BUFFER_SIZE to 128K (b9dee484)
      • DVDDemuxFFmpeg: Store probe_buffer on heap (a47821b7)
  4. kernel 4.10.y:
    • New commits in this build:
      • smsc95xx: Use skb_cow_head to deal with cloned skbs (18c2a29f)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] compare: cleanup: minor package fixes
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Is h265 playback for the most recent builds STILL working for all of you?

I am using osmc since a while and my laptop is under repair, so I cannot test with a pure, fresh libreelec image. For me (osmc) h265 playback keeps crashing osmc since a few builds (either a full crash or just sound playing without video), while not long ago h265 playback was much better than every previous build of either libreelec or osmc I ever had. Not that h265 playback would be neccassary for me, but I wonder why it was so much better shortly before.

So I am interested if it`s just my (modified) system or native libreelec as well?
Reply
Post a debug log of the OSMC issue (on our forum) and we'll take a look. Here isn't appropriate (as this is an LE thread)
Reply
(2017-04-24, 06:42)MMXT Wrote: Is h265 playback for the most recent builds STILL working for all of you?

It looks like h265 playback has been broken (instant crash) since #0419 when builds reverted back to ffmpeg-3.1.6 to investigate audio glitches.

This is a debug-enabled crashlog: http://sprunge.us/IBcF

It's possible the change from ffmpeg-3.3 back to ffmpeg-3.1.6 wasn't entirely complete and is causing problems with h265.

Edit: Hmmm, so it's not every HEVC sample that is crashing - Hobbit and Big Buck Bunny are OK, but the Big Bang Theory sample (8x01 The Locomotion Interruption, 68MB) crashes every time.

This Friends sample (12MB) will also crash: http://sprunge.us/ECMD

Both the Big Bang Theory and Friends samples have been fine up until now.

Edit2: It looks like 1080p HEVC files are playing normally, but everything else (ie. 720p HEVC) is crashing. BBB 720p crashes, BBB 1080p plays normally; Sintel 720p crashes, Sintel 1080p plays normally. Both Big Bang Theory and Friends samples are 720p.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
  •   
  • 1
  • 100
  • 101
  • 102(current)
  • 103
  • 104
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712