•   
  • 1
  • 152
  • 153
  • 154(current)
  • 155
  • 156
  • 304
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2017-07-07, 10:53)Cosmicbase Wrote: Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?
Reply
(2017-07-07, 12:42)popcornmix Wrote:
(2017-07-07, 10:53)Cosmicbase Wrote: Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?

In the YouTube Playlist, I choose "Play From Here" and the 1st track is played completely. The next title begins to play and usually remains black. However, the time bar continues to run. The title will continue as minutes and hours continue. At first I thought it was at the Playlist. But with Omx Player goes the continuous play a playlist without problems. Only makes the Omx Player problems with Amazon and Co.

Greetings Cosmicbase
Reply
(2017-07-07, 13:18)Cosmicbase Wrote:
(2017-07-07, 12:42)popcornmix Wrote:
(2017-07-07, 10:53)Cosmicbase Wrote: Hello there, so I'm happy so VOD is working with mmal player.
With omx player there is green screen.

I have one problem... With mmal player, I can't play tracks in loop with youtibe Addon. With omx player loop playing works fine, but amazon VOD have a green screen Problem.

Situation at the moment : mmal Player works fine for Amazon VOD an omx player works fine for YouTube Addon.
This is not right way. I want 1 Player for all.

Can you help me please.

omxplayer is a hardware decoder - it will never support DRM streams which are software decoded (Amazon/Netflix).
I'm trying to add an automatic disable of omxplayer in this case, but so far haven't been able to determine this at required point in time.

Can you give a detailed description of how to reproduce the mmal problem with youtube?

In the YouTube Playlist, I choose "Play From Here" and the 1st track is played completely. The next title begins to play and usually remains black. However, the time bar continues to run. The title will continue as minutes and hours continue. At first I thought it was at the Playlist. But with Omx Player goes the continuous play a playlist without problems. Only makes the Omx Player problems with Amazon and Co.

I hope my english is good for you.

Greetings Cosmicbase


I think the error lies in the mmal player. Have all versions of YouTube Addon tried. Unfortunately the Playlist in Youtube does not play automatically. After the first title it switches to the second title and then the time runs in black picture forever. But that's what I believe only since # 704. Previously I had problems with mmal player never. Is very unfortunate that the tracks are not looped. Now I have to click each title individually.
Is there a Chance to log this Problem. There is not really a error.

Please help.
Reply
New LibreELEC.tv Leia build #0707: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.11.9 #1 Sat Jul 8 00:49:03 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul  3 2017 14:20:31
Copyright (c) 2012 Broadcom
version 4139c62f14cafdb7d918a3eaa0dbd68cf434e0d8 (tainted) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170708004759-#0707-g0789bd3 [Build #0707]

# Kodi version
(18.0-ALPHA1 Git:734cda1). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (0789bd3d, changelog) and tip of XBMC master (734cda17, changelog) with the following modifications: Build Highlights:
  1. Kodi: Service Manager, DeviceKit, Musicbrainz throttling, addon cleanup
  2. netbsd-curses, libfmt bump
Build Details:
  1. LibreELEC.tv:
    • slice: only for RPi (PR:1753, 1 commit, 1 file changed)
    • kodi: update to kodi-734cda1 (latest kodi 18a1 master) (PR:1758, 15 commits, 52 files changed)
    • bluetooth-audio: fix log errors (PR:1752, 1 commit, 4 files changed)
    • ffmpeg: include hevc optimisation patch from popcornmix (PR:1760, 1 commit, 1 file changed)
  2. XBMC:
    • [visualization] add doxygen documentation and change on part to const (PR:12413, 3 commits, 4 files changed)
    • [addons] change and cleanup binary addon parts (PR:12410, 9 commits, 56 files changed)
    • Fix missing brackets in dbwrappers code (PR:12433, 1 commit, 1 file changed)
    • Service Manager: Fix order of init/deinit (PR:12432, 5 commits, 57 files changed)
    • Compiler warnings and dead code (PR:12425, 14 commits, 17 files changed)
    • [depends] bump to libiconv 1.15 (PR:12422, 1 commit, 1 file changed)
    • [music]Fix throttling of Musicbrainz requests by music scrapers (PR:12402, 1 commit, 1 file changed)
    • [modernize] Prefer 'default' for declarations (PR:12400, 42 commits, 512 files changed)
    • [bluray] Blu-ray updates (PR:12339, 5 commits, 11 files changed)
    • fix ServiceManager init/deinit (PR:12435, 2 commits, 3 files changed)
    • [dependencies][windows] Add libaacs. (PR:12429, 1 commit, 2 files changed)
    • DeviceKit cleanup (PR:12383, 2 commits, 8 files changed)
  3. peripheral.joystick:
    • [cmake] Add missing header (PR:116, 1 commit, 1 file changed)
  4. pvr.vdr.vnsi:
    • Added minimalistic support for PVR Addon API 5.3.0 (PR:4, 1 commit, 2 files changed)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1749: netbsd-curses: update to 4c156be
    • Added: [env] PR:1761: kodi: disable using debug fission
    • Reverted: [pkg] PR:4: Added minimalistic support for PVR Addon API 5.3.0 (reason: premature) (pvr.vdr.vnsi)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
I just updatet to 703 Release and installed Netflix, Amazon and Skygo Addon. All three of them work great- thank you very much for making this happen! Just donated to Kodi!
706 reboots when I start Amazon, 707 seems to work good again!

Only "Bug" I found in 707,706 and 703 is the problem, that I cant use the game emulators (missing dependencies)- this is related to the addon changes, right? Or is there anything I can do to fix it?
Reply
(2017-07-08, 08:46)linkinsoldier Wrote: Just donated to Kodi!

Many thanks!

(2017-07-08, 08:46)linkinsoldier Wrote: 706 reboots when I start Amazon, 707 seems to work good again!

Can you upload the crash log from #0706?

(2017-07-08, 08:46)linkinsoldier Wrote: Only "Bug" I found in 707,706 and 703 is the problem, that I cant use the game emulators (missing dependencies)- this is related to the addon changes, right?

Yes, the addon changes have made it impossible to update the LE 9.0 repository which is a fairly big task in itself and would need to be done almost weekly to keep up with the core Kodi API changes. Once the Kodi API stabilises it will be possible to refresh the LE 9.0 repository and bring back the game emulators etc.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2017-07-08, 09:40)Milhouse Wrote:
(2017-07-08, 08:46)linkinsoldier Wrote: 706 reboots when I start Amazon, 707 seems to work good again!

Can you upload the crash log from #0706?

here you go:
https://pastebin.com/Bx1eD15e
Reply
(2017-07-08, 10:16)linkinsoldier Wrote:
(2017-07-08, 09:40)Milhouse Wrote: Can you upload the crash log from #0706?

here you go:
https://pastebin.com/Bx1eD15e

Funnily enough I saw the same crash this morning with a local test build: http://sprunge.us/ZIff

This was while playing a VC1 file over nfs:// so it doesn't appear to be Amazon specific. I haven't been able to reproduce (it crashed a few seconds after pressing "stop" to end playback), but I'll upload a debug-enabled build in a short while as that will provide more detailed crash logs.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
After more testing I found 3 more things:

1) I had a crash (single event) on starting to stream Pitch Perfect 2 with Inputstream Stream Select manual:Crash log uploaded here:
https://pastebin.com/xTZzymCe (reuploaded with more details!)

Tried a lot but couldn't reproduce it.

2) When using Software Decode my Rpi gets pretty hot (getting heat warning icon) - I am using the official kodi case - am I the only one?

3) Stream select auto seems to work awesome when screen size is exactly 1280x720p (TV Series), but I seem to get issues when watching Movies with a different aspect ration. For Example:
Trying to stream "Pitch Perfect 2" from Amazon using Secure Decoding max 720p i get:
"Auto": 920x520
"Manuel":I get 1920x1040 (which is too much for the Rpi3) - but I can change it to 1280x688 and that works great

Is there maybe a bug with "getting the 720p" Stream? 1280 is the same, but it is only 688 instead of 720 and instead falls back to 920x520. Could this be improved by applying ranges instead of (guessing) == 720p? Or maybe by using == 1280 for the first part instead of == 720p for the later? Or choose the "highest" stream below "720p" instead of falling back to a default (guessing) stream?

Is this an Inputstream or an Amazon VOD Issue?
Reply
After the update to # 0707 kodi crashes constantly with the PVR. TV watch almost impossible.
I have the 9 crashlogs packed into a file here - https://drive.google.com/file/d/0B7Ag1MU...sp=sharing

EDIT:
Sorry my mistake, forgot to update the TVheadend. Let's see whether now is better...

EDIT1:
Unfortunately not really better... This is no fun - back to # 0706
[ 2x RPi2, 2x RPi3 ]
[ LE Testbuilds for RaspberryPi (Kodi 18.0) ]
[ Marantz NR1506 ]
[ Panasonic TX-50EXW784 ]
[ NAS @ OMV 3.0.9x (Erasmus) on Banana Pi ]
[ ODROID C2 + wrxtasy's LE 8.0 ]
Reply
Hey with Netflix I have two problems:

1. Audio offset (tryed to fix it by manualy set the offset, but even 10s aren't enough)

2. Video stops after Buffering, when rewinded by a few seconds Video is running till the next buffering

Inpustream is set 720p build is #0707 on RPI2

No problems with Amazon VOD or SkyGo

Another Problem is with TED Talks. There I can't play any Video

crashlog: http://sprunge.us/TXAZ
log: http://sprunge.us/aTUX
Reply
I've been using these nightlies for a couple years now, and have installed them probably over 150 times. Is there a cleanup routine I should run/complete once a year or so to purge leftovers from old images, or does installing a new nightly (via ssh) take care of everything?
Reply
(2017-07-08, 10:28)Milhouse Wrote: This was while playing a VC1 file over nfs:// so it doesn't appear to be Amazon specific. I haven't been able to reproduce (it crashed a few seconds after pressing "stop" to end playback), but I'll upload a debug-enabled build in a short while as that will provide more detailed crash logs.

That looks the same as linkinsoldier's crash log, so I suspect it hasn't really gone with #0707, but it just a bit random.
Milhouse can you reproduce this crash? Can you confirm which build it started in?
(I'm away from home this weekend so my ability to debug/test is limited).
Reply
(2017-07-08, 10:49)linkinsoldier Wrote: 2) When using Software Decode my Rpi gets pretty hot (getting heat warning icon) - I am using the official kodi case - am I the only one?

Software decode will inevitably get hotter than the more efficient hardware decode.
Is the video playback fine if you ignore the warning symbol?
If so, then "avoid_warnings=1" in config.txt will hide the warning.
No harm will occur - the throttling stops the temperature reaching undesirable levels.

If the throttling interferes with video playback then a themal solution is needed.
I use a FLIRC case which is *very* good and would solve the issue.
Removing the current case and aligning the pi pcb vertically may help with ventilation.
A stick on heat sink helps a little (but much less so than a case like the FLIRC).
Reply
Hello, I have now tried all nightly from # 703 and determined that I can not play with Youtube playlist with mmal player.
I click on "Play from here" and the track is played completely.
The next title starts about 10 seconds and usually without image content.
Then the sound goes out and the video goes black without ending.
It is no fun to select each song individually. With LE8 and Kodi 17 were no problems with mmal player. Have never used omx player before. Unfortunately I have to use the omx player for Youtube. Here is the play of Playlist without problems. Only now I have to switch between mmal player / Amazon and omx player / youtube. It is possible to use the mmal player again. Is there a way to log the scenario?
Maybe there is a way to put in a case in Amazon addon "use only mmal player".
Then you could activate omx and mmal player.

Greetings Cosmicbase
Reply
  •   
  • 1
  • 152
  • 153
  • 154(current)
  • 155
  • 156
  • 304
  •   
 
Thread Rating:
  • 12 Vote(s) - 4.67 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.6712