Kodi 18 - LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)

  Thread Rating:
  • 6 Vote(s) - 4.83 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
noggin Offline
Super Moderator
Posts: 4,732
Joined: Oct 2008
Reputation: 125
Location: United Kingdom
Post: #2731
(2017-07-31 22:29)Milhouse Wrote:  
(2017-07-31 16:24)edit4ever Wrote:  Starting with #0728 the Hauppauge wintv-dual stopped showing both tuners. #0727 works fine both tuners show up - anything newer than that only shows one tuner. Not sure what may have changed wit the patch or with the kernel that may be impacting the patch.

OK, can you go to Settings > LibreELEC > System, and at the bottom of the list on the right, enable "CrazyCat DVB drivers" then reboot. You should now have dual tuners. If not, can you post another logfile zip.

The Hauppauge dual tuner support only comes from the media_build ("CrazyCat") drivers which are now enabled as an optional extra (otherwise you only get the vanilla kernel driver, which supports only a single tuner).

Ultimately we may be include media_build as an addon, which means the downloads are smaller for those that don't need the extra drivers and firmware, will make builds less likely to break with a new kernel, and should allow media_build updates in between major releases.

Not sure how I missed this millhouse! My WinTV HD Dual is now working brilliantly.

Also - it may be very interesting to people in a DVB-T2 region that the GBP £5 XBox One DVB-T/T2/C tuner now has experimental driver support INCLUDING multiple devices in development. There's a thread over at TV Headend. https://tvheadend.org/boards/5/topics/13685 (Thanks to Olli Salonen)

Apologies if this is off topic - but could be a VERY good low cost Freeview HD solution in the UK (and also good in Sweden, Finland etc.) I predict a spike in tuner sales once this tuner driver gets into media_build...
find quote
Seppl Offline
Junior Member
Posts: 11
Joined: Jun 2017
Reputation: 0
Post: #2732
(2017-08-01 12:06)Mepsipax Wrote:  Hey guys,

I recently switched from Libreelec 8.0 to 9.0 nightly #728.

The youtube addon doesn't start any videos anymore now. Is this a known issue?

afaik Youtube only works with OMXPlayer, which is disabled, because it would cause netflix/amazon/... to crash, but you can enable it in the Player settings.
find quote
galopogos Offline
Junior Member
Posts: 28
Joined: Jan 2014
Reputation: 0
Post: #2733
Hello
I am having problems enabling the PVR Simple Client during the last builds
on the startup it gets disable saying is incomplatible with the kodi version
if i try to update it from the libreelec repo, i get an error dependencies cannot be satisfied
any hint?
thanks
find quote
pqatsi Offline
Junior Member
Posts: 7
Joined: Dec 2013
Reputation: 0
Post: #2734
(2017-08-01 18:57)galopogos Wrote:  Hello
I am having problems enabling the PVR Simple Client during the last builds
on the startup it gets disable saying is incomplatible with the kodi version
if i try to update it from the libreelec repo, i get an error dependencies cannot be satisfied
any hint?
thanks

This issue is reported in https://github.com/kodi-pvr/pvr.iptvsimple/issues/139

You can reinforce the fact you're being affected, but someone must to fix it.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,862
Joined: Feb 2011
Reputation: 326
Post: #2735
(2017-08-01 20:11)pqatsi Wrote:  This issue is reported in https://github.com/kodi-pvr/pvr.iptvsimple/issues/139

You can reinforce the fact you're being affected, but someone must to fix it.

I asked one of the kodi devs "you've PR-ed to iptv simple recently - do you know if it should work following PR:12550?"
and got response "not yet. but we're working on it."
find quote
pqatsi Offline
Junior Member
Posts: 7
Joined: Dec 2013
Reputation: 0
Post: #2736
(2017-08-01 20:35)popcornmix Wrote:  
(2017-08-01 20:11)pqatsi Wrote:  This issue is reported in https://github.com/kodi-pvr/pvr.iptvsimple/issues/139

You can reinforce the fact you're being affected, but someone must to fix it.

I asked one of the kodi devs "you've PR-ed to iptv simple recently - do you know if it should work following PR:12550?"
and got response "not yet. but we're working on it."

Really Nice! Thanks for reply!

Waiting anxiously for this commit.

An non-topic question: The procedure for VC-1 and mpeg2 licences still remounting /flash and changing manually config.txt or libreelec config entry may be developed some time? Also, there is some gain using these licences with these test builds?
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,862
Joined: Feb 2011
Reputation: 326
Post: #2737
(2017-08-01 20:38)pqatsi Wrote:  An non-topic question: The procedure for VC-1 and mpeg2 licences still remounting /flash and changing manually config.txt or libreelec config entry may be developed some time? Also, there is some gain using these licences with these test builds?

Yes, still the same procedure. Remount /flash and edit from Pi, or insert sdcard into windows (or mac/linux) PC and edit config.txt from there.

If you want to play 1080p MPEG-2 or VC-1 (e.g. HD live TV or raw BluRay rips) then you should get the licence.
If you don't play that sort of content then the licence isn't required.
find quote
pqatsi Offline
Junior Member
Posts: 7
Joined: Dec 2013
Reputation: 0
Post: #2738
(2017-08-01 22:08)popcornmix Wrote:  
(2017-08-01 20:38)pqatsi Wrote:  An non-topic question: The procedure for VC-1 and mpeg2 licences still remounting /flash and changing manually config.txt or libreelec config entry may be developed some time? Also, there is some gain using these licences with these test builds?

Yes, still the same procedure. Remount /flash and edit from Pi, or insert sdcard into windows (or mac/linux) PC and edit config.txt from there.

If you want to play 1080p MPEG-2 or VC-1 (e.g. HD live TV or raw BluRay rips) then you should get the licence.
If you don't play that sort of content then the licence isn't required.

And Kodi does use these decoders? Need some special decoders in Kodi to work (Like I see some issues with OMX, etc..)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2739
New LibreELEC.tv Leia build #0801: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.12.4 #1 Tue Aug 1 21:59:36 BST 2017 armv6l GNU/Linux

# vcgencmd version
Jul 28 2017 20:20:00
Copyright (c) 2012 Broadcom
version 6716e816fd1614c326071d86188976b5fbf9c22b (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20170801215819-#0801-geb93713 [Build #0801]

# Kodi version
(18.0-ALPHA1 Git:d0e3f71). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (eb937130, changelog) and tip of XBMC master (d0e3f716, changelog) with the following modifications: Build Highlights:
  1. pvr.demo: restored to build
  2. inputstream.adaptive: HLS updates
Build Details:
  1. XBMC:
    • [videoplayer] Fix CDVDFactoryInputStream::CreateInputStream fileitem (PR:12599, 1 commit, 1 file changed)
    • [VideoPlayer] Never skip the same commercial twice in a row (PR:12600, 1 commit, 3 files changed)
    • Fix silent failure when game add-on can't be installed (PR:11163, 1 commit, 2 files changed)
    • pass resume script param when launching addons (PR:12586, 1 commit, 7 files changed)
  2. inputstream.adaptive:
    • [HLS] First working video finished (f728d850)
    • [HLS] GetBuffer instead Read to avoid mem copies (c88b0af6)
    • [HLS] Included stream handling (556d2844)
    • [HLS] Seek fixed (5cfd9222)
    • [HLS] Seek / fix indexed streams sream position (a38c5c4e)
    • [HLS] changed IncludedStreams logic (again) (783643cf)
    • Don't build libssd for IOS (9954fd37)
    • Version bump (2.0.6) (e52d340f)
    • add License.gpl (625fc1b5)
    • [HLS] fill initialization segment for mp4 media (e01d9f77)
    • Disable optimization (select_stream) to make sure that initialization is read (7b3ca31f)
    • [HLS] allow URL's in segments / compile fix / compiler warnings (b1e66785)
  3. pvr.demo:
    • PVR API 5.4.0: Remove SwitchChannel, PVR_CHANNEL::strStreamURL. Imple (PR:50, 1 commit, 3 files changed)
  4. pvr.dvblink:
    • #92: returning empty string from GetLiveStreamURL (729fce75)
  5. newclock5:
    • New commits in this build:
      • DVDDemuxFFMPEG: Increase FFMPEG_FILE_BUFFER_SIZE to 128K (9a7beacc)
      • DVDDemuxFFmpeg: Use FFMPEG_FILE_BUFFER_SIZE for max_packet_size (2b54af3f)
      • fixup! rbp: Update the GL libs to new naming scheme (ef8b33d1)
      • PeripheralCecAdapter: Only stop playback if currently playing (01887992)
  6. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] PR:1848: kernel-firmware: cleanup

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2740
Weekly Linux 4.13-rc3 build #0801x: RPi / RPi2

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
find quote
polo_joe Online
Senior Member
Posts: 185
Joined: Aug 2012
Reputation: 1
Post: #2741
Why isn't neon enabled anymore?

17:41:10.259 T:1942629696 NOTICE: FFmpeg version/source: ffmpeg-3.3-kodi
17:41:10.259 T:1942629696 NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 4 cores available
17:41:10.259 T:1942629696 NOTICE: ARM Features: Neon disabled
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,862
Joined: Feb 2011
Reputation: 326
Post: #2742
(2017-08-02 12:04)polo_joe Wrote:  Why isn't neon enabled anymore?

17:41:10.259 T:1942629696 NOTICE: FFmpeg version/source: ffmpeg-3.3-kodi
17:41:10.259 T:1942629696 NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 4 cores available
17:41:10.259 T:1942629696 NOTICE: ARM Features: Neon disabled

Do you know which build this stopped? You are correct "Neon enabled" was reported in the past.
find quote
popcornmix Offline
Team-Kodi Member
Posts: 7,862
Joined: Feb 2011
Reputation: 326
Post: #2743
(2017-08-01 22:12)pqatsi Wrote:  And Kodi does use these decoders? Need some special decoders in Kodi to work (Like I see some issues with OMX, etc..)

Yes, of course. Both MMAL and OMXPlayer will use the hardware decoders when enabled.
find quote
polo_joe Online
Senior Member
Posts: 185
Joined: Aug 2012
Reputation: 1
Post: #2744
(2017-08-02 12:45)popcornmix Wrote:  
(2017-08-02 12:04)polo_joe Wrote:  Why isn't neon enabled anymore?

17:41:10.259 T:1942629696 NOTICE: FFmpeg version/source: ffmpeg-3.3-kodi
17:41:10.259 T:1942629696 NOTICE: Host CPU: ARMv7 Processor rev 4 (v7l), 4 cores available
17:41:10.259 T:1942629696 NOTICE: ARM Features: Neon disabled

Do you know which build this stopped? You are correct "Neon enabled" was reported in the past.

Not exactly, I searched for uploaded logs in this thread. I found out that the change happened between build 0521 and build 0603.
not working https://pastebin.com/qCv02qfa post #1945
working https://pastebin.com/e9a9cTaS post # 1816

Maybe this one https://github.com/popcornmix/xbmc/commi...c246274479
(This post was last modified: 2017-08-02 13:49 by polo_joe.)
find quote
Milhouse Offline
Team-Kodi Member
Posts: 12,877
Joined: Jan 2011
Reputation: 642
Post: #2745
Thanks, yes, NEON has been disabled since #0525(2). Sad

(Unfortunately I cocked up the build code of the 0524 build which I accidentally published as 0525, however I'll refer to this as #0524, and #0525 is the #0525 proper)

So NEON is enabled in #0524.

And NEON is disabled in #0525

There's no obvious change in #0525, but if you look at the list of included PRs in the first section (above "Build highlights") you'll see there's:
(2017-05-25 23:43)Milhouse Wrote:  Based on tip of LibreELEC.tv master (856d6246, changelog) and tip of XBMC master (feb2cda8, changelog) with the following modifications:
  • Include [pkg] PR:12034: KODI: Update NEON support

PR12034 is also included in #0524, however it changed between #0524 and #0525, which seems to have introduced the problem causing NEON to be disabled.

This is PR12034 on gist: https://gist.github.com/MilhouseVH/e13f2...4a6d979e6c

If you click on the "Revisions" tab you can see the changes introduced between #0525 and #0524 (revision #2). Revision #1 is the original version in #0524.

The version of the PR in #0525 now requires "-DENABLE_NEON=ON|OFF" when building Kodi, which wasn't necessary with the version in #0524.

I'm not sure if this new requirement is intentional, but I'll include the fix in the next build.

Edit: Pretty sure this is just cosmetic and only affects the way NEON is being reported

Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(This post was last modified: 2017-08-02 19:53 by Milhouse.)
find quote
Post Reply