•   
  • 1
  • 405
  • 406
  • 407(current)
  • 408
  • 409
  • 415
  •   
v18 -  LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)
(2018-08-03, 23:59)TDown Wrote: I started a new thread with the below but I figure it should be posted here.  This issue is definitely specific to V18:

I have witnessed a black screen flickering across multiple v18 Nightlies on a RPi 3B+.  I have since returned to v17 without this issue.

The issue only appears to happen with Standard Definition channels (480i).

http://ix.io/1fNI
http://www.filehosting.org/file/details/...licker.zip

The above are uploaded logs as well as a short clip recorded through Kodi/NPVR (I apologize for the randomly located hosting service).  The TS file when played through v18 flickers the same as watching a live channel.  Flickering does not exist when TS file is watched on PC.

Can you determine which of these v18 test builds is the first with this issue? You'll be limited to builds after mid March (when the Pi3B+ launched).
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
Update from #731 to #803, IR remote not work.
Reply
(2018-08-04, 11:47)TVPL Wrote: Update from #731 to #803, IR remote not work.

Please test builds 0801 and 0802 and report back if it works on these builds.

My guess is the v4l-utils bump (as part of the glibc bump) in 0802 could have caused a regression.

so long,

Hias
Reply
(2018-08-04, 12:57)HiassofT Wrote:
(2018-08-04, 11:47)TVPL Wrote: Update from #731 to #803, IR remote not work.

Please test builds 0801 and 0802 and report back if it works on these builds.

My guess is the v4l-utils bump (as part of the glibc bump) in 0802 could have caused a regression.

so long,

Hias

Yes: #801 work, #802 - #803 not work.
Reply
(2018-08-04, 14:07)TVPL Wrote: Yes: #801 work, #802 - #803 not work.

What kind of IR are you using? GPIO? USB dongle? Make/model/brand?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-04, 14:54)Milhouse Wrote:
(2018-08-04, 14:07)TVPL Wrote: Yes: #801 work, #802 - #803 not work.

What kind of IR are you using? GPIO? USB dongle? Make/model/brand?
GPIO & DIY Smile
Reply
Hi,
I'm probably in the wrong forum section, and if so, then please move it. Thanks.

My problem, in 8.90.003 for RPi 3, if I have a strm file in the Videos folder (the strm file will play there), and I save it to Favourites,  the link in Favourites will not play. The error message is like this "ERROR: GetDirectory - Error getting /storage/videos/Barock.strm". This is an internet audio radio station, but the same error message shows for live stream (local news) strm files. None of my Favourites strm links will play. The Favourites entry looks like this "<favourite name="Barock" thumb="/storage/pictures/baroque.jpg">PlayMedia(&quot;/storage/videos/Barock.strm&quotWink</favourite>". The /storage/videos Barock strm file looks like this.."http://stream.klassikradio.de/barock/aac-64/radiosure/". It's a Classical music station.

Any help on this will be appreciated.

Regards,
Bob
Reply
(2018-08-04, 00:11)Milhouse Wrote:
(2018-08-03, 23:59)TDown Wrote: I started a new thread with the below but I figure it should be posted here.  This issue is definitely specific to V18:

I have witnessed a black screen flickering across multiple v18 Nightlies on a RPi 3B+.  I have since returned to v17 without this issue.

The issue only appears to happen with Standard Definition channels (480i).

http://ix.io/1fNI
http://www.filehosting.org/file/details/...licker.zip

The above are uploaded logs as well as a short clip recorded through Kodi/NPVR (I apologize for the randomly located hosting service).  The TS file when played through v18 flickers the same as watching a live channel.  Flickering does not exist when TS file is watched on PC.

Can you determine which of these v18 test builds is the first with this issue? You'll be limited to builds after mid March (when the Pi3B+ launched). 
 https://forum.kodi.tv/showthread.php?tid...pid2756385

Based on the above, would jumping between Nightlie versions determine where ffmpeg2video-mmal was updated versus the version in 8.2.5?
Reply
New LibreELEC.tv Leia build #0804: RPi / RPi2
(Supercedes previous build)

SHA256 Checksum: f692383dd90b13064326412c388a41766f0b51dd3263b58e75ff2f1b84fbeca3 (RPi)
SHA256 Checksum: 667205bdc6b9bcf7edcc0f00f06f7c3b34e56427feb556a6f6ffa25d72386f1a (RPi2)

# uname -a
Linux rpi512 4.14.59 #1 Sat Aug 4 21:37:39 BST 2018 armv6l GNU/Linux

# vcgencmd version
Jul 26 2018 13:29:32
Copyright © 2012 Broadcom
version 3d2fdb1dbb8700520f36a513effc130d4160ff62 (clean) (release)

# lsb_release
LibreELEC (Milhouse): devel-20180804213547-#0804-gec66cab [Build #0804]

# Kodi version
(18.0-BETA1 Git:269a24c). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (ec66cab, changelog) and tip of XBMC master (d0da4e4, changelog) with the following modifications: Build Highlights:
  1. Revert v4l-utils update (back to 1.14.1) - @TVPL please test and confirm if this helps
  2. enable dynamic configuration of netconsole at runtime
Build Details:
  1. XBMC:
    • [cleanup] combine LibInputPointer log lines into a single one (PR:14258, 1 commit, 1 file changed)
    • Small cleanup/improvements (PR:14263, 4 commits, 6 files changed)
  2. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] PR:2862 (perma): glibc: update to glibc-2.28
    • Added: [env] PR:2865 (perma): pulseaudio: silence some warnings
    • Added: [env] PR:2866 (perma): samba: make services depend on network-online.target
    • Added: [env] PR:2867 (perma): enable dynamic configuration of netconsole at runtime
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-04, 15:09)TVPL Wrote:
(2018-08-04, 14:54)Milhouse Wrote:
(2018-08-04, 14:07)TVPL Wrote: Yes: #801 work, #802 - #803 not work.

What kind of IR are you using? GPIO? USB dongle? Make/model/brand?
GPIO & DIY Smile

Can you try #0804 and see if that is any better, thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
(2018-08-05, 01:52)TDown Wrote:  https://forum.kodi.tv/showthread.php?tid...pid2756385

Based on the above, would jumping between Nightlie versions determine where ffmpeg2video-mmal was updated versus the version in 8.2.5?

If you're sure you have no problem with 8.2.5 and RPi3+ without the MPEG codec licence, then identifying the regression in these test builds would be useful.

Or post a sample video (5 minutes) that can hopefully be used to reproduce the problem.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Reply
@Milhouse: #804 IR GPIO work again, tks.
Reply
(2018-08-05, 03:10)Milhouse Wrote:
(2018-08-05, 01:52)TDown Wrote:  https://forum.kodi.tv/showthread.php?tid...pid2756385

Based on the above, would jumping between Nightlie versions determine where ffmpeg2video-mmal was updated versus the version in 8.2.5?

If you're sure you have no problem with 8.2.5 and RPi3+ without the MPEG codec licence, then identifying the regression in these test builds would be useful.

Or post a sample video (5 minutes) that can hopefully be used to reproduce the problem. 
I've added an mpg2 license and confirmed that the problem is no longer present as hw oxm-mpeg2 is decoding.

This problem is definitely not present in 8.2.5.

I'll work on getting a test clip and downgrading to see if I can find where things broke.
Reply
(2018-08-05, 08:42)TVPL Wrote: @Milhouse: #804 IR GPIO work again, tks.
Thanks for reporting back!

Could you please also post some more details about IR config (your keytable and rc_maps.cfg files), then I'll have a look what went wrong with the v4l-utils bump.

so long,

Hias
Reply
Hello, 

@Milhouse About IR issues on #803,  I have RPI2 B with #803 with an DIY IR on GPIO working without any issues, I have 2 custom remotes merged on  one rc-keymaps files

this is my flash config file

dtoverlay=gpio-ir:gpio_pin=17
dtoverlay=gpio-ir-tx,gpio_pin=18

check these outputs
LibreELEC:~ # ir-keytable
Found /sys/class/rc/rc1/ (/dev/input/event0) with:
        Driver: gpio-rc-recv, table: rc-rc6-mce
        lirc device: /dev/lirc1
        Supported protocols: lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp
        Enabled protocols: lirc sony nec
        Name: gpio_ir_recv
        bus: 25, vendor/product: 0001:0001, version: 0x0100
        Repeat delay = 500 ms, repeat period = 125 ms
LibreELEC:~ # ir-ctl -d /dev/lirc0 --features
Receive features /dev/lirc0:
 - Device cannot receive
Send features /dev/lirc0:
 - Device can send raw IR
 - Set carrier
 - Set duty cycle
LibreELEC:~ # ir-ctl -d /dev/lirc1 --features
Receive features /dev/lirc1:
 - Device can receive raw IR
 - Can set receiving timeout min:1 microseconds max:1250000 microseconds
Send features /dev/lirc1:
 - Device cannot send
LibreELEC:~ #


I can send and receive IR...no issues at all, hope this can help for future releases
Reply
  •   
  • 1
  • 405
  • 406
  • 407(current)
  • 408
  • 409
  • 415
  •   
 
Thread Rating:
  • 19 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 18.0)4.5819