Windows - Mimic Issue with Channel Delay

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Bug  Mimic Issue with Channel Delay
Post: #1
Dear,

I'm so glad to use mimic but If (Settings)-(TV)-(Playback)-Delay channel Switch parameter is > 0ms
No info are showed during the channel zapping
It doesn't occur at all with Estuary skin
MimiC Issue with Delay

Attached log ,
the 2 channels zap are with channel swtich = 250ms
you can see no Window Init (DialogSeekBar.xml)
and the next 2 channels zap are with channel switch = 0ms
Any idea ?

regards
JP

ps:this occur on every platform win/osx/amm/libreelec /OE
(This post was last modified: 2017-05-10 09:30 by jpeg73.)
find quote
braz Offline
Skilled Skinner
Posts: 3,253
Joined: Aug 2012
Reputation: 100
Post: #2
No idea, I'm not at all familiar with that setting. I'll take a look when I get some free time.

What do you mean by zapping, channel changing?
(This post was last modified: 2017-05-10 15:59 by braz.)
find quote
braz Offline
Skilled Skinner
Posts: 3,253
Joined: Aug 2012
Reputation: 100
Post: #3
Took a look at your log, you've got a lot of video decoding errors that are not skin related. And it's not a complete log, what version of Kodi are you running?
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #4
Hi , I'm using the lastest kodi 17.1 on win10.
The main issue Ive is because I'm using a docking station with my laptop and my audio is switching between internal & external
Did I have regenerate a clean log ?
Thanks for your help
JP
(This post was last modified: 2017-05-11 15:00 by jpeg73.)
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #5
Hi ,
Here is an complete log with audio fix

https://pastebin.com/XsM1Vv5a

Scenaerio is the same
Two first channel swtich with parameter >0ms ( no DialogSeekBar.xml)
the next 2 channel switch with parameter = 0ms ( (DialogSeekBar.xml exists)

this issue is reproductible on each platform WIN10, OSX10, LE (imx6 or Ammlogic) , OE( intel )

thanks
JP
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #6
Hi ,
Is somebody has some idea / guidance :-(
thanks
JP
find quote
braz Offline
Skilled Skinner
Posts: 3,253
Joined: Aug 2012
Reputation: 100
Post: #7
It's probably something to do with the visibility condition in the seekbar XML, haven't had a chance to look yet.
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #8
Hi ,
I try to understand but really I din't catch why when channel swtich parameter >0 the DialogSeekBar.xml isn't called by Kodi
For other skin, it is proporely called
I'm a bit lost :-(
THX
JP
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #9
Hi ,
I try with Omni skin -> same behaviour than Mimic
but not present with Estuary
I continue to be lost .. .any idea?
thanks in advance
JP
find quote
braz Offline
Skilled Skinner
Posts: 3,253
Joined: Aug 2012
Reputation: 100
Post: #10
I'll look into this when I have time, but have to admit this is low priority for me. Working on updating the skins for Kodi 18. And NextPVR isn't working with Kodi 18 yet it appears, so haven't been able to test.
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #11
No problem , I can understand
Ive some basis, but I don't know where to search .. .then if you can just advice few points to search
I'll try to help you
Thanks in advance
JP
find quote
braz Offline
Skilled Skinner
Posts: 3,253
Joined: Aug 2012
Reputation: 100
Post: #12
First thing I would do is compare the visibility conditions at the top of DialogSeekbar.xml with the ones in Estuary.
find quote
jpeg73 Offline
Junior Member
Posts: 11
Joined: Jan 2015
Reputation: 0
Post: #13
Well if I replace <visible>[Window.IsActive(videoosd) | Player.Paused | Player.Seeking | Player.DisplayAfterSeek | Player.Forwarding | Player.Rewinding] + VideoPlayer.IsFullscreen + ![Window.IsVisible(fullscreeninfo) | Window.IsVisible(musicosd) | Window.IsVisible(OSDVideoSettings) | Window.IsVisible(OSDAudioSettings) | Window.IsVisible(PVROSDGuide) | Window.IsVisible(PVROSDTeletext) | Window.IsVisible(PVROSDChannels) | Window.IsVisible(subtitlesearch) | Window.IsVisible(videobookmarks) | Window.IsActive(script.pseudotv.TVOverlay.xml) | Window.IsActive(script.pseudotv.live.TVOverlay.xml)]</visible>

By

<visible>Player.Seeking | Player.DisplayAfterSeek | [Player.Paused + !Player.Caching] | Player.Forwarding | Player.Rewinding | Player.ShowInfo | Window.IsActive(fullscreeninfo) | Window.IsActive(videoosd) | Window.IsActive(musicosd) | Window.IsActive(playerprocessinfo) | !IsEmpty(Player.SeekNumeric)</visible>


it works perfectly ! Thanks a lot Big Grin
find quote