TMDB scraper failures for previously working movies

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
boh73 Offline
Junior Member
Posts: 5
Joined: Jun 2017
Reputation: 0
Post: #16
Now, with v3.9.4, all movies was scraped.
But hat to download new version by zip and install it manual.

Thank you all for the very quick help :-)
find quote
Karellen Offline
Super Moderator
Posts: 2,496
Joined: Apr 2017
Reputation: 45
Post: #17
Glad it worked.

Yes, I had to download mine as a zip as well. I suppose it takes time to push the update out.

My Signature
Links to : Forum Rules | Banned Add-Ons | Free Movies/TV Shows | Debug Log |


find quote
Traseus Offline
Junior Member
Posts: 2
Joined: Jun 2017
Reputation: 0
Post: #18
For me, it dosent work with the zip. If I try so, the Update failed!

What can I do?
find quote
piflintstone Offline
Junior Member
Posts: 6
Joined: Jan 2015
Reputation: 0
Post: #19
Still not working with Universal Movie Scraper although it was updated aswell (2.8.2.). I updated manually, although more movies were scraped now than before, still not all are scraped. IMDB works....
find quote
crysdevbec Offline
Junior Member
Posts: 4
Joined: Jan 2016
Reputation: 0
Post: #20
I had the same results as piflintstone. I updated both scrapers yesterday. The TMDB scraper now works. The Universal scraper (when configured for TMDB) still does not, reporting back in the debug log that information is not found for movie.
find quote
mchp92 Offline
Senior Member
Posts: 214
Joined: Apr 2017
Reputation: 3
Post: #21
Side Q
Where ia kodi.log kept?


Sent from my iPhone (typie typie)
find quote
olympia Offline
Team-Kodi Member
Posts: 2,718
Joined: May 2008
Reputation: 39
Post: #22
(2017-06-06 20:40)crysdevbec Wrote:  I had the same results as piflintstone. I updated both scrapers yesterday. The TMDB scraper now works. The Universal scraper (when configured for TMDB) still does not, reporting back in the debug log that information is not found for movie.

Very poor report without any log file or at least an example movie where it won't work.
...anyhow, I figured out and fixed in v2.8.3
find quote
nickr Offline
Team-Kodi Member
Posts: 18,703
Joined: May 2009
Reputation: 387
Location: Christchurch NZ
Post: #23
(2017-06-06 20:44)mchp92 Wrote:  Side Q
Where ia kodi.log kept?


Sent from my iPhone (typie typie)
For future reference debug log (wiki)

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
mchp92 Offline
Senior Member
Posts: 214
Joined: Apr 2017
Reputation: 3
Post: #24
Thanks but the link does not show. It reads as debug log (wiki) and is not clickable


Sent from my iPhone (typie typie)
find quote
piflintstone Offline
Junior Member
Posts: 6
Joined: Jan 2015
Reputation: 0
Post: #25
(2017-06-06 22:21)olympia Wrote:  
(2017-06-06 20:40)crysdevbec Wrote:  I had the same results as piflintstone. I updated both scrapers yesterday. The TMDB scraper now works. The Universal scraper (when configured for TMDB) still does not, reporting back in the debug log that information is not found for movie.

Very poor report without any log file or at least an example movie where it won't work.
...anyhow, I figured out and fixed in v2.8.3

Thanks,

however it still isn't working reliably. The issue is that it won't show all movies that fit a name. Movies like "The Island" (2005 with Scarlett Johansson) it does not work. If I use tmdb search with Universal Movie Scraper it will list several Movies called "the island " but by far not all and sadly not the proper one.
It seems as if some results are skipped.
This was one of 5 movies I added today with "The Island" not being recognized.
If I switch search to IMDB things will work and data from TMDB will be scraped.
find quote
olympia Offline
Team-Kodi Member
Posts: 2,718
Joined: May 2008
Reputation: 39
Post: #26
but then it doesn't work with tmdb scraper either... I will need to have a look.

Probably none of you guys are realizing how substantial API change has been handled in no time on the fly what could have a huge impact on user experience for the entire userbase, while most of the users haven't even realized there was a problem...

edit: ...and the island 2005 works for me, so please do me a favor and post a debug log (and check if you are really using v2.8.3)
(This post was last modified: 2017-06-07 18:08 by olympia.)
find quote
unsanctified Offline
Junior Member
Posts: 2
Joined: Jun 2017
Reputation: 0
Post: #27
Upgrading the TMDB scraper worked for me, however the Universal Movie Scraper still is not. I'm currently using version 2.8.2 in Jarvis 16.1-RC3 but have not seen an update in the repo yet to 2.8.3. I hope that it will be available soon and will fix the problem.

TMDB changing their API on the fly is not very good and can cause a lot of problems to any application using it, I totally understand olympia. Generally a company will use versioning in their API to avoid these kinds of issues... ie: http://company.com/api/function , http://company.com/api/V2/function etc... this way their business partners can plan for the change and use the updated API in their new app versions. Too bad that didn't happen here...
find quote
unsanctified Offline
Junior Member
Posts: 2
Joined: Jun 2017
Reputation: 0
Post: #28
I got home from work and was auto updated to Universal Movie Scraper v.2.8.3 and now it works fine. Thanks for your quick help olympia.
find quote
nickr Offline
Team-Kodi Member
Posts: 18,703
Joined: May 2009
Reputation: 387
Location: Christchurch NZ
Post: #29
(2017-06-07 07:29)mchp92 Wrote:  Thanks but the link does not show. It reads as debug log (wiki) and is not clickable


Sent from my iPhone (typie typie)

That seems to be a current tapatalk error (by the way please turn off your tapatalk sig).

Anyway, it is supposed to create a link to the page Debug Log in the wiki - go to the wiki and you will find it.

If I have helped you or increased your knowledge, click the 'thank user' button to give thanks :) (People with less than 20 posts won't see the "Thank you" button.)
find quote
mchp92 Offline
Senior Member
Posts: 214
Joined: Apr 2017
Reputation: 3
Post: #30
Ok will have a look there
As for sig: turned it off cpl times but seems tapatalk decides to put it back to on sometimes Undecided
find quote