Schedules Direct for Tvheadend addon
#61
It's possible that tvheadend is not matching the name of the service to what is listed in the xmltv.xml file.  Here is the json info for channel 62:

Code:
      "stationID": "18774",
      "name": "ION Television Satellite Feed",
      "callsign": "IONSAT",
      "affiliate": "ION",

If you log into the webui for tveadend - see what name is listed under the CONFIGURATION > CHANNEL/EPG tab for channel 62.  You can also see what the epg source is and manually connect it to the correct guide data.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
#62
(2019-04-16, 14:52)cerk Wrote:
(2019-04-16, 02:10)edit4ever Wrote: OK - I think I solved adding the location info for the lineups.  Give this new release a try and make sure you get the correct channels:

https://github.com/edit4ever/script.modu...tag/v0.3.0

Thanks!

Thanks for looking at this issue so quickly!

It looks like it is working for adding a lineup. I decided to add a second lineup (one of the Charter Spectrum lineups - Greenville) and delete that lineup. I believe the remove lineup command did not work properly (I believe I selected the Greenville lineup to delete but the Asheville lineup was deleted instead). It could have been user error though. I will test tomorrow - I think SchedulesDirect limits the amount of lineup changes you can do per day. 
I confirmed today that there is an issue with deleting the correct lineup. For example, I added Burnsville and Greenville along with my Asheville lineup. Then I deleted Burnsville (that worked) and then deleted Greenville but it deleted the Asheville entry instead. Don't worry about it though - I'll look at the code when I have the time.
Reply
#63
(2019-04-16, 17:38)edit4ever Wrote: It's possible that tvheadend is not matching the name of the service to what is listed in the xmltv.xml file.  Here is the json info for channel 62:

Code:
      "stationID": "18774",
      "name": "ION Television Satellite Feed",
      "callsign": "IONSAT",
      "affiliate": "ION",

If you log into the webui for tveadend - see what name is listed under the CONFIGURATION > CHANNEL/EPG tab for channel 62.  You can also see what the epg source is and manually connect it to the correct guide data.
The channel number in tvheadend is 62 but in the xml file it is 062. Maybe that is the reason why I'm having this issue. In the meantime, I will manually fix that channel. Thanks again!
Reply
#64
I can see where the issue is in the deleted section...I'll should be able to fix that.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
#65
Got it - forgot to update the remove lineups section with the new name - location structure.  Here you go:

https://github.com/edit4ever/script.modu...tag/v0.3.1

Thanks!
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
#66
(2019-04-17, 16:14)edit4ever Wrote: Got it - forgot to update the remove lineups section with the new name - location structure.  Here you go:

https://github.com/edit4ever/script.modu...tag/v0.3.1

Thanks!
It works! Thank you!
Reply
#67
(2019-04-17, 15:17)cerk Wrote:
(2019-04-16, 17:38)edit4ever Wrote: It's possible that tvheadend is not matching the name of the service to what is listed in the xmltv.xml file.  Here is the json info for channel 62:

Code:
      "stationID": "18774",
      "name": "ION Television Satellite Feed",
      "callsign": "IONSAT",
      "affiliate": "ION",

If you log into the webui for tveadend - see what name is listed under the CONFIGURATION > CHANNEL/EPG tab for channel 62.  You can also see what the epg source is and manually connect it to the correct guide data.
The channel number in tvheadend is 62 but in the xml file it is 062. Maybe that is the reason why I'm having this issue. In the meantime, I will manually fix that channel. Thanks again!  
So I tried manually correcting channel 62, but there is no channel 62 in the Configuration --> Channel / EPG --> EPG Grabber Channels tab. So when I try to manually assign an EPG source in the Configuration --> Channel / EPG --> Channels tab, channel 62 is not an option.

I looked at the actual xmltv file that is generated and the first channel it shows is a channel above 100. There is no mention of channel 62. So somehow that channel is being filtered out during the xmltv file creation. My gut instinct is that it has something to do with the fact that the channel only has 2 digits in it while the rest of the channels have 3. I'll keep looking.
Reply
#68
I assume you are using an HDhomerun as you are loading a cable lineup?  If so - can you take a look in the userdata folder and check the filter.cfg file and see if channel 62 is listed there and if so in which sectionHuh

This could be an issue with the hdhomerun channel lineup that is being sent to sd4tvh or an issue with the way sd4tvh is filtering that lineup.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
#69
Also - go ahead and check the output of your hdhomerun by accessing http://YOUR.HDHOMERUN.IP/lineup.json

See if the channel is listed there as well.
Current Kodi addon projects: zap2epg, sd4tvh and tvh2kodi (tvh config from inside Kodi)
Testing ATSC single and dual tuners on RPi3 and the occasional s905 box
If you like my work you can buy me a coffee!
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Schedules Direct for Tvheadend addon51