•   
  • 1
  • 8
  • 9
  • 10
  • 11
  • 12(current)
Release script.colorbox
(2018-01-26, 02:55)Edworld Wrote:
(2018-01-25, 19:23)badaas Wrote: 2.0.7 quick bugfix (beta) [leave ' intact]

https://github.com/BADMS/script.colorbox
It works.

Badaas,

I have horizon installed and it blurs every poster regardless of , or ' (installed colorbox repo) including planes, trains and automobiles.

Could it be possible that your "daemon" version of the script treats , '  correctly and the runscript version (RunScript(script.colorbox,info=blur,id=PICTURE_NAME,prefix=mypic1,blursize=1,quality=8)) doesn't?   
 Must be, I have kind of left that RunScript tacked on and didn't even know it still worked Wink
Will have a look to see what is what.. thanks for help.


Edit:
Ahhhhhhhhh, it's because you pass the filename via XML, the name would need encapsualting in quotes to stop it using the ',' in filenames and list delimiter, hence it cuts off at first ','.
So in XML it would be id='"FIENAME"', the ' escapes the quote. Hence the stripping of them chars previously (now removed).

Umm, would need some coding to work both ways. Stick to daemon for now until I (or you) figure a fix to escape the chars for RunScript.
I can'r remember if possible to escape " without using ' in XML ..

Maybe:

Code:
RunScript(script.colorbox,info=blur,id=$ESCINFO[PICTURE_NAME],prefix=mypic1,blursize=1,quality=8)
Reply
(2018-01-26, 13:58)badaas Wrote: Edit:
Ahhhhhhhhh, it's because you pass the filename via XML, the name would need encapsualting in quotes to stop it using the ',' in filenames and list delimiter, hence it cuts off at first ','.
So in XML it would be id='"FIENAME"', the ' escapes the quote. Hence the stripping of them chars previously (now removed).

Umm, would need some coding to work both ways. Stick to daemon for now until I (or you) figure a fix to escape the chars for RunScript.
I can'r remember if possible to escape " without using ' in XML ..

Maybe:
Code:
RunScript(script.colorbox,info=blur,id=$ESCINFO[PICTURE_NAME],prefix=mypic1,blursize=1,quality=8)
Thanks for looking into this. I haven't been successful in implementing the daemon version of the script, but will continue to try
Reply
@badaas 

I want to see how expensive this script is but I'm totally confused with all those NINE SEVEN ect. And I'm also not sure if all this posts here in the thread are still valid Smile You really should create a small readme.

So, any assistance is welcome:
I have a $VAR that includes the background items that should be used.
What exactly do I have to do to get the values of this $VAR blurred and which prop do I have to use?


( @jurialmunkey I guess you can also help me )


Edit:
Just stole some code of phil65 and added this feature to my Embuary helper to have more control about these stuff and what is going to happen if it's enabled for my skin. 
Thanks for your great work and addon, but a small readme/howto would still be useful Wink It's a pita to crawl the codes of skins that have it implemented.
Embuary | Skin | Helper | Info | Repo | GitHub
Reply
Hello,

on windows it works now great but under libreelec and android the ImageColorSEVEN is empy and always FFffffff. The Blur works unter linux and android.

its the same code how under windows, but dont works.
has someone a idea?
Reply
can nobody help?
Reply
Baddass, please help

Hi Trying to keep Backgrounds Blurry using your colorbox option on all views bar the Home Screen.

Id this possibel ?

Using the Aura Skin 

I took out the line <onunload condition="System.HasAddon(script.colorbox)">SetProperty(NINE_manual_set,"var=main,set=$INFO[Skin.String(colorbox_main)]|var=comp,set=$INFO[Skin.String(colorbox_comp)]|var=quality,set=$INFO[Skin.String(colorbox_quality)]|var=blursize,set=$INFO[Skin.String(colorbox_blursize)]|var=bitsize,set=$INFO[Skin.String(colorbox_bitsize)]|var=pixelsize,set=$INFO[Skin.String(colorbox_pixelsize)]|var=black,set=$INFO[Skin.String(colorbox_black)]|var=white,set=$INFO[Skin.String(colorbox_white)]|var=blend,set=$INFO[Skin.String(colorbox_blend)]|var=desat,set=$INFO[Skin.String(colorbox_desat)]",home)</onunload> 
 from SkinSettings.xml

..... and this looks good but as soon as You load another view and go back to home then home is then Blurry ??

Assume this is possible as you give the option to only blur Info Diogs 

Help
Reply
Hi, sorry no support. I will try find some time.
You can always find some skins I made here and copy code.
Reply
(2019-12-08, 13:30)badaas Wrote: Hi, sorry no support. I will try find some time.
You can always find some skins I made here and copy code.

Thanks 

After a big of digging around I altered these lines in Includes_Global.xml of AURA and now I dont get Blurry Backgrounds on HOME or "PRESSING UP" option

 <variable name="Global_Background_Image">
        <value condition="Skin.HasSetting(NoFanart)">$VAR[Global_Background_Image_NoFanart]</value>

        <!-- <value condition="!String.IsEmpty(Window(home).Property(ImageFilterFIVE)) + Skin.HasSetting(EnableBlur) + [!Skin.HasSetting(OnlyBlurInfo) | [Skin.HasSetting(OnlyBlurInfo) + [Window.IsVisible(DialogVideoInfo.xml) | Window.IsVisible(DialogMusicInfo.xml) | Window.IsVisible(DialogAddonInfo.xml) | Window.IsVisible(script-script.extendedinfo-DialogVideoInfo.xml) | Window.IsVisible(script-script.extendedinfo-DialogInfo.xml)]]] + !Control.HasFocus(9602)">$INFO[Window(home).Property(ImageFilterFIVE)]</value>-->

                <value condition="!Window.IsVisible(home) + !Control.HasFocus(9602)">$INFO[Window(home).Property(ImageFilterFIVE)]</value>

        <value>$VAR[Global_Background_Image_Var]</value>
    </variable>
Reply
  •   
  • 1
  • 8
  • 9
  • 10
  • 11
  • 12(current)



Logout Mark Read Team Forum Stats Members Help
script.colorbox1
This forum uses Lukasz Tkacz MyBB addons.