v17 -  Crash on start while updating channel and EPG information from MythTV backend
#1
Exclamation 
Kodi often crashes when updating channel and EPG information from MythTV backend. Kodi is on the same machine as the MythTV backend. Follow link with crash log for details. http://paste.ubuntu.com/25586209/

OS: Mythbuntu 16.04.3 LTS (linux)
FE: Kodi 17.4
BE: MythTV 29.0 (not 0.29; they are using a new version schema).

Does any one have an idea how to solve this issue?
Or should I file a bug on trac?
Or are there any users with similar issues?

Please help.

Thank you
Best regards
sjuk
Reply
#2
This is a known problem. Unfortunately, there is no fix available. For a currently unknown reason, your pvr database gets corrupted.
Reply
#3
I turned off notifications in settings>livetv>recordings and find that the number of crashes has drastically decreased. Ymmv
Reply
#4
(2017-09-21, 16:39)ksooo Wrote: This is a known problem. Unfortunately, there is no fix available. For a currently unknown reason, your pvr database gets corrupted.

Thank you for the impressive fast reply. Does this mean the pvr database of the pvr addon in Kodi gets corrupted?
(I wonder if I have to do something to prevent corrupting the mythtv-database.)

Perhaps I can give some more information to help solving the problem. For example I can install the dbg-packages, if this could help.
Is there anything I can do to help solving the issue?
Reply
#5
(2017-09-21, 16:53)disaacso Wrote: I turned off notifications in settings>livetv>recordings and find that the number of crashes has drastically decreased. Ymmv

Thanks. I will give it a try by disabling the notifications and let you know if it did improve the situation.
Reply
#6
I doubt that this is related, but if it helps...
Reply
#7
(2017-09-21, 16:58)sjuk Wrote:
(2017-09-21, 16:53)disaacso Wrote: I turned off notifications in settings>livetv>recordings and find that the number of crashes has drastically decreased. Ymmv

Thanks. I will give it a try by disabling the notifications and let you know if it did improve the situation.

(2017-09-21, 17:08)ksooo Wrote: I doubt that this is related, but if it helps...

I've tried that, but without any markable success. Kodi crashed more than five times in a row after disabling the notifications.
But thanks for guessing.

@ ksoo: Is there anything I can do to help? Do you need more information? The issue is quite easy reproducible.
I'm an experienced linux user for years. With very little assistance I could give you more information.
But I don't know what information is needed to solve the problem. Would you please be so kind to give me a hint?
Or, should I file a bug on trac?

Thank you in advance...
Reply
#8
Has there been any resolved to Krypton rebooting many times on startup with MythTV PVR?  Or is it just time to downgrade to 16?

Actually using Libreelec but think this is a Kodi issue
Reply
#9
@sjuk please give Kodi 18 nightly a try and report back. There are good chances that the issue is fixed there.

@bbolin pleare do not hijack random threads for unrelated questions.
Reply
#10
How in the world is my question unrelated too "Kodi 17 - Crash on start while updating channel and EPG information from MythTV backend"

That is my question.  If it's a matter of trying 18.x will give it a try
Reply
#11
(2017-09-21, 16:39)ksooo Wrote: This is a known problem. Unfortunately, there is no fix available. For a currently unknown reason, your pvr database gets corrupted.
 The issue is that the dvr database loading isn't "multithread" safe. It's a Known Issue and I believe being worked on for Leia (see https://github.com/xbmc/xbmc/pull/12906).

For now, the best workaround is to turn off "guide caching" in TV settings. 

Settings -> PVR & Live TV -> Guide -> Don't Cache in Local Database.

Kodi will take significantly longer to start up on first run, but after that it works fine.
Reply
#12
@ksooo
I also have such crashes on startup of kodi during loading EPG from the mediportal backend.
It's also quite often for me (50/50) after a cold start. After i delete the tv epg sqlite database, it always works.
So the assumption that the DB gets corrupted because of multithreading access is reasonable.

Here is a log of my crash: https://forum.kodi.tv/showthread.php?tid...pid2691884
I'll know @Martijn has stated in the thread above that there will be no fixes for v17,
but ill think this is a major bug in v17 and makes it half the boot/start ups unusable.
(the WAF is really low Angel  but i raised it a little bit and teached her to use the switch of the HTPC Wink )

So here is my question:
Any chance to get this multithreading fix (https://github.com/xbmc/xbmc/pull/12906) in kodi v17 with another bugfix realease?

I am here to help testing and i am sure other users will thank you all if this is fixed also for v17.

thx
pOpY
Reply
#13
(2018-02-16, 16:57)popy Wrote: @ksooo
I also have such crashes on startup of kodi during loading EPG from the mediportal backend.
It's also quite often for me (50/50) after a cold start. After i delete the tv epg sqlite database, it always works.
So the assumption that the DB gets corrupted because of multithreading access is reasonable.

Here is a log of my crash: https://forum.kodi.tv/showthread.php?tid...pid2691884
I'll know @Martijn has stated in the thread above that there will be no fixes for v17,
but ill think this is a major bug in v17 and makes it half the boot/start ups unusable.
(the WAF is really low Angel  but i raised it a little bit and teached her to use the switch of the HTPC Wink )

So here is my question:
Any chance to get this multithreading fix (https://github.com/xbmc/xbmc/pull/12906) in kodi v17 with another bugfix realease?

I am here to help testing and i am sure other users will thank you all if this is fixed also for v17.

thx
pOpY


Sorry, no more fixes for v17. I suggest to switch to a recent Kodi 18 nightly, although it's not even alpha it runs just fine for many people.

Or try the workaround suggested in previous post -> do not cache epg data locally.
Reply
#14
(2017-11-27, 16:39)thezencowsaysmu Wrote: [quote="ksooo" pid='2649566' dateline='1506004786']The issue is that the dvr database loading isn't "multithread" safe. It's a Known Issue and I believe being worked on for Leia (see https://github.com/xbmc/xbmc/pull/12906).

LOL. Thanks for pointing me to my own work. :-)

But yeah, should be fixed with v18.
Reply
#15
ok thx.
Will try the workaround.

pOpY
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Crash on start while updating channel and EPG information from MythTV backend00